Project

General

Profile

bug #7615

Registrations not searchable in the PhycoBank portal

Added by Wolf-Henning Kusber 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-dataportal
Target version:
Start date:
08/01/2018
Due date:
% Done:

100%

Severity:
major
Found in Version:
Tags:

Description

100002 Planothidium taeansa
100003 Planothidium naradoense

sind im Vaadin Editor über die Nummer suchbar
http://test.e-taxonomy.eu/cdmserver/phycobank_production/app/registration#!list/all

Diese Nummern sind über die Nummer nicht im Portal auffindbar:
http://test.e-taxonomy.eu/dataportal/preview/phycobank/cdm_dataportal/search/registration/?identifier=100008&taxon_name=&type_designation_status%5B%5D=0&op=%EF%80%82&form_build_id=form-8vOZJ9fVkVjiIEIf_pkbzdAPjcxfDpra_zeim6m0J4Y&form_id=cdm_dataportal_search_registration_form

(Es könnte noch bis zu 9 weitere Nummern betreffen, also kein generelles sondern ein spezielles Problem)

picture105-1.png View (20.7 KB) Andreas Kohlbecker, 08/02/2018 11:39 AM


Related issues

Copied to Edit - feature request #7621: registration search also covers typified names New 08/03/2018

Associated revisions

Revision bb177c82 (diff)
Added by Andreas Kohlbecker 5 months ago

fix #7615 cleaning registration search parameter 'taxonNameFilterPattern'

History

#1 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from New to In Progress
  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.2

This happens because the dataportal sends an empty querystring for the scientific name and the webservice is not ignoring empty strings.

#2 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 50

#3 Updated by Andreas Kohlbecker 5 months ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 50 to 0

ready for review.

#4 Updated by Wolf-Henning Kusber 5 months ago

  • Status changed from Resolved to In Progress
  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 0 to 50

ID-Suche = Perfekt, alle 10 Fälle, in denen keine Anzeige erfolgte, funktionieren jetzt über die ID-Suche

Was im Augenblick noch nicht im Portal funktioniert, ist die Namenssuche der oben genannten Namen.

Sorry, habs auf Progress zurückgestellt.

#5 Updated by Andreas Kohlbecker 5 months ago

  • File picture105-1.png View added
  • Status changed from In Progress to Feedback
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

The search behaves correctly. "Planothidium taeansa" is not found because there is no registration for the name "Planothidium taeansa" only for the Holotype:

To me this looks like incomplete data. Is this really a registration for a type designation only?

The intended behavior of the name search is to search for registrations where the registered name matched the query string. The typified names associated with the typedesignations are not covered by this search. Maybe we need to extend the search so that the typified names are also included? Maybe as optional search mode or should this be the default?

#6 Updated by Andreas Kohlbecker 5 months ago

data issue solved, name added to registration

#7 Updated by Andreas Kohlbecker 5 months ago

We definitely need to extend the search so that typified names are also covered by the search. ... new ticket: #7621

#8 Updated by Andreas Kohlbecker 5 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

#9 Updated by Andreas Kohlbecker 5 months ago

#10 Updated by Andreas Kohlbecker 5 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)