Project

General

Profile

bug #7230

bug #6545: [MASTER] Eclipse 4 bugs

Refresh in name editor does not work if using "reuse taxon" in Misapplied Name View (e4)

Added by Andreas Müller 11 months ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
01/31/2018
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

(but details view is refreshed - at least the upper part)


Related issues

Copied from Edit - bug #7117: Some bugs in Misapplied Name View after e4 migration Closed 12/06/2017

Associated revisions

Revision 7171015b (diff)
Added by Katja Luther 10 months ago

ref #7230: refresh of name editor and details view after changing taxon of misapplied name relationship

Revision eb6e490d (diff)
Added by Katja Luther 10 months ago

ref #7230: refresh of name editor and details view after changing taxon of misapplied name relationship

Revision 30c956e4 (diff)
Added by Katja Luther 10 months ago

smaller changes for updating editor when changing taxon in misapplied name relationship

Revision 57838f98 (diff)
Added by Katja Luther 9 months ago

ref #7230: refresh of name editor and details view after changing taxon of misapplied name relationship

History

#1 Updated by Andreas Müller 11 months ago

  • Description updated (diff)

#2 Updated by Andreas Müller 11 months ago

  • Copied from bug #7117: Some bugs in Misapplied Name View after e4 migration added

#3 Updated by Andreas Müller 10 months ago

  • Target version changed from Release 4.14 to Release 5.0

#4 Updated by Katja Luther 10 months ago

  • Status changed from New to In Progress

now the details view and name editor are updated, but there is still a bug in showing the taxonrelationship after the change. Closing the name editor and reopening solves the problem.

#5 Updated by Katja Luther 10 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

Katja Luther wrote:

now the details view and name editor are updated, but there is still a bug in showing the taxonrelationship after the change. Closing the name editor and reopening solves the problem.

I could not reproduce this problem, please have a look whether it appears again. The problem was that the details view showed the details view of the taxon, not of the relationship

#6 Updated by Katja Luther 10 months ago

  • % Done changed from 0 to 60

#7 Updated by Katja Luther 9 months ago

Katja Luther wrote:

now the details view and name editor are updated, but there is still a bug in showing the taxonrelationship after the change. Closing the name editor and reopening solves the problem.

this problem is solved, the taxonrelation has to be added explicitely to the new from taxon.

#8 Updated by Andreas Müller 8 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther

Seems to be fixed

#9 Updated by Andreas Müller 7 months ago

  • % Done changed from 60 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)