Project

General

Profile

bug #7227

New name bulk editor shows all menu entries

Added by Andreas Müller 11 months ago. Updated 6 months ago.

Status:
Worksforme
Priority:
Priority14
Category:
taxeditor
Target version:
Start date:
01/29/2018
Due date:
% Done:

40%

Severity:
normal
Found in Version:

Description

When opening the TaxEditor + connect to datasource, then open the name bulk editor and before running a first search the menu shows all types of entries that should not be there, such as "Change to Person" or "deduplicate" (does not exist for names yet) or "edit rights"

picture970-1.png View (15.3 KB) Andreas Müller, 01/29/2018 03:10 PM

name_editor_initial_context_menu.png View (25.4 KB) Patrick Plitzner, 03/23/2018 09:59 AM


Related issues

Copied to Edit - bug #7516: details view has to show empty page if bulk editor has no item selected New 06/26/2018

Associated revisions

Revision 3699c749 (diff)
Added by Katja Luther 10 months ago

ref #7227: check for empty selection for menu creation

Revision 1e91a49b (diff)
Added by Katja Luther 10 months ago

ref #7227:minor

Revision cdc15f8a (diff)
Added by Katja Luther 9 months ago

ref #7227: disable setMarker in bulkeditor if no entity is selected

Revision c416d097 (diff)
Added by Katja Luther 6 months ago

fix #7227: remove marker menu in bulkeditor when nothing is selected

History

#1 Updated by Andreas Müller 11 months ago

  • Target version changed from Unassigned CDM tickets to Release 4.13

The problem seems to appear also in other bulk editors (e.g. person/team) and not only after restarting the TaxEditor but also with ordinary newly opened bulk editors. But not always, so I wonder if it is always reproducable.

#2 Updated by Andreas Müller 11 months ago

  • Target version changed from Release 4.13 to Release 4.14

#3 Updated by Andreas Müller 10 months ago

  • Target version changed from Release 4.14 to Release 5.0

#4 Updated by Katja Luther 10 months ago

  • Status changed from New to In Progress
  • Priority changed from New to Priority14

this is fixed, except for setMarker and openIn

#5 Updated by Katja Luther 9 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Patrick Plitzner

please review

#6 Updated by Patrick Plitzner 9 months ago

I still see some menu items

#7 Updated by Katja Luther 7 months ago

  • Target version changed from Release 5.0 to Release 5.1

the last menu items come from a not emptied details view. we have to fix this.

#8 Updated by Katja Luther 6 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

create a new ticket for the correct handling of details view, if no entity is selected and close this ticket. (see #7516)

#9 Updated by Andreas Müller 6 months ago

  • Description updated (diff)

#10 Updated by Andreas Müller 6 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Do I understand correctly that the "Set marker" menu item appears due to #7516? If this is the case then we can close this ticket otherwise we still need to remove the "set marker" menu.

#11 Updated by Andreas Müller 6 months ago

  • % Done changed from 0 to 40

#12 Updated by Andreas Müller 6 months ago

  • Copied to bug #7516: details view has to show empty page if bulk editor has no item selected added

#13 Updated by Katja Luther 6 months ago

  • Status changed from Feedback to Worksforme
  • Assignee changed from Katja Luther to Andreas Müller

We can close this ticket because with the NatTable implementation this problem does not exist anymore.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)