Project

General

Profile

feature request #7119

feature request #7118: migrate selection dialogs

implement filter button for selection dialogs

Added by Katja Luther about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
12/06/2017
Due date:
% Done:

70%

Severity:
normal
Tags:

Description

analog to the filter in the old filterDialogs we need a button for this functionality


Related issues

Related to Edit - feature request #7142: Implement person and team filter for agent search dialog New 12/19/2017

Associated revisions

Revision e3252ce1 (diff)
Added by Katja Luther about 1 year ago

apply the filter in selection dialog after selecting the filter

Revision f48bafae (diff)
Added by Katja Luther 12 months ago

ref #7119: filter dialog should not remember selection when clicking cancel

Revision 4afd70fc (diff)
Added by Katja Luther 12 months ago

ref #7119: with empty selection the filter dialog could not be closed

History

#1 Updated by Katja Luther about 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

please review

#2 Updated by Andreas Müller 12 months ago

#3 Updated by Andreas Müller 12 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

The filter for areas does not yet correctly remember if "Country" is disabled. Next time when the filter is opened "Country" is again enabled.

#4 Updated by Andreas Müller 12 months ago

If the search string is still empty, after setting the filter ALL areas are loaded. This is unexpected behavior and should happen only if "*" is written in the search box.

#5 Updated by Andreas Müller 12 months ago

Cancel does not yet work in filter dialog. It works like ok instead.

#6 Updated by Andreas Müller 12 months ago

The filter dialog is still missing a title

#7 Updated by Andreas Müller 12 months ago

  • % Done changed from 0 to 70

#8 Updated by Andreas Müller 12 months ago

There is an issue if NO vocabulary is chosen in area search filter. See also https://dev.e-taxonomy.eu/redmine/issues/7121#note-4

Maybe we should not allow to choose none and disable OK button in this case. However, the issue needs to be handled correctly in cdmlib, too.

#9 Updated by Katja Luther 12 months ago

Andreas Müller wrote:

If the search string is still empty, after setting the filter ALL areas are loaded. This is unexpected behavior and should happen only if "*" is written in the search box.

this is fixed now.

#10 Updated by Katja Luther 12 months ago

Andreas Müller wrote:

The filter for areas does not yet correctly remember if "Country" is disabled. Next time when the filter is opened "Country" is again enabled.

I can't reproduce this problem.

#11 Updated by Katja Luther 12 months ago

Andreas Müller wrote:

Cancel does not yet work in filter dialog. It works like ok instead.

this is fixed

#12 Updated by Katja Luther 12 months ago

Andreas Müller wrote:

There is an issue if NO vocabulary is chosen in area search filter. See also https://dev.e-taxonomy.eu/redmine/issues/7121#note-4

Maybe we should not allow to choose none and disable OK button in this case. However, the issue needs to be handled correctly in cdmlib, too.

this is fixed in the editor, needs to be handled in cdmlib

#13 Updated by Katja Luther 7 months ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)