Project

General

Profile

Actions

bug #7047

closed

Vaadin UI and View scope beans are not always destroyed correctly

Added by Andreas Kohlbecker about 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

while examining problems related to the connection pool runnig out of available connections it turned out that Vaadin UI and View scope beans are not always destroyed correctly once the view or UI was no longer used.

One problem was caused by the LoginViewBean being in UIScope. This issue has been solved meanwhile with cdm-vaadin|157c9c3 but it seems as if some views and presenters are still never being disposed and garbage collected correctly. This can potentially cause the vaadin UIs to eat up all memory over long time.


Files

Vaadin-Bean-Destroy-Breakpoints.bkpt (10.3 KB) Vaadin-Bean-Destroy-Breakpoints.bkpt Andreas Kohlbecker, 01/23/2018 01:42 PM

Related issues

Related to EDIT - bug #6687: Multiple representations of the same entity merge problemClosedAndreas Kohlbecker

Actions
Related to EDIT - bug #7046: replace open session per view pattern by DTO strategyClosedAndreas Kohlbecker

Actions
Related to EDIT - bug #7036: correctly release vaadin view resources when the browser windows has been closedClosedAndreas Kohlbecker

Actions
Related to EDIT - bug #7742: vaadin view presenters not disposing ehcaches and object references in event bus which can cause memory leaksClosedAndreas Kohlbecker

Actions
Actions #1

Updated by Andreas Kohlbecker about 5 years ago

  • Related to bug #7036: correctly release vaadin view resources when the browser windows has been closed added
Actions #2

Updated by Andreas Kohlbecker about 5 years ago

  • Related to bug #6687: Multiple representations of the same entity merge problem added
Actions #3

Updated by Andreas Kohlbecker about 5 years ago

  • Related to bug #7046: replace open session per view pattern by DTO strategy added
Actions #4

Updated by Andreas Kohlbecker about 5 years ago

  • Related to deleted (bug #7036: correctly release vaadin view resources when the browser windows has been closed)
Actions #5

Updated by Andreas Kohlbecker about 5 years ago

  • Is duplicate of bug #7036: correctly release vaadin view resources when the browser windows has been closed added
Actions #6

Updated by Andreas Kohlbecker about 5 years ago

  • Is duplicate of deleted (bug #7036: correctly release vaadin view resources when the browser windows has been closed)
Actions #7

Updated by Andreas Kohlbecker about 5 years ago

  • Related to bug #7036: correctly release vaadin view resources when the browser windows has been closed added
Actions #9

Updated by Andreas Kohlbecker almost 5 years ago

  • Priority changed from New to Priority11
Actions #10

Updated by Andreas Kohlbecker over 4 years ago

  • Related to bug #7742: vaadin view presenters not disposing ehcaches and object references in event bus which can cause memory leaks added
Actions #11

Updated by Andreas Kohlbecker over 4 years ago

  • Description updated (diff)
  • Status changed from New to Feedback
  • Target version changed from Unassigned CDM tickets to Release 5.3

this should also be fixed now that #7742 is solved

Actions #12

Updated by Andreas Kohlbecker over 4 years ago

  • Status changed from Feedback to Resolved
Actions #13

Updated by Andreas Kohlbecker over 4 years ago

  • Target version changed from Release 5.3 to Release 5.4

The RegistrationWorkingsetPresenter, LoginPresenter and RegistationUI still are not destroyed correctly. At least RegistrationWorkingsetPresenter still seems to be registered to the view event bus.

Is this a session timeout issue?

Actions #14

Updated by Andreas Kohlbecker over 4 years ago

  • Status changed from Resolved to In Progress
Actions #15

Updated by Andreas Kohlbecker over 4 years ago

Andreas Kohlbecker wrote:

The RegistrationWorkingsetPresenter, LoginPresenter and RegistationUI still are not destroyed correctly. At least RegistrationWorkingsetPresenter still seems to be registered to the view event bus.

Is this a session timeout issue?

after ~1h the above mentioned beans have been destroyed with the VaadinSession

Actions #16

Updated by Andreas Kohlbecker over 4 years ago

  • Priority changed from Priority11 to Highest
Actions #17

Updated by Andreas Kohlbecker over 4 years ago

  • Target version changed from Release 5.4 to Release 5.5

this should be fixed mean while according to the examination made for #7824

I am leaving this issue open to be confirmed very soon.

Actions #18

Updated by Andreas Müller over 4 years ago

if you think it is fixed shouldn't we set it to resolved and keep in 5.4 milestone? So we remember it as being primarily a review ticket. If not fully fixed we can still move it to next version, if fixed we simply close it.

Actions #19

Updated by Andreas Kohlbecker over 4 years ago

  • Status changed from In Progress to Closed
  • Target version changed from Release 5.5 to Release 5.4
  • % Done changed from 0 to 100

this has been solved by the changes made for #7036

Actions

Also available in: Atom PDF