Project

General

Profile

bug #6283

Exceptions when editing polytomous key

Added by Katja Luther about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Priority14
Assignee:
Category:
cdmlib
Target version:
Start date:
12/15/2016
Due date:
% Done:

0%

Severity:
normal
Found in Version:

Description

Hallo Katja,

ich habe mich dieses Jahr doch noch an neuen Schlüsseln versucht. Bei Orchis gab es ein paar Fehlermeldungen, die ich aber stets durch Neusortieren des Schlüssels, abspeichern, schließen und wiederöffnen austricksen konnte. Natürlich funktionierte das ausgerechnet vor dem letzten Schlüsselpunkt nicht mehr. Jetzt bekomme ich Orchis gar nicht mehr geöffnet. Kannst Du bei Gelegenheit mal schauen und wiederbeleben? Ich würde den Rest dann dranheften.

Vielen Dank und schöne Grüße
Ralf

Associated revisions

Revision 99c779dd (diff)
Added by Katja Luther about 2 years ago

ref #6283: fix NPE exceptions caused by null values in children list

Revision d8cc12a4 (diff)
Added by Katja Luther about 2 years ago

ref #6283: minor changes to fix exceptions in polytomous key editing

Revision 6ed48b2e (diff)
Added by Patrick Plitzner almost 2 years ago

ref #6283 Fixed potential NPE for EntitySelectionElement

  • refactored constructors to always initialise the clazz variable

History

#1 Updated by Katja Luther about 2 years ago

There where still some NPE caused by null values in children list of polytomouskey nodes. And sometimes a ConcurrentModificationException appears.

#2 Updated by Katja Luther almost 2 years ago

  • Assignee changed from Katja Luther to Patrick Plitzner

I test it again and it works now. Please test, if there are NPE when editing the key.

#3 Updated by Katja Luther almost 2 years ago

  • Status changed from New to Resolved

#4 Updated by Patrick Plitzner almost 2 years ago

I am not really sure what to test here because I do not know how to reproduce the problem. I clicked around and added, edited and deleted some polytomous keys and only found one exception which I fixed with taxeditor|6ed48b2e205576b31d01ad6fec209b0ec8abc7d3
Katja, maybe you test again after my changes and then we can close this ticket.

#5 Updated by Patrick Plitzner almost 2 years ago

  • Assignee changed from Patrick Plitzner to Katja Luther

#6 Updated by Katja Luther almost 2 years ago

  • Status changed from Resolved to Closed

seems to be fine

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)