Project

General

Profile

Actions

bug #10466

open

Open issues in logfiles

Added by Andreas Müller 6 months ago. Updated about 1 month ago.

Status:
Feedback
Priority:
Priority14
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

70%

Estimated time:
Severity:
normal
Found in Version:
Tags:

Description

copied from #10441

Caused by: org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: eu.etaxonomy.cdm.model.taxon.Taxon.descriptions, could not initialize proxy - no Session
    at org.hibernate.collection.internal.AbstractPersistentCollection.throwLazyInitializationException(AbstractPersistentCollection.java:606)
    at org.hibernate.collection.internal.AbstractPersistentCollection.withTemporarySessionIfNeeded(AbstractPersistentCollection.java:218)
    at org.hibernate.collection.internal.AbstractPersistentCollection.initialize(AbstractPersistentCollection.java:585)
    at org.hibernate.collection.internal.AbstractPersistentCollection.read(AbstractPersistentCollection.java:149)
    at org.hibernate.collection.internal.PersistentSet.iterator(PersistentSet.java:188)
    at eu.etaxonomy.cdm.model.taxon.Taxon.getDefaultDescription(Taxon.java:459)

Also check for new issues in log files. Ask users to send them.


Related issues

Copied from EDIT - bug #10441: LIE in logfiles for DefinedTermBase.includesClosedKatja Luther

Actions
Actions #1

Updated by Andreas Müller 6 months ago

  • Copied from bug #10441: LIE in logfiles for DefinedTermBase.includes added
Actions #2

Updated by Andreas Müller 6 months ago

  • Description updated (diff)
Actions #3

Updated by Andreas Müller 6 months ago

  • Tags set to performance
  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • Priority changed from New to Highest
  • % Done changed from 0 to 70

This should be fixed.

Actions #4

Updated by Andreas Müller 6 months ago

  • Assignee changed from Andreas Müller to Katja Luther

Please check in log files if the error is still in log files.

Actions #5

Updated by Andreas Müller about 1 month ago

  • Target version changed from Release 5.49 to Release 5.43
Actions #6

Updated by Andreas Müller about 1 month ago

  • Priority changed from Highest to Priority14
Actions #8

Updated by Andreas Müller about 1 month ago

Can you also check if #5263 is still relevant?

Actions #9

Updated by Katja Luther about 1 month ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Katja Luther to Andreas Müller

There are still some LIE (always the same):
Caused by: org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: eu.etaxonomy.cdm.model.term.DefinedTermBase.includes, could not initialize proxy - no Session

Actions

Also available in: Atom PDF