Project

General

Profile

Actions

feature request #10354

closed

Show term data in term node details view

Added by Andreas Müller about 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Tags:

Description

copied from #9697

Term data should be visible in the details view of a term node in term tree editing. But they should (usually) not be writable. Maybe except for Character Editor details view.


Files

clipboard-202306231419-h3ekz.png (38.5 KB) clipboard-202306231419-h3ekz.png Andreas Müller, 06/23/2023 02:19 PM
clipboard-202309051815-al58b.png (31.1 KB) clipboard-202309051815-al58b.png Andreas Müller, 09/05/2023 06:15 PM

Related issues

Copied from EDIT - feature request #9697: Remaining issues for reimplementation of termtree editorsNewKatja Luther

Actions
Copied to EDIT - feature request #6794: Improve term structureIn ProgressAndreas Müller

Actions
Copied to EDIT - feature request #10353: Implement supplemental data editing for term treesNewKatja Luther

Actions
Copied to EDIT - feature request #10325: Improve (large) termtree editingNewKatja Luther

Actions
Actions #1

Updated by Andreas Müller about 1 year ago

Actions #2

Updated by Andreas Müller about 1 year ago

Actions #3

Updated by Andreas Müller about 1 year ago

Actions #4

Updated by Andreas Müller about 1 year ago

Actions #5

Updated by Andreas Müller about 1 year ago

  • Status changed from New to In Progress
Actions #6

Updated by Andreas Müller about 1 year ago

AM:

es werden jetzt bei NamedAreas trotzdem inapplicableIf und so angezeigt, was nicht dahin gehört. Außerdem ist das + actionable und erzeugt Fehlermeldung:

Actions #7

Updated by Katja Luther 11 months ago

Andreas Müller wrote in #note-6:

AM:

es werden jetzt bei NamedAreas trotzdem inapplicableIf und so angezeigt, was nicht dahin gehört. Außerdem ist das + actionable und erzeugt Fehlermeldung:

this was removed.

Actions #8

Updated by Katja Luther 11 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • Priority changed from New to Priority14

I think this is solved. Please review.

Actions #9

Updated by Katja Luther 11 months ago

  • % Done changed from 0 to 50
Actions #10

Updated by Andreas Müller 11 months ago

  • Target version changed from Release 5.49 to Release 5.40
  • % Done changed from 50 to 70
Actions #11

Updated by Andreas Müller 11 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 70 to 80

Now it seems to work correctly for all term types. Only for term type Character I wonder if we do not want to have the xxxapplicablexxx fields. They are part of a CharacterNode so should be available here I guess. At least they are in the Character Editor.

Actions #12

Updated by Andreas Müller 11 months ago

Now, in the character editor the character can't be edited anymore:

I don't know if this is caused by the fixes for this ticket but it urgently needs to be fixed for the release as it is a serious regression.

The above screenshot is from edit-test/flora-greece

Actions #13

Updated by Andreas Müller 11 months ago

The above can not be observed in rem_conf_am character editor so it might be data or database related.

Actions #14

Updated by Andreas Müller 11 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 80 to 100

This seems to be fully fixed now.

Actions

Also available in: Atom PDF