Project

General

Profile

bug #8279

ClassCastException in CdmUserHelper.user()

Added by Andreas Kohlbecker 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
New
Category:
cdm-vaadin
Target version:
Start date:
05/16/2019
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

found in the server log:

com.vaadin.server.ServerRpcManager$RpcInvocationException: Unable to invoke method click in com.vaadin.shared.ui.button.ButtonServerRpc
        at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:162)
        at com.vaadin.server.ServerRpcManager.applyInvocation(ServerRpcManager.java:119)
        at com.vaadin.server.communication.ServerRpcHandler.handleInvocation(ServerRpcHandler.java:437)
        at com.vaadin.server.communication.ServerRpcHandler.handleInvocations(ServerRpcHandler.java:402)
        at com.vaadin.server.communication.ServerRpcHandler.handleRpc(ServerRpcHandler.java:273)
        at com.vaadin.server.communication.UidlRequestHandler.synchronizedHandleRequest(UidlRequestHandler.java:90)
        at com.vaadin.server.SynchronizedRequestHandler.handleRequest(SynchronizedRequestHandler.java:41)
        at com.vaadin.server.VaadinService.handleRequest(VaadinService.java:1435)
        at com.vaadin.server.VaadinServlet.service(VaadinServlet.java:380)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
        at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:808)

....

Caused by: java.lang.ClassCastException: java.lang.String cannot be cast to eu.etaxonomy.cdm.model.common.User
        at eu.etaxonomy.cdm.api.utility.CdmUserHelper.user(CdmUserHelper.java:118)
        at eu.etaxonomy.vaadin.mvp.CdmEditorPresenterBase.adaptToUserPermission(CdmEditorPresenterBase.java:145)
        at eu.etaxonomy.vaadin.mvp.AbstractEditorPresenter.onViewFormReady(AbstractEditorPresenter.java:66)
        at eu.etaxonomy.vaadin.mvp.AbstractPopupEditor.loadInEditor(AbstractPopupEditor.java:834)
        at eu.etaxonomy.cdm.vaadin.view.registration.RegistrationWorkingsetPresenter.onTaxonNameEditorActionEdit(RegistrationWorkingsetPresenter.java:369)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at org.vaadin.spring.events.internal.MethodListenerWrapper.publish(MethodListenerWrapper.java:78)
        at org.vaadin.spring.events.internal.ListenerCollection.publish(ListenerCollection.java:167)
        at org.vaadin.spring.events.internal.ScopedEventBus.publish(ScopedEventBus.java:116)
        at org.vaadin.spring.events.internal.ScopedEventBus.publish(ScopedEventBus.java:109)
        at eu.etaxonomy.cdm.vaadin.view.registration.RegistrationWorksetViewBean.lambda$putRegistrationListComponent$e83e5a40$1(RegistrationWorksetViewBean.java:387)
        at sun.reflect.GeneratedMethodAccessor228.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:510)
        ... 75 more

Associated revisions

Revision b7723abf (diff)
Added by Andreas Kohlbecker 7 months ago

fix #8279 avoiding ClassCastExceptin in CdmUserHelper

Revision c251b820 (diff)
Added by Andreas Kohlbecker 7 months ago

ref #8279 removing unused call to CdmUserHelper.user()

History

#1 Updated by Andreas Kohlbecker 7 months ago

  • Target version changed from Release 5.7 to Release 5.8

#2 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#3 Updated by Andreas Kohlbecker 7 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)