Project

General

Profile

bug #6084

NPE when opening the checklist editor with no areas selected in preferences

Added by Patrick Plitzner over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
09/14/2016
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

You can reproduce this by deleting the preferences for the checklist editor in .cdmLibrary/.metadata/.plugins/org.eclipse.core.runtime/.settings/eu.etaxonomy.taxeditor.store.prefs

!ENTRY eu.taxeditor 1 0 2016-09-14 08:16:27.824
!MESSAGE Notifying context listeners, that the context has started.
2016-09-14 08:16:55,924 ERROR [eu.etaxonomy.taxeditor.view.CdmViewerContextMenu$CommandInvoker] - An exception occured while trying to execute eu.etaxonomy.taxeditor.editor.handler.OpenChecklistViewHandler
org.eclipse.swt.SWTException: Graphic is disposed
    at org.eclipse.swt.SWT.error(SWT.java:4282)
    at org.eclipse.swt.SWT.error(SWT.java:4197)
    at org.eclipse.swt.SWT.error(SWT.java:4168)
    at org.eclipse.swt.graphics.Image.getBounds(Image.java:840)
    at org.eclipse.swt.custom.CTabFolderRenderer.computeSize(CTabFolderRenderer.java:286)
    at org.eclipse.swt.custom.CTabFolder.setItemSize(CTabFolder.java:2405)
    at org.eclipse.swt.custom.CTabFolder.updateItems(CTabFolder.java:3347)
    at org.eclipse.swt.custom.CTabFolder.showItem(CTabFolder.java:3217)
    at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.java:2737)
    at org.eclipse.ui.internal.presentations.PaneFolder.setSelection(PaneFolder.java:732)
    at org.eclipse.ui.internal.presentations.defaultpresentation.DefaultTabFolder.setSelection(DefaultTabFolder.java:256)
    at org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(PresentablePartFolder.java:282)
    at org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(LeftToRightTabOrder.java:65)
    at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(TabbedStackPresentation.java:473)
    at org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1245)
    at org.eclipse.ui.internal.PartStack.setSelection(PartStack.java:1198)
    at org.eclipse.ui.internal.WorkbenchPage.internalBringToTop(WorkbenchPage.java:866)
    at org.eclipse.ui.internal.WorkbenchPage.internalActivate(WorkbenchPage.java:690)
    at org.eclipse.ui.internal.WorkbenchPage.activate(WorkbenchPage.java:663)
    at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2957)
    at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2850)
    at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2842)
    at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2793)
    at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
    at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2789)
    at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2773)
    at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2756)
    at eu.etaxonomy.taxeditor.editor.EditorUtil.open(EditorUtil.java:80)
    at eu.etaxonomy.taxeditor.editor.EditorUtil.open(EditorUtil.java:131)
    at eu.etaxonomy.taxeditor.editor.handler.OpenChecklistEditorHandler.open(OpenChecklistEditorHandler.java:48)
    at eu.etaxonomy.taxeditor.editor.handler.OpenChecklistEditorHandler.open(OpenChecklistEditorHandler.java:1)
    at eu.etaxonomy.taxeditor.handler.defaultHandler.DefaultOpenHandlerBase.execute(DefaultOpenHandlerBase.java:30)
    at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:293)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:476)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:508)
    at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(HandlerService.java:169)
    at eu.etaxonomy.taxeditor.view.CdmViewerContextMenu$CommandInvoker.widgetSelected(CdmViewerContextMenu.java:109)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:240)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1258)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3588)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3209)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
    at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1386)

!ENTRY eu.taxeditor 4 0 2016-09-14 08:16:55.930
!MESSAGE An exception occured while trying to execute eu.etaxonomy.taxeditor.editor.handler.OpenChecklistViewHandler
!STACK 0
org.eclipse.swt.SWTException: Graphic is disposed
    at org.eclipse.swt.SWT.error(SWT.java:4282)
    at org.eclipse.swt.SWT.error(SWT.java:4197)
    at org.eclipse.swt.SWT.error(SWT.java:4168)
    at org.eclipse.swt.graphics.Image.getBounds(Image.java:840)
    at org.eclipse.swt.custom.CTabFolderRenderer.computeSize(CTabFolderRenderer.java:286)
    at org.eclipse.swt.custom.CTabFolder.setItemSize(CTabFolder.java:2405)
    at org.eclipse.swt.custom.CTabFolder.updateItems(CTabFolder.java:3347)
    at org.eclipse.swt.custom.CTabFolder.showItem(CTabFolder.java:3217)
    at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.java:2737)
    at org.eclipse.ui.internal.presentations.PaneFolder.setSelection(PaneFolder.java:732)
    at org.eclipse.ui.internal.presentations.defaultpresentation.DefaultTabFolder.setSelection(DefaultTabFolder.java:256)
    at org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(PresentablePartFolder.java:282)
    at org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(LeftToRightTabOrder.java:65)
    at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(TabbedStackPresentation.java:473)
    at org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1245)
    at org.eclipse.ui.internal.PartStack.setSelection(PartStack.java:1198)
    at org.eclipse.ui.internal.WorkbenchPage.internalBringToTop(WorkbenchPage.java:866)
    at org.eclipse.ui.internal.WorkbenchPage.internalActivate(WorkbenchPage.java:690)
    at org.eclipse.ui.internal.WorkbenchPage.activate(WorkbenchPage.java:663)
    at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2957)
    at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2850)
    at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2842)
    at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2793)
    at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
    at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2789)
    at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2773)
    at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2756)
    at eu.etaxonomy.taxeditor.editor.EditorUtil.open(EditorUtil.java:80)
    at eu.etaxonomy.taxeditor.editor.EditorUtil.open(EditorUtil.java:131)
    at eu.etaxonomy.taxeditor.editor.handler.OpenChecklistEditorHandler.open(OpenChecklistEditorHandler.java:48)
    at eu.etaxonomy.taxeditor.editor.handler.OpenChecklistEditorHandler.open(OpenChecklistEditorHandler.java:1)
    at eu.etaxonomy.taxeditor.handler.defaultHandler.DefaultOpenHandlerBase.execute(DefaultOpenHandlerBase.java:30)
    at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:293)
    at org.eclipse.core.commands.Command.executeWithChecks(Command.java:476)
    at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:508)
    at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(HandlerService.java:169)
    at eu.etaxonomy.taxeditor.view.CdmViewerContextMenu$CommandInvoker.widgetSelected(CdmViewerContextMenu.java:109)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:240)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1258)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3588)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3209)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
    at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1386)

Associated revisions

Revision 6ac3c9c1 (diff)
Added by Katja Luther over 2 years ago

fix #6084: check if areas are selected in preferences before open the distribution editor

History

#1 Updated by Patrick Plitzner over 2 years ago

  • Description updated (diff)

#2 Updated by Katja Luther over 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

Applied in changeset taxeditor:commit:taxeditor|6ac3c9c18cc95fd462d8e2ce82dcb0904cce7c6e.

the problem was the not selected areas for the view, added a check for these areas before opening the view.

#3 Updated by Katja Luther over 2 years ago

  • Assignee changed from Katja Luther to Patrick Plitzner
  • Target version changed from Unassigned CDM tickets to Release 4.3

#4 Updated by Patrick Plitzner over 2 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Patrick Plitzner to Katja Luther
  • % Done changed from 50 to 100

works fine

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)