Project

General

Profile


Taxonomic Editor - Functionality

This represents Taxonomic Editor functionality as of Fri Aug 21 15:03:49 2009. Lisa Banfield will use this as the basis for the user manual.

As such, it is important that Lisa is kept aware of any additions or edits to this list - these should be added below under "Functionality to be integrated with main document" and only integrated with the main document after consultation with Lisa.

File menu / basic application navigation

  • Create a new taxonomic tree

    • File -> New -> CDM -> Taxonomic Tree
    • Click "new" icon in toolbar area under File menu -> CDM -> Taxonomic Tree
  • Close editors

    • File -> Close
    • File -> Close All
    • Right-click on editor tab -> Close
    • Right-click on editor tab -> Close All
    • Right-click on editor tab -> Close Others
  • Re-open a recently opened taxon editor

    • File -> 1 xxxxxx
  • Open a non-taxon editor window - all windows that are available to the application can be opened here, e.g. the User Manager and Datasource administration windows. If something like the property sheet has disappeared, the user can always re-open here.

    • Window -> Show View
  • Maximize / restore a window

    • Double click window tab
  • Minimize / restore window to its nearest margin

    • Click on the "-" icon (minimize) of any individual window to minimize to its nearest margin, where it is then represented by two icons, one which reveals the name of the window on mouseover and one which says "restore" on mouseover. These have slightly different behavior.

Preferences

  • Choose which status labels to show in distribution menus

    • Window -> Preferences -> Description -> Distribution Status
  • Choose which feature categories will appear in the descriptive area

    • Window -> Preferences -> Description -> Features
  • Choose size of recently opened taxon editors list

    • Window -> Preferences -> Editors -> Size of recently opened files list
  • Choose which name relationship types will appear in relationship type menus

    • Window -> Preferences -> Taxonomic -> Name Relationship Type
  • Choose which nomenclatural code to be used when creating names

    • Window -> Preferences -> Taxonomic -> Nomenclatural Code
  • Choose which nomenclatural status types will be available in status menus

    • Window -> Preferences -> Taxonomic -> Nomenclatural Status Type
  • Choose which ranks will appear in rank menus

    • Window -> Preferences -> Taxonomic -> Ranks
  • Choose which specimen type statuses are available in status menu when creating / editing a specimen designation

    • Window -> Preferences -> Taxonomic -> Specimen Type Designation
  • Choose which name taxon relationship types will appear in taxon relationship type menus

    • Window -> Preferences -> Taxonomic -> Taxon Relationship Type

Software update

  • Check for software update, download if available

    • 1) Help -> Software Updates ... -> Search for updates of the currently installed features; 2) Check "EDIT Taxonomic Editor" -> Next -> Click "I accept the terms of the license agreement -> Next -> Finish; 3) Install All

Bulk editor

  • work in progress #778

Login

  • Login dialog presented at startup; all changes during the session will be logged under the user's name in the datasource

Taxonomic tree

  • Close tree so that only its roots are showing

    • Taxonomic Tree toolbar -> "-" icon (Collapse all)
  • Link tree to taxon editor that has focus - within the tree, the name of the taxon editor which currently has focus will be selected. A known bug, which is really more a weakness, is that if the tree is closed so that an open taxon name is no longer visible, upon re-starting the application, the tree will not be able to find the taxon name. This is because the path to the taxon has not yet been revealed during the current session (let me know if this requires further explanation!).

    • Taxonomic Tree toolbar -> "-><-" icon (Link open editors ...)
  • Choose which data types - taxon. tree, taxon, synonym - to show in the tree

    • Taxonomic Tree -> downward arrow (View Menu) -> Customize View -> Content
  • Open taxon for editing

    • Right-click on name in tree -> Edit
    • Double-click on name in tree
  • Move taxon to new taxonomic parent

    • Right-click on name in tree ~~> Move -> Choose new parent from search ~~ see #928
    • Drag name in tree and drop on to new parent
  • Create new taxonomic child taxon

    • Right-click on name in tree ~~> New Child ~~ opens empty taxon editor; new name will appear in tree when editor is saved
    • Right-click on name in tree ~~> Quick Add Child ~~ opens input dialog for name, which will appear in tree when "OK" is pressed
    • In editing area, right-click -> New -> Child Taxon
  • Import / Export - dunno what this is about, I'll ask Niels when he's back #779

  • Delete a taxon

    • Right-click on name in tree ~~> Delete ~~ taxon with children cannot be deleted until individual children are deleted

Search

  • Search for all taxa and synonyms where a name is used - each search creates a new results list; double-clicking on an entry in the results list will open for editing the taxon where the name is used

    • In Search box in toolbox area under the menu bar, enter search term using "*" as wildcard -> Search
  • Restrict search to one or a combination of Taxa, Synonyms, Names (without Taxa), Common Names

    • Next to "Search" button, click on downward facing arrow -> check or uncheck accordingly

Editing a taxon

  • Enter a taxon's name - taxa and synonyms without names cannot be saved

    • Click in taxon's area, start typing - name parsed on-the-fly, atomized fields and parsing status ("parsed" / "problem") shown in property sheet
  • Understanding system feedback - when there is an error or warning sign on a name's icon in the editing area, a mouseover will reveal the problem, e.g. "Error parsing string Xxxxx", "This taxon requires a sec. reference"

  • Add a heterotypic synonym

    • At the end of a name in the editing area, hit carriage return
    • In the editing area, right-click -> New -> Heterotypic Synonym
  • Add a homotypic synonym

    • In the editing area, right-click -> New -> Homotypic Synonym
    • Create a heterotypic synonym -> drag the synonym into the accepted taxon's homotypic group
  • Change a synonym's homotypic group

    • Drag the synonym into the accepted taxon's homotypic group
  • Change a taxon to a synonym

    • Right-click the accepted taxon in the editing area -> Change Accepted Taxon to Synonym -> Choose new accepted taxon from drop-down list (work in progress #818)
  • Change a synonym to an accepted taxon

    • Right-click the synonym in the editing area -> Change To -> Accepted Taxon (Currently does nothing, oddly enough #925)
  • Change a synonym to a synonym, misapplication, or concept relation

    • Right-click the synonym in the editing area -> Change To -> Synonym / Concept Relation -> rel. type / Misapplication
    • Drag the synonym into the misapplications or concept relations group
  • Set / unset a synonym as group basionym - there was a command in the right-click menu for this, I need to clarify w Niels why it has been removed #927

  • Delete a synonym / misapplication / concept relation - note #926

    • Right-click on element -> Delete
  • Save taxon

    • Right-click in editing area -> Save
    • Click "save" icon in toolbar area under File menu

Editing a taxon's descriptive information

  • work in progress #832

Editing in the property sheet

  • Edit a name's constituent parts - selected name shown in property sheet indicated with light blue in editing area

  • Edit a name's cache

    • Edit name in the field "Editable Cache". Note that "Protect cache from overwriting" is now set to "yes", and that Uninomial, etc. are no longer editable
  • Edit a name's individual fields, e.g. Uninomial, Epithet, etc.

    • Set "Protect cache from overwriting" to no, edit individual fields. Note that cache is automatically updated.
  • Edit authorship cache

    • Edit authorship in the field "Editable Cache". Note that "Protect cache from overwriting" is now set to "yes", and that the subfields are no longer editable
  • Edit authorship's individual fields, e.g. Authorship, Ex-Authorship, etc.

    • Set "Protect cache from overwriting" to no, edit individual fields. Note that cache is automatically updated.
  • Search for a reference - note, references can be created when a name is parsed or with the Bulk Editor

    • Nomenclatural Reference -> Search -> Choose reference from reference search dialog -> OK
  • Edit reference cache

    • Edit authorship in the field "Editable Cache". Note that "Protect cache from overwriting" is now set to "yes", and that the subfields are no longer editable
  • Edit reference's individual fields

    • Set "Protect cache from overwriting" to no, edit individual fields. Note that cache is automatically updated.
  • Edit / create a reference's date published

    • Nomenclatural reference -> Date Published -> edit individual fields
    • Nomenclatural reference ~~> edit "Date Published" ~~ note that individual fields are updated accordingly
  • Add / remove nomenclatural status - make sure name title cache reflects change

    • Choose either a status or the blank entry from the "Nomenclatural Status" dropdown
  • Add / remove annotation - annotation list not shown in property sheet per #765

    • Annotations -> Click "..." -> Add / remove annotation in dialog
  • Add / remove markers - work in progress #782

  • Add / remove extensions - work in progress #783

  • Add / remove specimen type designation - appearance in property sheet dependent on name rank, i.e. species or below

  • Add / remove name type designation - appearance in property sheet dependent on name rank, i.e. above species

  • Edit a type designation's citation - same as Edit reference* above

Datasource

  • Open datasource window

    • Window -> Show View -> Datasource
  • Create a datasource

    • Right-click on datasource window -> New
  • Edit a datasource - causes a duplicate entry in datasources #861

    • Right-click on datasource -> Edit
  • Delete a datasource

    • Right-click on datasource -> Delete
  • Connect to a datasource - causes application re-start; note that by default, user is asked which database to connect to upon startup until this is explicitly turned off by checking "don't ask" in the startup dialog

    • Right-click on datasource -> Connect

User management

  • Open user management window

    • Window -> Show View -> User Manager
  • Create a user

    • Right-click on user management window -> New
  • Edit a user

    • Right-click on user -> Edit
  • Delete a user

    • Right-click on user -> Delete

Initial startup

  • Choose nomenclatural code

    • User prompted via a radio button dialog to choose between ICZN or ICBN

State restored after application restart

  • Open taxon editors from last session are re-opened

  • Recently opened taxon editors in File menu is restored

  • Taxonomic tree state - i.e. open nodes - is restored from previous session

  • Previously chosen datasource is re-selected


Taxonomic Editor - Functionality to be integrated with main document

  • annotation list bug #765 fixed

Preferences

Features and extension types have additional functionality, in that the user can create, edit (not yet impl.) or remove (not yet impl.) entries from the display lists.

  • Choose which languages will appear in the language dropdown in common names

    • Window -> Preferences -> Description -> Languages
  • Choose which extension types can be created in the property sheet

    • Window -> Preferences -> Taxonomic -> Extension Types
  • Choose which marker types can be created and flagged in the property sheet

    • Window -> Preferences -> Taxonomic -> Marker Types
  • Choose whether to be presented a dialog to select a datasource when the application is started - otherwise, datasource from previous session is used

    • Window -> Preferences -> General -> Taxonomic Editor

Bulk editor

The Bulk Editor

TODO add new image gallery wrinkles

Add picture from clipboard (Maximum size: 40 MB)