Project

General

Profile

Revision eb691546

IDeb69154603b21c14e674baacea5093b845a81126
Parent fcccac41
Child 9b96d6f2

Added by Andreas Müller 2 months ago

ref #9204 update spring to 4.3.28, spring security to 4.2.18 and spring secur oauth2 to 2.5.0 and dependent aspectj and servlet-api

View differences:

cdmlib-services/src/main/resources/eu/etaxonomy/cdm/services_security_base.xml
5 5
  xmlns:security="http://www.springframework.org/schema/security"
6 6
  xsi:schemaLocation="
7 7
    http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-3.0.xsd
8
    http://www.springframework.org/schema/tx http://www.springframework.org/schema/tx/spring-tx-4.0.xsd
9
    http://www.springframework.org/schema/context http://www.springframework.org/schema/context/spring-context-4.0.xsd
10
    http://www.springframework.org/schema/security http://www.springframework.org/schema/security/spring-security-4.0.xsd"
8
    http://www.springframework.org/schema/tx http://www.springframework.org/schema/tx/spring-tx-4.3.xsd
9
    http://www.springframework.org/schema/context http://www.springframework.org/schema/context/spring-context-4.3.xsd
10
    http://www.springframework.org/schema/security http://www.springframework.org/schema/security/spring-security-4.2.xsd"
11 11
    >
12 12

  
13

  
14 13
    <!--
15 14
        ======================================================================
16 15
          security specific configuration
pom.xml
27 27
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
28 28
    <project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
29 29
    <java.codelevel>1.8</java.codelevel>
30
    <spring.version>4.2.4.RELEASE</spring.version>
31
    <spring-security.version>4.0.3.RELEASE</spring-security.version>
32
    <spring-security-oauth2.version>2.3.5.RELEASE</spring-security-oauth2.version>  <!-- checked 2020-08, further upgrade possible -->
30
    <spring.version>4.3.28.RELEASE</spring.version>                                 <!-- checked 2020-08, further upgrade possible -->
31
    <spring-security.version>4.2.18.RELEASE</spring-security.version>               <!-- checked 2020-08, further upgrade possible -->
32
    <spring-security-oauth2.version>2.5.0.RELEASE</spring-security-oauth2.version>  <!-- checked 2020-08 -->
33 33
    <spring-cloud.version>1.1.3.RELEASE</spring-cloud.version>
34 34
	<hibernate.version>5.0.7.Final</hibernate.version>
35 35
	<hibernate-validator.version>6.1.5.Final</hibernate-validator.version>          <!-- checked 2020-08 -->
......
43 43
    <doxia.version>1.6</doxia.version>
44 44
    <poi.version>3.13</poi.version>
45 45
    <jackson.version>2.11.2</jackson.version>           <!-- checked 2020-08 -->
46
	<commons-logging.version>1.2</commons-logging.version>
46
	<commons-logging.version>1.2</commons-logging.version> <!-- checked 2020-08 -->
47 47
	<slf4j.version>1.7.30</slf4j.version>               <!-- checked 2020-08 -->
48 48
	<jaxb.version>2.2.11</jaxb.version>
49 49
	<cglib.version>3.2.0</cglib.version>
50
	<aspectj.version>1.8.8</aspectj.version>
50
	<aspectj.version>1.9.6</aspectj.version>            <!-- checked 2020-08 -->
51 51
	<geotools.version>23.0</geotools.version>           <!-- checked 2020-04 -->
52 52
    <javadoc.opts>-Xdoclint:none</javadoc.opts>         
53 53
  </properties>
......
954 954
        <version>3.4.1.Final</version>
955 955
        <!-- checked 2020-08 -->
956 956
      </dependency>
957
      <!-- TODO com.springsource.org.aopalliance and com.springsource.org.apache.commons.logging 
958
        seem to be duplicates of e.g. apache commons-logging. Needs to be further 
959
        checked. -->
960 957
	  <!-- since hibernate 5.0.4 Dialect throws exception if jta is missing  -->
961 958
	  <dependency>
962 959
        <groupId>javax.transaction</groupId>
......
1458 1455
        <artifactId>spring-cloud-security</artifactId>
1459 1456
        <version>${spring-security.version}</version>
1460 1457
      </dependency>
1458
      <dependency>
1459
        <!-- required by spring security core, but not needed anymore in spring security 5.x  -->
1460
        <groupId>aopalliance</groupId>
1461
        <artifactId>aopalliance</artifactId>
1462
        <version>1.0</version>
1463
      </dependency>
1461 1464

  
1462 1465
      <!-- ******* SERVLET/JSP/JSF ******* -->
1463 1466
      <dependency>
1464 1467
        <groupId>javax.servlet</groupId>
1465 1468
        <artifactId>javax.servlet-api</artifactId>
1466
        <version>3.1.0</version>
1469
        <version>4.0.1</version>
1470
        <!-- checked 2020-08 -->
1467 1471
      </dependency>
1468 1472

  
1469 1473
      <!-- yourkit profiler api controller (used in ..) -->

Also available in: Unified diff

Add picture from clipboard (Maximum size: 40 MB)