Project

General

Profile

Download (61.2 KB) Statistics
| Branch: | Tag: | Revision:
1
<?xml version="1.0" encoding="UTF-8"?> 
2
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
3
  <modelVersion>4.0.0</modelVersion>
4
  <groupId>eu.etaxonomy</groupId>
5
  <artifactId>cdmlib-parent</artifactId>
6
  <version>5.29.0-SNAPSHOT</version>
7
  <name>CDM Library</name>
8
  <description>The Java implementation of the Common Data Model (CDM), the data model for EDIT's internet platform for cybertaxonomy.</description>
9
  <url>http://cybertaxonomy.eu/cdmlib/</url>
10
  <inceptionYear>2007</inceptionYear>
11
  <packaging>pom</packaging>
12
  <modules>
13
    <module>cdmlib-commons</module>
14
    <module>cdmlib-model</module>
15
	<module>cdmlib-api</module>
16
    <module>cdmlib-db</module>
17
    <module>cdmlib-test</module>
18
    <module>cdmlib-persistence</module>
19
    <module>cdmlib-services</module>
20
    <module>cdmlib-ext</module>
21
    <module>cdmlib-io</module>
22
    <module>cdmlib-remote</module>
23
    <module>cdmlib-print</module>
24
    <module>cdmlib-remote-webapp</module>
25
    <module>cdmlib-cache</module>
26
  </modules>
27
  <properties>    
28
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
29
    <project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
30
    <java.codelevel>1.8</java.codelevel>
31
    <spring.version>4.3.30.RELEASE</spring.version>                                 <!-- checked 2020-08, further upgrade possible -->
32
    <spring-security.version>4.2.20.RELEASE</spring-security.version>               <!-- checked 2020-08, further upgrade possible -->
33
    <spring-security-oauth2.version>2.5.1.RELEASE</spring-security-oauth2.version>  <!-- checked 2020-08 -->
34
    <spring-cloud.version>1.1.3.RELEASE</spring-cloud.version>
35
	<hibernate.version>5.1.17.Final</hibernate.version>
36
	<hibernate-validator.version>6.1.5.Final</hibernate-validator.version>          <!-- checked 2020-08 -->
37
    <hibernate-search.version>5.5.2.Final</hibernate-search.version>
38
    <lucene.version>5.4.1</lucene.version>
39
	<unitils.version>3.4.6</unitils.version>
40
    <hsqldb.version>2.5.1</hsqldb.version>  <!-- upgrade to 2.6.1 "cannot access Server" in LocalHsqldb during compile time -->
41
    <httpcomponents.version>4.5.13</httpcomponents.version>
42
    <doxia.version>1.11.1</doxia.version>                <!-- checked 2021-12 -->
43
    <poi.version>4.1.2</poi.version>                    <!-- checked 2020-08 -->
44
    <jackson.version>2.13.1</jackson.version>           <!-- checked 2021-12 -->
45
	<commons-logging.version>1.2</commons-logging.version> <!-- checked 2020-08 -->
46
	<slf4j.version>1.7.30</slf4j.version>               <!-- checked 2020-08 -->
47
	<jaxb.version>2.3.3</jaxb.version>                 <!-- checked 2020-08, there is a newer version 3.0.0-MX, not checked if compatible -->
48
	<cglib.version>3.3.0</cglib.version>
49
	<aspectj.version>1.9.7</aspectj.version>            <!-- checked 2022-01 -->
50
	<geotools.version>23.2</geotools.version>           <!-- checked 2020-08 -->
51
    <dozer.version>6.5.2</dozer.version>                <!-- checked 2021-02 -->
52
    <javax.mail.version>1.5.6</javax.mail.version>      <!-- compatible to the one in spring-context-support/4.3.28.RELEASE -->
53
    <javadoc.opts>-Xdoclint:none</javadoc.opts>         
54
  </properties>
55
  
56
  <scm>
57
    <connection>scm:git:https://dev.e-taxonomy.eu/git/cdmlib.git</connection>
58
    <developerConnection>scm:git:ssh://git@dev.e-taxonomy.eu/var/git/cdmlib.git</developerConnection>
59
    <url>https://dev.e-taxonomy.eu/gitweb/cdmlib.git/tree</url>
60
  </scm>
61
  
62
  <prerequisites>
63
    <maven>3.2.3</maven>
64
  </prerequisites>
65
  
66
    <mailingLists>
67
        <mailingList>
68
            <name>EDIT Platform Developers</name>
69
            <subscribe>
70
                https://lists.fu-berlin.de/listinfo/editplatformdevelopers#subscribe
71
            </subscribe>
72
            <unsubscribe>
73
                https://lists.fu-berlin.de/listinfo/editplatformdevelopers#options
74
            </unsubscribe>
75
        </mailingList>
76
        <mailingList>
77
            <name>EDIT User</name>
78
            <subscribe>
79
                https://lists.fu-berlin.de/listinfo/edituser#subscribe
80
            </subscribe>
81
            <unsubscribe>
82
                https://lists.fu-berlin.de/listinfo/edituser#options
83
            </unsubscribe>
84
        </mailingList>
85
    </mailingLists>
86
  <licenses>
87
    <license>
88
      <name>Mozilla Public License Version 1.1</name>
89
      <url>http://www.mozilla.org/MPL/MPL-1.1.html</url>
90
      <distribution>repo</distribution>
91
    </license>
92
  </licenses>
93
  <organization>
94
    <name>EDIT</name>
95
    <url>https://cybertaxonomy.eu/</url>
96
  </organization>
97
  <developers>
98
    <developer>
99
      <id>a.kohlbecker</id>
100
      <name>Andreas Kohlbecker</name>
101
      <email>a.kohlbecker [at] bgbm.org</email>
102
      <organization>Botanical Garden Botanical Museum Berlin</organization>
103
      <organizationUrl>https://www.bgbm.org/en/biodiversity-informatics</organizationUrl>
104
      <timezone>+1</timezone>
105
      <roles>
106
        <role>Architect</role>
107
        <role>Java Developer</role>
108
        <role>Release Manager</role>
109
      </roles>
110
      <url />
111
    </developer>
112
    <developer>
113
      <id>k.luther</id>
114
      <name>Katja Luther</name>
115
      <email>k.luther [at] bgbm.org</email>
116
      <organization>Botanical Garden Botanical Museum Berlin</organization>
117
      <organizationUrl>https://www.bgbm.org/en/biodiversity-informatics</organizationUrl>
118
      <timezone>+1</timezone>
119
      <roles>
120
        <role>Java Developer</role>
121
      </roles>
122
      <url />
123
    </developer>
124
    <developer>
125
      <id>a.mueller</id>
126
      <name>Andreas Müller</name>
127
      <email>a.mueller [at] bgbm.org</email>
128
      <organization>Botanical Garden Botanical Museum Berlin</organization>
129
      <organizationUrl>https://www.bgbm.org/en/biodiversity-informatics</organizationUrl>
130
      <timezone>+1</timezone>
131
      <roles>
132
        <role>Architect</role>
133
        <role>Java Developer</role>
134
        <role>Release Manager</role>
135
      </roles>
136
      <url />
137
    </developer>
138
  </developers>
139
  <!--contributors> <contributor> <name>Test-Contributor</name> </contributor> 
140
    </contributors -->
141
  <issueManagement>
142
    <system>Redmine</system>
143
    <url>https://dev.e-taxonomy.eu/redmine/projects/edit</url>
144
  </issueManagement>
145
  <ciManagement>
146
    <system>Jenkins</system>
147
    <url>https://int.e-taxonomy.eu/jenkins</url>
148
  </ciManagement>
149
  <!-- **** REPOSITORIES **** -->
150
  <profiles>
151
    <profile>
152
      <id>local-repository</id>
153
      <activation>
154
        <property>
155
          <name>localrepo</name>
156
        </property>
157
      </activation>
158
      <repositories>
159
        <repository>
160
          <id>EditLocalRepository</id>
161
          <url>file://${localrepo}/eu/etaxonomy/</url>
162
          <releases>
163
            <enabled>false</enabled>
164
            <updatePolicy>always</updatePolicy>
165
          </releases>
166
          <snapshots>
167
            <enabled>true</enabled>
168
            <updatePolicy>always</updatePolicy>
169
          </snapshots>
170
        </repository>
171
      </repositories>
172
    </profile>
173
  </profiles>
174
  <repositories>
175
    <!-- the cdm internal repository -->
176
    <repository>
177
      <id>EditRepository</id>
178
      <url>https://cybertaxonomy.eu/mavenrepo/</url>
179
    </repository>
180
    <!-- apache incubating repository -->
181
    <repository>
182
      <id>ApacheIncubating</id>
183
      <url>https://people.apache.org/repo/m2-incubating-repository/</url>
184
    </repository>
185
    <!-- Neccessary for hibernate-envers -->
186
    <repository>
187
  <!--    <releases>
188
        <enabled>true</enabled>
189
        <updatePolicy>always</updatePolicy>
190
        <checksumPolicy>warn</checksumPolicy>
191
      </releases>
192
      <snapshots>
193
        <enabled>false</enabled>
194
        <updatePolicy>never</updatePolicy>
195
        <checksumPolicy>fail</checksumPolicy>
196
      </snapshots>   -->
197
      <id>jboss-repository</id>
198
      <name>JBoss Repository</name>
199
      <url>https://repository.jboss.org</url>
200
    </repository>
201
    <repository>
202
    	<id>OSGeo Repository</id>
203
    	<url>https://repo.osgeo.org/repository/release/</url>
204
    </repository>
205
  </repositories>
206
  <!-- **** PLUGINS **** -->
207
  <build>
208
    <plugins>
209
      <plugin>
210
        <groupId>org.apache.maven.plugins</groupId>
211
        <artifactId>maven-compiler-plugin</artifactId>
212
		<!-- TODO #9919 upgrading to 3.x leads to test failures in model etc. -->
213
		<version>2.5.1</version> 
214
        <configuration>
215
          <source>${java.codelevel}</source>
216
          <target>${java.codelevel}</target>
217
          <encoding>${project.build.sourceEncoding}</encoding>  <!-- necessary? should be covered by project. properties source encoding -->
218
		  <!-- to increase stacksize see #6404 -->
219
        </configuration>
220
      </plugin>
221
      <plugin>
222
        <groupId>org.apache.maven.plugins</groupId>
223
        <artifactId>maven-surefire-plugin</artifactId>
224
        <version>3.0.0-M5</version>  <!-- updated 2020-09 -->
225
        <configuration>
226
          <argLine>-Xmx512M -Dfile.encoding=${project.build.sourceEncoding}</argLine>
227
          <runOrder>alphabetical</runOrder>
228
          <includes>
229
            <include>**/*Test.java</include>
230
          </includes>
231
        </configuration>
232
      </plugin>
233
      <plugin>
234
          <groupId>org.apache.maven.plugins</groupId>
235
          <artifactId>maven-resources-plugin</artifactId>
236
          <version>3.0.2</version>
237
          <configuration>
238
              <encoding>${project.build.sourceEncoding}</encoding>
239
          </configuration>
240
      </plugin>
241
      <plugin>
242
        <groupId>org.codehaus.mojo</groupId>
243
        <artifactId>buildnumber-maven-plugin</artifactId>
244
        <version>1.4</version>
245
        <executions>
246
          <execution>
247
            <!--<phase>deploy</phase> -->
248
            <goals>
249
              <goal>create</goal>
250
            </goals>
251
          </execution>
252
        </executions>
253
        <configuration>
254
          <doCheck>false</doCheck>
255
          <!-- Only create the build number if there are no local modifications -->
256
          <doUpdate>false</doUpdate>
257
          <!-- automatically update the local svn copy -->
258
        </configuration>
259
      </plugin>
260
      <plugin>
261
        <groupId>org.apache.maven.plugins</groupId>
262
        <artifactId>maven-site-plugin</artifactId>
263
        <version>3.10.0</version>
264
        <configuration>
265
          <locales>en</locales>
266
          <outputEncoding>UTF-8</outputEncoding><!-- necessary? should be covered by project. properties output encoding -->
267
          <!-- chmod: not not use chmod, rather adapt the umask of the user 
268
            at the server to which the site is deployed -->
269
          <chmod>false</chmod>
270
        </configuration>
271
      </plugin>
272
      <plugin>
273
        <groupId>org.apache.maven.plugins</groupId>
274
        <artifactId>maven-source-plugin</artifactId>
275
        <version>2.1.2</version>
276
        <executions>
277
          <execution>
278
            <id>attach-sources</id>
279
            <phase>verify</phase>
280
            <goals>
281
              <goal>jar</goal>
282
            </goals>
283
          </execution>
284
        </executions>
285
      </plugin>
286
      <plugin>
287
        <groupId>org.apache.maven.plugins</groupId>
288
        <artifactId>maven-javadoc-plugin</artifactId>
289
        <version>2.7</version>
290
        <configuration>
291
          <stylesheet>maven</stylesheet>
292
          <quiet>true</quiet>
293
          <detectLinks>true</detectLinks>
294
          <failOnError>false</failOnError>
295
          <additionalparam>${javadoc.opts}</additionalparam>
296
        </configuration>
297
        <executions>
298
          <execution>
299
            <id>aggregate</id>
300
            <goals>
301
              <goal>aggregate</goal>
302
            </goals>
303
            <phase>site</phase>
304
          </execution>
305
        </executions>
306
      </plugin>
307
      <plugin>
308
        <groupId>org.apache.maven.plugins</groupId>
309
        <artifactId>maven-eclipse-plugin</artifactId>
310
        <version>2.9</version>
311
        <configuration>
312
          <downloadSources>true</downloadSources>
313
          <downloadJavadocs>true</downloadJavadocs>
314
        </configuration>
315
      </plugin>
316
      <plugin>
317
        <groupId>com.agilejava.docbkx</groupId>
318
        <artifactId>docbkx-maven-plugin</artifactId>
319
        <version>2.0.9</version>
320
        <executions>
321
          <execution>
322
            <goals>
323
              <goal>generate-html</goal>
324
              <goal>generate-pdf</goal>
325
            </goals>
326
            <phase>pre-site</phase>
327
          </execution>
328
        </executions>
329
        <dependencies>
330
          <dependency>
331
            <groupId>org.docbook</groupId>
332
            <artifactId>docbook-xml</artifactId>
333
            <version>4.4</version>
334
            <scope>runtime</scope>
335
          </dependency>
336
        </dependencies>
337
        <configuration>
338
          <includes>ReferenceDocumentation.xml</includes>
339
          <chunkedOutput>true</chunkedOutput>
340
          <htmlStylesheet>resources/css/html.css</htmlStylesheet>
341
          <xincludeSupported>true</xincludeSupported>
342
          <!--<htmlCustomization>src/docbkx/resources/xsl/html_chunk.xsl</htmlCustomization> -->
343
          <!-- if anyone can get the xsl-fo customization to work properly, 
344
            then by all means use it <foCustomization>src/docbkx/resources/xsl/fopdf.xsl</foCustomization> -->
345
          <entities>
346
            <entity>
347
              <name>version</name>
348
              <value>${project.version}</value>
349
            </entity>
350
          </entities>
351
          <!--We want the final documentation and the required resources 
352
            to end up in the right place -->
353
          <postProcess>
354
            <copy todir="target/site/reference">
355
              <fileset dir="target/docbkx">
356
                <include name="**/*.html" />
357
                <include name="**/*.pdf" />
358
              </fileset>
359
            </copy>
360
            <copy todir="target/site/reference/html">
361
              <fileset dir="src/docbkx">
362
                <include name="**/*.css" />
363
                <include name="**/*.png" />
364
                <include name="**/*.gif" />
365
                <include name="**/*.jpg" />
366
              </fileset>
367
            </copy>
368
          </postProcess>
369
        </configuration>
370
      </plugin>
371
      <plugin>
372
        <groupId>org.codehaus.mojo</groupId>
373
        <artifactId>wagon-maven-plugin</artifactId>
374
        <version>2.0.2</version>
375
        <configuration>
376
          <fromDir>${project.build.directory}/docbkx/</fromDir>
377
          <includes>**/*</includes>
378
          <excludes />
379
          <url>scpexe://cybertaxonomy.eu</url>
380
          <serverId>cybertaxonomy.eu</serverId>
381
          <toDir>var/www/wp5.e-taxonomy.eu/cdmlib/reference/${project.version}</toDir>
382
        </configuration>
383
        <executions>
384
          <execution>
385
            <id>upload-reference-documentation</id>
386
            <phase>site-deploy</phase>
387
            <goals>
388
              <goal>upload</goal>
389
            </goals>
390
          </execution>
391
        </executions>
392
      </plugin>
393
      <plugin>
394
        <groupId>org.apache.maven.plugins</groupId>
395
        <artifactId>maven-release-plugin</artifactId>
396
        <version>2.1</version>
397
        <configuration>
398
          <allowTimestampedSnapshots>true</allowTimestampedSnapshots>
399
          <autoVersionSubmodules>true</autoVersionSubmodules>
400
          <preparationGoals>clean verify install</preparationGoals>
401
          <goals>deploy</goals><!-- skipping site-deploy by explicitly configuring 
402
            the goal here -->
403
          <tagBase>http://dev.e-taxonomy.eu/svn/tags/cdmlib</tagBase>
404
        </configuration>
405
      </plugin>
406
      <plugin>
407
        <groupId>external.atlassian.jgitflow</groupId>
408
        <artifactId>jgitflow-maven-plugin</artifactId>
409
        <version>1.0-m6</version>
410
        <configuration>
411
          <pushHotfixes>true</pushHotfixes>
412
          <pushReleases>true</pushReleases> 
413
          <enableSshAgent>true</enableSshAgent>
414
          <allowSnapshots>true</allowSnapshots>
415
          <allowUntracked>true</allowUntracked>
416
        </configuration>
417
        <dependencies>
418
          <!-- 
419
                upgrading dependency jsch.agent.version of jgit-flow plugin to 0.1.53 
420
                in order have ssl key exchange algorithms compatible with openssh 6.7 
421
             -->
422
          <dependency>
423
            <groupId>com.jcraft</groupId>
424
            <artifactId>jsch</artifactId>
425
            <version>0.1.53</version>
426
          </dependency>
427
        </dependencies>
428
      </plugin>
429
      <plugin>
430
        <groupId>org.apache.maven.plugins</groupId>
431
        <artifactId>maven-enforcer-plugin</artifactId>
432
        <version>3.0.0-M2</version>
433
        <executions>
434
          <execution>
435
            <id>enforce</id>
436
            <configuration>
437
              <fail>true</fail>
438
              <skip>false</skip>
439
              <rules>
440
                <dependencyConvergence />                
441
				<requireMavenVersion>
442
                  <version>[3.6.0,)</version>
443
                </requireMavenVersion>
444
              </rules>
445
            </configuration>
446
            <goals>
447
              <goal>enforce</goal>
448
              <!-- Binds by default to the lifecycle phase: validate -->
449
            </goals>
450
          </execution>
451
        </executions>
452
      </plugin>
453
    </plugins>
454
    <extensions>
455
      <extension>
456
        <groupId>org.apache.maven.wagon</groupId>
457
        <artifactId>wagon-scm</artifactId>
458
        <version>3.5.1</version>
459
      </extension>
460
      <extension>
461
        <groupId>org.apache.maven.wagon</groupId>
462
        <artifactId>wagon-ssh</artifactId>
463
        <version>3.5.1</version>
464
      </extension>
465
      <extension>
466
        <groupId>org.apache.maven.wagon</groupId>
467
        <artifactId>wagon-ssh-external</artifactId>
468
        <version>3.5.1</version>
469
      </extension>
470
      <extension>
471
        <groupId>org.apache.maven.scm</groupId>
472
        <artifactId>maven-scm-manager-plexus</artifactId>
473
        <version>1.12.2</version>
474
      </extension>
475
      <extension>
476
        <groupId>org.apache.maven.scm</groupId>
477
        <artifactId>maven-scm-provider-svnexe</artifactId>
478
        <version>1.12.2</version>
479
      </extension>
480
      <!-- WebDAV plugin to upload snapshots -->
481
      <extension>
482
        <groupId>org.apache.maven.wagon</groupId>
483
        <artifactId>wagon-webdav-jackrabbit</artifactId>
484
        <version>3.5.1</version>
485
      </extension>
486
    </extensions>
487
    <pluginManagement>
488
      <plugins>
489
        <plugin>
490
          <groupId>org.apache.maven.plugins</groupId>
491
          <artifactId>maven-antrun-plugin</artifactId>
492
          <version>3.0.0</version>
493
        </plugin>
494
      </plugins>  
495
    </pluginManagement>
496
  </build>
497
  <reporting>
498
    <plugins>
499
      <plugin>
500
        <!-- you will want to start by publishing your classes' Javadocs -->
501
        <groupId>org.apache.maven.plugins</groupId>
502
        <artifactId>maven-javadoc-plugin</artifactId>
503
        <version>2.7</version>
504
        <configuration>
505
          <detectLinks>true</detectLinks>
506
          <additionalparam>${javadoc.opts}</additionalparam>
507
        </configuration>
508
      </plugin>
509
      <plugin>
510
        <!-- this will generate an indexed and cross-referenced HTML version 
511
          of your source code -->
512
        <groupId>org.apache.maven.plugins</groupId>
513
        <artifactId>maven-jxr-plugin</artifactId>
514
        <version>2.2</version>
515
      </plugin>
516
      <plugin>
517
        <!-- if you use @todo tags to remind you of things to be done (which 
518
          is a good coding practice), the taglist report will generate a list of all 
519
          the items marked @todo or TODO -->
520
        <groupId>org.codehaus.mojo</groupId>
521
        <artifactId>taglist-maven-plugin</artifactId>
522
        <version>2.4</version>
523
      </plugin>
524
      <plugin>
525
        <!-- Test coverage can be a useful indication of the quality of your 
526
          unit tests. It basically tells you how much of your code is actually run 
527
          by your unit tests, which, in turn, can give you a good idea of the tests' 
528
          quality -->
529
        <groupId>org.codehaus.mojo</groupId>
530
        <artifactId>cobertura-maven-plugin</artifactId>
531
        <version>2.4</version>
532
        <!-- <executions> <execution> <id>clean</id> <phase>clean</phase> 
533
          <goals> <goal>clean</goal> </goals> </execution> </executions> -->
534
      </plugin>
535
      <!-- -->
536
      <plugin>
537
        <groupId>org.apache.maven.plugins</groupId>
538
        <artifactId>maven-project-info-reports-plugin</artifactId>
539
        <version>2.8</version>
540
        <configuration>
541
          <!-- when the dependencyLocations option is enabled maven will 
542
            determine if resources are located within a given repository. If that repository 
543
            doesn’t exist anyomore or is just terribly slow and will produce tons of 
544
            line in the log starting with: '[ERROR] Unable to determine if resource ...' 
545
            This will slow down site build drastically, therefore we disable this option 
546
            here. -->
547
          <dependencyLocationsEnabled>false</dependencyLocationsEnabled>
548
        </configuration>
549
        <!-- just the deafault <reportSets> <reportSet> <reports> <report>dependencies</report> 
550
          <report>project-team</report> <report>mailing-list</report> <report>cim</report> 
551
          <report>issue-tracking</report> <report>license</report> <report>scm</report> 
552
          </reports> </reportSet> </reportSets> -->
553
      </plugin>
554
      <!-- The changes-maven-plugin plug-in uses a special XML file (src/changes/changes.xml) 
555
        to track releases and changes in each release -->
556
      <plugin>
557
        <groupId>org.apache.maven.plugins</groupId>
558
        <artifactId>maven-changes-plugin</artifactId>
559
        <version>2.3</version>
560
        <configuration>
561
          <issueLinkTemplatePerSystem>
562
            <default>%URL%/ticket/%ISSUE%</default>
563
          </issueLinkTemplatePerSystem>
564
        </configuration>
565
        <reportSets>
566
          <reportSet>
567
            <reports>
568
              <report>changes-report</report>
569
            </reports>
570
          </reportSet>
571
        </reportSets>
572
      </plugin>
573
      <!-- The changelog plug-in generates a nice report describing which 
574
        files have been changed and by whom -->
575
      <!-- <plugin> <groupId>org.codehaus.mojo</groupId> <artifactId>changelog-maven-plugin</artifactId> 
576
        </plugin> -->
577
    </plugins>
578

    
579
  </reporting>
580
  <!-- DISTRIBUTION MANAGEMENT -->
581
  <distributionManagement>
582
    <site>
583
      <id>cybertaxonomy.eu</id>
584
      <name>CDM Library Website</name>
585
      <url>scpexe://cybertaxonomy.eu/var/www/wp5.e-taxonomy.eu/cdmlib/</url>
586
    </site>
587
    <repository>
588
      <uniqueVersion>false</uniqueVersion>
589
      <id>cybertaxonomy.eu</id>
590
      <name>Edit Maven Repository</name>
591
      <url>scpexe://cybertaxonomy.eu/var/www/wp5.e-taxonomy.eu/mavenrepo/</url>
592
      <layout>default</layout>
593
    </repository>
594
  </distributionManagement>
595
  <!-- **** DEPENDENCIES **** -->
596
  <dependencies>
597
    <dependency>
598
      <!-- junit is required for all module tests, also those not depending on cdmlib-test, so it is added here on parent level with test scope -->
599
      <groupId>junit</groupId>
600
      <artifactId>junit</artifactId>
601
      <scope>test</scope>
602
    </dependency>
603
  </dependencies>
604
  <dependencyManagement>
605
    <dependencies>
606
      <dependency>
607
        <groupId>eu.etaxonomy</groupId>
608
        <artifactId>cdmlib-commons</artifactId>
609
        <version>${project.version}</version>
610
      </dependency>
611
      <dependency>
612
        <groupId>eu.etaxonomy</groupId>
613
        <artifactId>cdmlib-model</artifactId>
614
        <version>${project.version}</version>
615
      </dependency>
616
      <dependency>
617
        <groupId>eu.etaxonomy</groupId>
618
        <artifactId>cdmlib-api</artifactId>
619
        <version>${project.version}</version>
620
      </dependency>
621
      <dependency>
622
        <groupId>eu.etaxonomy</groupId>
623
        <artifactId>cdmlib-persistence</artifactId>
624
        <version>${project.version}</version>
625
      </dependency>
626
      <dependency>
627
        <groupId>eu.etaxonomy</groupId>
628
        <artifactId>cdmlib-services</artifactId>
629
        <version>${project.version}</version>
630
      </dependency>
631
      <dependency>
632
        <groupId>eu.etaxonomy</groupId>
633
        <artifactId>cdmlib-io</artifactId>
634
        <version>${project.version}</version>
635
      </dependency>
636
      <dependency>
637
        <groupId>eu.etaxonomy</groupId>
638
        <artifactId>cdmlib-remote</artifactId>
639
        <version>${project.version}</version>
640
      </dependency>
641
      <dependency>
642
        <groupId>eu.etaxonomy</groupId>
643
        <artifactId>cdmlib-remote-webapp</artifactId>
644
        <version>${project.version}</version>
645
      </dependency>
646
      <dependency>
647
        <groupId>eu.etaxonomy</groupId>
648
        <artifactId>cdm-server</artifactId>
649
        <version>${project.version}</version>
650
      </dependency>
651
      <dependency>
652
        <groupId>eu.etaxonomy</groupId>
653
        <artifactId>cdmlib-ext</artifactId>
654
        <version>${project.version}</version>
655
      </dependency>
656
      <dependency>
657
        <groupId>eu.etaxonomy</groupId>
658
        <artifactId>cdmlib-print</artifactId>
659
        <version>${project.version}</version>
660
      </dependency>
661
      
662
      <!--*********** JAXB********* -->
663
      <dependency>
664
        <groupId>jakarta.xml.bind</groupId>
665
        <artifactId>jakarta.xml.bind-api</artifactId>
666
        <version>${jaxb.version}</version>  <!-- not sure if jaxb.version is always the same -->
667
      </dependency>
668
<!--       <dependency> -->
669
<!--         replaced by jakarta.xml.bind-api -->
670
<!--         <groupId>javax.xml.bind</groupId> -->
671
<!--         <artifactId>jaxb-api</artifactId> -->
672
<!--         <version>2.3.1</version> -->
673
<!--         checked 2020-08 -->
674
<!--       </dependency> -->
675
      <dependency>
676
         <!-- dependency for jaxb-api -->
677
         <groupId>javax.activation</groupId>
678
         <artifactId>javax.activation-api</artifactId>
679
         <version>1.2.0</version>
680
         <!-- checked 2020-08 -->
681
      </dependency>
682
 	  <dependency>
683
		<groupId>org.glassfish.jaxb</groupId>
684
		<artifactId>jaxb-runtime</artifactId>
685
		<version>${jaxb.version}</version>
686
	  </dependency>
687
	  <dependency>
688
		<groupId>org.glassfish.jaxb</groupId>
689
		<artifactId>jaxb-jxc</artifactId>
690
		<version>${jaxb.version}</version>
691
	  </dependency>
692
      <dependency>
693
          <!-- currently required as xsom references older version -->
694
          <groupId>com.sun.xml.bind.external</groupId>
695
          <artifactId>relaxng-datatype</artifactId>
696
          <version>${jaxb.version}</version>
697
      </dependency>
698
      <dependency>
699
          <!-- jaxb-runtime dependency -->
700
          <groupId>jakarta.activation</groupId>
701
          <artifactId>jakarta.activation-api</artifactId>
702
          <version>1.2.2</version>
703
      </dependency>
704
      <!--  JAB END -->
705
      
706
	  <dependency>
707
	    <!-- only for version management org.apache.ant:ant depends in different versions from 
708
             org.unitils:unitils-easymock:3.4.2 and org.glassfish.jaxb:jaxb-jxc:2.2.11 -->
709
	    <groupId>org.apache.ant</groupId>
710
	    <artifactId>ant</artifactId>
711
	    <version>1.10.12</version>
712
	  </dependency>
713
      <!-- ******* hibernate uses slf4j ******* -->
714
      <dependency>
715
        <groupId>org.slf4j</groupId>
716
        <artifactId>slf4j-api</artifactId>
717
        <version>${slf4j.version}</version>
718
      </dependency>
719
      <dependency>
720
        <groupId>org.slf4j</groupId>
721
        <artifactId>slf4j-log4j12</artifactId>
722
        <version>${slf4j.version}</version>
723
      </dependency>
724
	  <dependency>
725
        <!-- try to generally exclude -nop as we try to use log4j12, this is done already for unitils -->
726
        <groupId>org.slf4j</groupId>
727
        <artifactId>slf4j-nop</artifactId>
728
        <version>${slf4j.version}</version>
729
      </dependency>
730
      <!-- ******* testing ******* -->
731
      <dependency>
732
        <groupId>junit</groupId>
733
        <artifactId>junit</artifactId>
734
        <version>4.13.2</version>
735
        <scope>test</scope>
736
      </dependency>
737
      <dependency>
738
        <groupId>com.carrotsearch</groupId>
739
        <artifactId>junit-benchmarks</artifactId>
740
        <version>0.7.2</version>
741
        <scope>test</scope>
742
      </dependency>
743
      <dependency>
744
        <groupId>org.unitils</groupId>
745
        <artifactId>unitils-core</artifactId>
746
        <version>${unitils.version}</version>
747
        <!-- <scope>test</scope> unscoped since we need this dependency at 
748
          compile time in persistence for H2DbSupport.java -->
749
      </dependency>
750
      <dependency>
751
        <groupId>org.unitils</groupId>
752
        <artifactId>unitils-database</artifactId>
753
        <version>${unitils.version}</version>
754
     <!--    <scope>test</scope>  -->
755
        <exclusions>
756
          <exclusion>
757
            <groupId>org.springframework</groupId>
758
            <artifactId>spring-jdbc</artifactId>
759
          </exclusion>
760
        </exclusions>
761
      </dependency>
762
      <dependency>
763
        <groupId>org.unitils</groupId>
764
        <artifactId>unitils-dbmaintainer</artifactId>
765
        <version>${unitils.version}</version>
766
     <!--    <scope>test</scope>  -->
767
        <exclusions>
768
          <exclusion>
769
            <groupId>org.hibernate</groupId>
770
            <artifactId>hibernate</artifactId>
771
          </exclusion>
772
          <exclusion>
773
            <groupId>org.slf4j</groupId>
774
            <artifactId>slf4j-nop</artifactId>
775
          </exclusion>
776
        </exclusions>
777
      </dependency>
778
      <dependency>
779
        <groupId>org.objenesis</groupId>
780
        <artifactId>objenesis</artifactId>
781
        <version>3.2</version>
782
      </dependency>
783
      <dependency>
784
        <groupId>org.unitils</groupId>
785
        <artifactId>unitils-dbunit</artifactId>
786
        <version>${unitils.version}</version>
787
     <!--    <scope>test</scope>  -->
788
      </dependency>
789
      <dependency>
790
        <groupId>org.unitils</groupId>
791
        <artifactId>unitils-easymock</artifactId>
792
        <version>${unitils.version}</version>
793
     <!--    <scope>test</scope>  -->
794
      </dependency>
795
      <dependency>
796
        <groupId>org.unitils</groupId>
797
        <artifactId>unitils-mock</artifactId>
798
        <version>${unitils.version}</version>
799
     <!--    <scope>test</scope>  -->
800
      </dependency>
801
      <dependency>
802
        <groupId>org.unitils</groupId>
803
        <artifactId>unitils-inject</artifactId>
804
        <version>${unitils.version}</version>
805
     <!--    <scope>test</scope>  -->
806
      </dependency>
807
      <dependency>
808
        <groupId>org.unitils</groupId>
809
        <artifactId>unitils-orm</artifactId>
810
        <version>${unitils.version}</version>
811
     <!--    <scope>test</scope>  -->
812
        <exclusions>
813
          <exclusion>
814
            <groupId>javax.persistence</groupId>
815
            <artifactId>persistence-api</artifactId>
816
          </exclusion>
817
        </exclusions>
818
      </dependency>
819
      <dependency>
820
        <groupId>org.unitils</groupId>
821
        <artifactId>unitils-spring</artifactId>
822
        <version>${unitils.version}</version>
823
     <!--    <scope>test</scope>  -->
824
      </dependency>
825
      <dependency>
826
        <groupId>xmlunit</groupId>
827
        <artifactId>xmlunit</artifactId>
828
        <version>1.6</version>
829
     <!--    <scope>test</scope>  -->
830
      </dependency>
831
  <!--    <dependency>
832
        <groupId>org.dbunit</groupId>
833
        <artifactId>dbunit</artifactId>
834
        <version>2.4.9</version>  -->
835
     <!--    <scope>test</scope>  -->
836
  <!--    </dependency>   -->
837
      <!-- dependency of unitils-database, but with lower number there , 
838
        higher number needed for compatibility with current hibernate and Java 1.6 
839
        PreparedStatement -->
840
      <dependency>
841
        <groupId>commons-dbcp</groupId>
842
        <artifactId>commons-dbcp</artifactId>
843
        <version>1.4</version>
844
        <!-- <scope>test</scope> -->
845
      </dependency>
846
	  <dependency>
847
		<groupId>eu.etaxonomy</groupId>
848
		<artifactId>cdmlib-test</artifactId>
849
     <!--    <scope>test</scope>  -->
850
		<version>${project.version}</version>
851
	  </dependency>
852
      <dependency>
853
        <!-- used in cdmlib-services for the EmailSendTest -->
854
        <groupId>org.subethamail</groupId>
855
        <artifactId>subethasmtp</artifactId>
856
        <version>3.1.7</version>
857
        <scope>test</scope>
858
      </dependency>
859
      <dependency>
860
        <groupId>javax.activation</groupId>
861
        <artifactId>activation</artifactId>
862
        <version>1.1.1</version>
863
      </dependency>
864
      <!-- ******* aspect ******* -->
865
      <dependency>
866
        <!-- not really needed as long as aspectjweaver is on classpath which is a superset of aspectjrt -->
867
        <groupId>org.aspectj</groupId>
868
        <artifactId>aspectjrt</artifactId>
869
        <version>${aspectj.version}</version>
870
      </dependency>
871
      <dependency>
872
        <groupId>org.aspectj</groupId>
873
        <artifactId>aspectjweaver</artifactId>
874
        <version>${aspectj.version}</version>
875
      </dependency>
876
      <!-- ******* VARIOUS ******* -->
877
      <dependency>
878
        <groupId>xml-resolver</groupId>
879
        <artifactId>xml-resolver</artifactId>
880
        <version>1.2</version>
881
        <!-- checked 2020-08 -->
882
      </dependency>
883
      
884
      <dependency>
885
        <groupId>log4j</groupId>
886
        <artifactId>log4j</artifactId>
887
        <version>1.2.17</version>
888
      </dependency>
889
      <dependency>
890
        <groupId>net.sf.opencsv</groupId>
891
        <artifactId>opencsv</artifactId>
892
        <version>2.3</version>
893
      </dependency>
894
      <dependency>
895
        <groupId>org.osgi</groupId>
896
        <artifactId>osgi.core</artifactId>
897
        <version>7.0.0</version>
898
      </dependency>
899
      <dependency>
900
        <groupId>cglib</groupId>
901
        <artifactId>cglib-nodep</artifactId>
902
        <version>${cglib.version}</version>
903
      </dependency>
904
      <!-- <dependency> -->
905
      <!-- we try to have only dependencies to cglib-nodep to reduce size and to avoid
906
           having 2 similar libraries. #9206  -->
907
<!--         <groupId>cglib</groupId> -->
908
<!--         <artifactId>cglib</artifactId> -->
909
<!--         <version>${cglib.version}</version> -->
910
<!--       </dependency> -->
911
      <dependency>
912
        <groupId>commons-lang</groupId>
913
        <artifactId>commons-lang</artifactId>
914
        <version>2.6</version>
915
      </dependency>
916
      <dependency>
917
        <groupId>org.apache.commons</groupId>
918
        <artifactId>commons-lang3</artifactId>
919
        <version>3.12.0</version>
920
      </dependency>
921
      <dependency>
922
        <groupId>commons-collections</groupId>
923
        <artifactId>commons-collections</artifactId>
924
        <version>3.2.2</version>
925
      </dependency>
926
      <dependency>
927
        <groupId>org.apache.httpcomponents</groupId>
928
        <artifactId>httpclient</artifactId>
929
        <version>${httpcomponents.version}</version>
930
      </dependency>
931
      <dependency>
932
        <groupId>org.apache.httpcomponents</groupId>
933
        <artifactId>httpcore</artifactId>
934
        <!-- Note: version differs from default httpcomponents version -->
935
        <version>4.4.15</version>
936
      </dependency>
937
      <dependency>
938
        <groupId>commons-io</groupId>
939
        <artifactId>commons-io</artifactId>
940
        <version>2.11.0</version>
941
      </dependency>
942
      <dependency>
943
          <groupId>org.apache.commons</groupId>
944
          <artifactId>commons-compress</artifactId>
945
          <version>1.21</version>
946
      </dependency>
947
      <dependency>
948
          <groupId>org.checkerframework</groupId>
949
          <artifactId>checker-qual</artifactId>
950
          <version>3.6.0</version>
951
      </dependency>
952
      <!-- only for version management, poi currently requires 1.6, commons-logging 
953
        1.1.1 requires 1.6, so we update here to the latest version -->
954
      <dependency>
955
        <groupId>commons-codec</groupId>
956
        <artifactId>commons-codec</artifactId>
957
        <version>1.15</version>
958
      </dependency>
959
      <!-- only for version management, httpcore:4.2.4, commons-beanutils:1.8.3, 
960
        commons-collections:3.2.1 currently require 1.1.1 , httpclient:4.2.3, spring-modules-cache 
961
        require 1.1 and batik-ext requires 1.0.4, so we update here to the latest 
962
        version 1.1.2, poi and springframework require 1.1.3 -->
963
      <dependency>
964
        <groupId>commons-logging</groupId>
965
        <artifactId>commons-logging</artifactId>
966
        <version>${commons-logging.version}</version>
967
      </dependency>
968
      <!-- only for version management, hibernate-commons-annotations:4.0.1.Final 
969
        requires 3.1.0.CR2 , so we update 
970
        here to the latest version 3.4.1.Final -->
971
      <dependency>
972
        <groupId>org.jboss.logging</groupId>
973
        <artifactId>jboss-logging</artifactId>
974
        <version>3.4.1.Final</version>
975
        <!-- checked 2020-08 -->
976
      </dependency>
977
<!-- 	  <dependency> -->
978
<!-- 	    see note in cdmib-persistence pom  -->
979
<!--         <groupId>javax.transaction</groupId> -->
980
<!--         <artifactId>jta</artifactId> -->
981
<!--         <version>1.1</version> -->
982
<!--       </dependency>   -->
983
		
984
      <!-- TODO xerces xmlParserAPIs duplicates many classes from jre and 
985
        xml-apis. It is a dependency that comes with xom:xom -->
986
      <dependency>
987
        <groupId>org.apache.jena</groupId>
988
        <artifactId>jena-tdb</artifactId>
989
        <version>1.1.2</version>
990
      </dependency>
991

    
992
      <dependency>
993
        <groupId>net.sf.ezmorph</groupId>
994
        <artifactId>ezmorph</artifactId>
995
        <version>1.0.6</version>
996
      </dependency>
997
      <dependency>
998
        <groupId>commons-beanutils</groupId>
999
        <artifactId>commons-beanutils</artifactId>
1000
        <version>1.9.4</version>
1001
      </dependency>
1002
      <dependency>
1003
        <groupId>net.sf.json-lib</groupId>
1004
        <artifactId>json-lib</artifactId>
1005
        <version>2.4</version>
1006
        <!-- classifier required as json-lib exists on maven central as json-lib-2.4-jdk15.jar and xxx-jdk13.jar, see #9887 -->
1007
        <classifier>jdk15</classifier>
1008
      </dependency>
1009
      <!-- media  -->
1010
      <dependency>
1011
        <groupId>org.devlib.schmidt</groupId>
1012
        <artifactId>imageinfo</artifactId>
1013
        <version>1.9</version>
1014
      </dependency>
1015
       <dependency>
1016
        <groupId>de.digitalcollections.iiif</groupId>
1017
        <artifactId>iiif-apis</artifactId>
1018
        <version>0.3.9</version>
1019
      </dependency>
1020
<!--       <dependency> -->
1021
<!--         only for version management iterators depends in different versions from -->
1022
<!--               de.digitalcollections.iiif:iiif-apis:0.3.9 -->
1023
<!--       	<groupId>org.dmfs</groupId> -->
1024
<!--       	<artifactId>iterators</artifactId> -->
1025
<!--       	<version>1.5</version> -->
1026
<!--       </dependency> -->
1027
      <!--         -->
1028
      <dependency>
1029
        <groupId>org.apache.poi</groupId>
1030
        <artifactId>poi</artifactId>
1031
        <version>${poi.version}</version>
1032
      </dependency>
1033
      <dependency>
1034
        <groupId>org.apache.poi</groupId>
1035
        <artifactId>poi-ooxml-schemas</artifactId>
1036
        <version>${poi.version}</version>
1037
      </dependency>
1038
      <dependency>
1039
        <groupId>org.apache.poi</groupId>
1040
        <artifactId>poi-ooxml</artifactId>
1041
        <version>${poi.version}</version>
1042
      </dependency>
1043
      <dependency>
1044
        <groupId>org.apache.poi</groupId>
1045
        <artifactId>ooxml-schemas</artifactId>
1046
        <version>1.4</version>
1047
      </dependency>
1048
      <!--       <dependency> -->
1049
<!-- maybe needed in cdmlib-io, see https://poi.apache.org/help/faq.html  question 3 on when to use ooxml-schemas and when poi-ooxml-schemas  -->
1050
<!--         <groupId>org.apache.poi</groupId> -->
1051
<!--         <artifactId>ooxml-schemas</artifactId> -->
1052
<!--         <version>1.4</version> -->
1053
<!--       </dependency> -->
1054
      <dependency>
1055
     	<!-- only for version management xmlbeans depends in different versions from 
1056
        org.apache.poi:poi-ooxml-schemas:3.13 and org.apache.poi:ooxml-schemas:1.4 -->
1057
      	<groupId>org.apache.xmlbeans</groupId>
1058
      	<artifactId>xmlbeans</artifactId>
1059
      	<version>3.1.0</version>
1060
        <!-- checked 2020-08 -->
1061
      </dependency>
1062
      <dependency>
1063
        <groupId>org.docx4j</groupId>
1064
        <artifactId>docx4j</artifactId>
1065
        <version>6.1.2</version>
1066
      </dependency>
1067
      <dependency>
1068
        <!-- only for version management jcl-over-slf4j depends in different versions from 
1069
        org.docx4j:docx4j:6.0.1 and org.apache.jena:jjena-tdb:1.1.2 -->
1070
        <groupId>org.slf4j</groupId>
1071
        <artifactId>jcl-over-slf4j</artifactId>
1072
        <version>1.7.25</version>
1073
      </dependency>
1074
      <dependency>
1075
        <!-- only for version management xalan depends in different versions from 
1076
        org.docx4j:docx4j:6.0.1 and xom:xom:1.2.5 -->
1077
      	<groupId>xalan</groupId>
1078
      	<artifactId>xalan</artifactId>
1079
      	<version>2.7.2</version>
1080
      </dependency>
1081
      <dependency>
1082
        <!-- only for version management org.apache.xmlgraphics:xmlgraphics-commons depends in different versions from 
1083
        org.docx4j:docx4j:6.0.1 and org.apache.xmlgraphics:fop:1.1 -->
1084
      	<groupId>org.apache.xmlgraphics</groupId>
1085
      	<artifactId>xmlgraphics-commons</artifactId>
1086
      	<version>2.6</version>
1087
      </dependency>
1088
      <dependency>
1089
        <groupId>org.apache.commons</groupId>
1090
        <artifactId>commons-imaging</artifactId>
1091
        <version>1.0-alpha2</version>
1092
      </dependency>
1093
      <dependency>
1094
        <groupId>org.cybertaxonomy.media</groupId>
1095
        <artifactId>media-info-model</artifactId>
1096
        <version>1.2.0</version>
1097
      </dependency>
1098
      <!-- joda-time -->
1099
      <dependency>
1100
        <groupId>joda-time</groupId>
1101
        <artifactId>joda-time</artifactId>
1102
        <version>2.10.13</version>
1103
      </dependency>
1104
	  <!-- maybe replaced by usertype.core -->
1105
      <dependency>
1106
        <groupId>org.jadira.usertype</groupId>
1107
        <artifactId>usertype.jodatime</artifactId>
1108
        <version>2.0.1</version>
1109
      </dependency>
1110
      <dependency>
1111
        <groupId>org.apache.lucene</groupId>
1112
        <artifactId>lucene-core</artifactId>
1113
        <version>${lucene.version}</version>
1114
      </dependency>
1115
	  <dependency>
1116
		<groupId>org.apache.lucene</groupId>
1117
		<artifactId>lucene-suggest</artifactId>
1118
		<version>${lucene.version}</version>
1119
	  </dependency>
1120
	  <dependency>
1121
		<groupId>org.apache.lucene</groupId>
1122
		<artifactId>lucene-analyzers-common</artifactId>
1123
		<version>${lucene.version}</version>
1124
	  </dependency>
1125
	  <dependency>
1126
        <groupId>org.apache.lucene</groupId>
1127
        <artifactId>lucene-queryparser</artifactId>
1128
        <version>${lucene.version}</version>
1129
      </dependency>
1130
      <dependency>
1131
        <groupId>org.apache.lucene</groupId>
1132
        <artifactId>lucene-highlighter</artifactId>
1133
        <version>${lucene.version}</version>
1134
      </dependency>
1135
      <dependency>
1136
        <groupId>org.apache.lucene</groupId>
1137
        <artifactId>lucene-grouping</artifactId>
1138
        <version>${lucene.version}</version>
1139
      </dependency>
1140
      <dependency>
1141
        <groupId>org.apache.lucene</groupId>
1142
        <artifactId>lucene-join</artifactId>
1143
        <version>${lucene.version}</version>
1144
      </dependency>
1145
      <dependency>
1146
        <groupId>org.apache.lucene</groupId>
1147
        <artifactId>lucene-backward-codecs</artifactId>
1148
        <version>${lucene.version}</version>
1149
      </dependency>
1150
      <dependency>
1151
        <groupId>org.apache.lucene</groupId>
1152
        <artifactId>lucene-misc</artifactId>
1153
        <version>${lucene.version}</version>
1154
      </dependency>
1155
      <dependency>
1156
        <groupId>org.apache.lucene</groupId>
1157
        <artifactId>lucene-facet</artifactId>
1158
        <version>${lucene.version}</version>
1159
      </dependency>
1160
            
1161
      <dependency>
1162
        <groupId>com.ibm.lsid</groupId>
1163
        <artifactId>lsid-client</artifactId>
1164
        <version>1.1.2</version>
1165
      </dependency>
1166
      <dependency>
1167
        <groupId>com.ibm.lsid</groupId>
1168
        <artifactId>lsid-server</artifactId>
1169
        <version>1.1.2</version>
1170
      </dependency>
1171
      <dependency>
1172
        <groupId>wsdl4j</groupId>
1173
        <artifactId>wsdl4j</artifactId>
1174
        <version>1.6.3</version>
1175
      </dependency>
1176
<!--       <dependency> -->
1177
<!--         <groupId>net.sf.dozer</groupId> -->
1178
<!--         <artifactId>dozer</artifactId> -->
1179
<!--         <version>5.5.1</version> -->
1180
<!--       </dependency> -->
1181
      <dependency>
1182
          <groupId>com.github.dozermapper</groupId>
1183
          <artifactId>dozer-core</artifactId>
1184
          <version>${dozer.version}</version>
1185
      </dependency>
1186
      <dependency>
1187
        <groupId>com.github.dozermapper</groupId>
1188
        <artifactId>dozer-spring4</artifactId>
1189
        <version>${dozer.version}</version>
1190
      </dependency>
1191
      <dependency>
1192
        <groupId>net.sf.ehcache</groupId>
1193
        <artifactId>ehcache</artifactId>
1194
        <version>2.10.6</version>
1195
      </dependency>
1196
      <!-- ******* XML ******* -->
1197
      <dependency>
1198
<!--        xml-apis seems to be ALMOST fully included in java8 but ElementTraversal seems to be missing, therefore SDDDocumentBuilder does not compile -->
1199
        <groupId>xml-apis</groupId>
1200
        <artifactId>xml-apis</artifactId>
1201
<!--             WARNING: do not upgrade to later versions 2.0.x of xml-apis -->
1202
<!--             since these are effectivly reloaded to the early beta version -->
1203
<!--             1.0.b2 -->
1204
        <version>1.4.01</version>
1205
      </dependency>
1206
      <dependency>
1207
        <groupId>xerces</groupId>
1208
        <artifactId>xercesImpl</artifactId>
1209
        <version>2.12.1</version>
1210
        <!-- checked 2021-12 -->
1211
      </dependency>
1212
      <!-- >batik-ext required by Xerces 2.11.0 for class ElementTraversal, 
1213
        as this is not included anymore in xml-apis 2.x -->
1214
<!--       <dependency> -->
1215
<!--         <groupId>org.apache.xmlgraphics</groupId> -->
1216
<!--         <artifactId>batik-ext</artifactId> -->
1217
<!--         <version>1.13</version> -->
1218
<!--       </dependency> -->
1219
      <dependency> <!-- required by cdmlib-print -->
1220
        <groupId>org.apache.xmlgraphics</groupId>
1221
        <artifactId>fop</artifactId>
1222
        <version>2.6</version>
1223
      </dependency>
1224
      <dependency>
1225
        <groupId>org.odftoolkit</groupId>
1226
        <artifactId>odfdom-java</artifactId>
1227
        <version>0.8.7</version>
1228
      </dependency>
1229
      <dependency>
1230
          <!-- used in eu.etaxonomy.cdm.io.markup and for swagger -->
1231
          <groupId>com.google.guava</groupId>
1232
          <artifactId>guava</artifactId>
1233
          <version>31.0.1-jre</version>
1234
      </dependency>
1235
      <!-- last jdom 1.x version -->
1236
	  <dependency>
1237
        <groupId>org.jdom</groupId>
1238
        <artifactId>jdom</artifactId>
1239
        <version>1.1.3</version>
1240
      </dependency>
1241
	  <!-- jdom2 may exist in parallel to jdom(1) as it uses a different package structure -->
1242
	  <dependency>
1243
		 <groupId>org.jdom</groupId>
1244
		 <artifactId>jdom2</artifactId>
1245
		 <version>2.0.6</version>
1246
	  </dependency>
1247
      <dependency>
1248
        <groupId>com.thoughtworks.xstream</groupId>
1249
        <artifactId>xstream</artifactId>
1250
        <version>1.4.14</version>
1251
      </dependency>
1252
      <dependency>
1253
      <groupId>xmlpull</groupId>
1254
        <artifactId>xmlpull</artifactId>
1255
        <version>1.2.0</version>
1256
      </dependency>
1257
      <dependency>
1258
        <groupId>xpp3</groupId>
1259
        <artifactId>xpp3</artifactId>
1260
        <version>1.1.4c</version>
1261
      </dependency>
1262
<!--       <dependency> -->
1263
<!--        stax is part of java8 and therefore not needed anymore -->
1264
<!--         <groupId>stax</groupId> -->
1265
<!--         <artifactId>stax</artifactId> -->
1266
<!--         <version>1.2.0</version> -->
1267
<!--       </dependency> -->
1268
      <dependency>
1269
        <groupId>xom</groupId>
1270
        <artifactId>xom</artifactId>
1271
        <version>1.3.7</version>
1272
        <exclusions>
1273
          <!-- need to exclude com.ibm.icu:icu4j since it contains an invalid 
1274
            file which causes the jetty-maven-plugin to fail see http://stackoverflow.com/questions/3026956/javassist-failure-in-hibernate-invalid-constant-type-60 -->
1275
          <exclusion>
1276
            <groupId>com.ibm.icu</groupId>
1277
            <artifactId>icu4j</artifactId>
1278
          </exclusion>
1279
        </exclusions>
1280
      </dependency>
1281
      <!-- ******* SAXON (ViBRANT)******* -->
1282
      <dependency>
1283
        <groupId>net.sf.saxon</groupId>
1284
        <artifactId>Saxon-HE</artifactId>
1285
        <version>10.6</version>
1286
      </dependency>
1287
      <!-- ******* http components (ViBRANT)******* -->
1288
      <dependency>
1289
        <groupId>org.apache.httpcomponents</groupId>
1290
        <artifactId>httpmime</artifactId>
1291
        <version>${httpcomponents.version}</version>
1292
      </dependency>
1293
      <!-- ***** json ******************** -->
1294
      <dependency>
1295
        <groupId>org.json</groupId>
1296
        <artifactId>json</artifactId>
1297
        <version>20200518</version>
1298
      </dependency>
1299
      <!-- ******* HIBERNATE / EJB3 ******* -->
1300
      <dependency>
1301
        <groupId>org.hibernate.javax.persistence</groupId>
1302
        <artifactId>hibernate-jpa-2.1-api</artifactId>
1303
        <version>1.0.2.Final</version>
1304
      </dependency>
1305
      <dependency>
1306
        <groupId>org.hibernate</groupId>
1307
        <artifactId>hibernate-core</artifactId>
1308
        <version>${hibernate.version}</version>
1309
      </dependency>
1310
      <dependency>
1311
        <groupId>org.hibernate</groupId>
1312
        <artifactId>hibernate-entitymanager</artifactId>
1313
        <version>${hibernate.version}</version>
1314
      </dependency>
1315
      <dependency>
1316
        <groupId>org.hibernate</groupId>
1317
        <artifactId>hibernate-envers</artifactId>
1318
        <version>${hibernate.version}</version>
1319
      </dependency>
1320
      <dependency>
1321
        <groupId>org.hibernate</groupId>
1322
        <artifactId>hibernate-c3p0</artifactId>
1323
        <version>${hibernate.version}</version>
1324
      </dependency>
1325
      <dependency>
1326
        <groupId>com.mchange</groupId>
1327
        <artifactId>c3p0</artifactId>
1328
        <!-- 
1329
          IMPORTANT!!!
1330
          when changing the version of this artifact, the 
1331
          version in cdm-server pom.xml must be changed 
1332
          the same otherwise db connections through jndi 
1333
          will not work!
1334
		  NOTE: not so critical anymore as we use cdmlib-db
1335
		  now for both projects
1336
        -->
1337
        <version>0.9.5.2</version>
1338
      </dependency>
1339
      <dependency>
1340
        <groupId>com.mchange</groupId>
1341
        <artifactId>mchange-commons-java</artifactId>
1342
        <!-- mchange-commons-java needs to match the version as defined in the c3p0/pom.xml -->
1343
        <version>0.2.11</version>
1344
      </dependency>
1345
      <dependency>
1346
        <groupId>org.hibernate.common</groupId>
1347
        <artifactId>hibernate-commons-annotations</artifactId>
1348
        <version>5.1.0.Final</version>
1349
      </dependency>
1350
      <dependency>
1351
        <groupId>org.hibernate</groupId>
1352
        <artifactId>hibernate-search-orm</artifactId>
1353
        <version>${hibernate-search.version}</version>
1354
      </dependency>
1355
      <dependency>
1356
        <groupId>org.hibernate</groupId>
1357
        <artifactId>hibernate-search-engine</artifactId>
1358
        <version>${hibernate-search.version}</version>
1359
      </dependency>
1360
      <dependency>
1361
        <groupId>org.javassist</groupId>
1362
        <artifactId>javassist</artifactId>
1363
        <version>3.28.0-GA</version>
1364
      </dependency>
1365

    
1366
      <!-- ******* SPRING ******* -->
1367
      <dependency>
1368
        <groupId>org.springframework</groupId>
1369
        <artifactId>spring-core</artifactId>
1370
        <version>${spring.version}</version>
1371
      </dependency>
1372
      <dependency>
1373
        <groupId>org.springframework</groupId>
1374
        <artifactId>spring-context</artifactId>
1375
        <version>${spring.version}</version>
1376
      </dependency>
1377
      <dependency>
1378
        <groupId>org.springframework</groupId>
1379
        <artifactId>spring-beans</artifactId>
1380
        <version>${spring.version}</version>
1381
      </dependency>
1382
      <dependency>
1383
        <groupId>org.springframework</groupId>
1384
        <artifactId>spring-orm</artifactId>
1385
        <version>${spring.version}</version>
1386
      </dependency>
1387
      <dependency>
1388
        <groupId>org.springframework</groupId>
1389
        <artifactId>spring-jdbc</artifactId>
1390
        <version>${spring.version}</version>
1391
      </dependency>
1392
      <dependency>
1393
        <groupId>org.springframework</groupId>
1394
        <artifactId>spring-tx</artifactId>
1395
        <version>${spring.version}</version>
1396
      </dependency>
1397
      <dependency>
1398
        <groupId>org.springframework</groupId>
1399
        <artifactId>spring-test</artifactId>
1400
        <version>${spring.version}</version>
1401
      </dependency>
1402
      <dependency>
1403
        <groupId>org.springframework</groupId>
1404
        <artifactId>spring-web</artifactId>
1405
        <version>${spring.version}</version>
1406
      </dependency>
1407
	  <dependency>
1408
      	<groupId>org.springframework</groupId>
1409
        <artifactId>spring-webmvc</artifactId>
1410
        <version>${spring.version}</version>
1411
      </dependency>
1412
      <dependency>
1413
        <groupId>org.springframework</groupId>
1414
        <artifactId>spring-aop</artifactId>
1415
        <version>${spring.version}</version>
1416
      </dependency>
1417
      <dependency>
1418
        <groupId>org.springframework</groupId>
1419
        <artifactId>spring-aspects</artifactId>
1420
        <version>${spring.version}</version>
1421
      </dependency>
1422
      <dependency>
1423
        <groupId>org.springframework</groupId>
1424
        <artifactId>spring-expression</artifactId>
1425
        <version>${spring.version}</version>
1426
      </dependency>
1427
      <dependency>
1428
        <groupId>org.springframework</groupId>
1429
        <artifactId>spring-context-support</artifactId>
1430
        <version>${spring.version}</version>
1431
      </dependency>
1432
      <dependency>
1433
        <groupId>org.springframework</groupId>
1434
        <artifactId>spring-oxm</artifactId>
1435
        <version>${spring.version}</version>
1436
      </dependency>
1437
      <dependency>
1438
        <groupId>org.springframework.security</groupId>
1439
        <artifactId>spring-security-core</artifactId>
1440
        <version>${spring-security.version}</version>
1441
      </dependency>
1442
      <dependency>
1443
        <groupId>org.springframework.security</groupId>
1444
        <artifactId>spring-security-config</artifactId>
1445
        <version>${spring-security.version}</version>
1446
      </dependency>
1447
      <dependency>
1448
        <groupId>org.springframework.security</groupId>
1449
        <artifactId>spring-security-web</artifactId>
1450
        <version>${spring-security.version}</version>
1451
      </dependency>
1452
      <dependency>
1453
        <groupId>org.springframework.security.oauth</groupId>
1454
        <artifactId>spring-security-oauth2</artifactId>
1455
        <version>${spring-security-oauth2.version}</version>
1456
      </dependency>
1457
      <dependency>
1458
        <groupId>org.springframework.cloud</groupId>
1459
        <artifactId>spring-cloud-security</artifactId>
1460
        <version>${spring-security.version}</version>
1461
      </dependency>
1462
      <dependency>
1463
        <!-- required by spring security core, but not needed anymore in spring security 5.x  -->
1464
        <groupId>aopalliance</groupId>
1465
        <artifactId>aopalliance</artifactId>
1466
        <version>1.0</version>
1467
      </dependency>
1468

    
1469
      <!-- ******* SERVLET/JSP/JSF ******* -->
1470
      <dependency>
1471
        <groupId>javax.servlet</groupId>
1472
        <artifactId>javax.servlet-api</artifactId>
1473
        <version>4.0.1</version>
1474
        <!-- checked 2020-08 -->
1475
      </dependency>
1476

    
1477
      <!-- yourkit profiler api controller (used in ..) -->
1478
      <dependency>
1479
        <groupId>com.yourkit</groupId>
1480
        <artifactId>yjp-controller-api-redist</artifactId>
1481
        <version>2015-build-15086</version>
1482
        <scope>test</scope>
1483
      </dependency>
1484
      <!-- For Validation -->
1485
      <dependency>
1486
        <groupId>javax.validation</groupId>
1487
        <artifactId>validation-api</artifactId>
1488
        <version>2.0.1.Final</version>
1489
        <!-- checked 2020-08 -->
1490
      </dependency>
1491
      <dependency>
1492
        <groupId>org.hibernate.validator</groupId>
1493
        <artifactId>hibernate-validator</artifactId>
1494
        <version>${hibernate-validator.version}</version>
1495
      </dependency>
1496
      <dependency>
1497
        <groupId>com.fasterxml</groupId>
1498
        <artifactId>classmate</artifactId>
1499
        <version>1.5.1</version>     
1500
        <!-- checked 2020-08 -->
1501
      </dependency>
1502
	  <dependency>
1503
        <groupId>javax.el</groupId>
1504
        <artifactId>javax.el-api</artifactId>
1505
        <version>3.0.0</version>
1506
        <!-- checked 2020-08 -->
1507
	  </dependency>
1508
      <dependency>
1509
          <groupId>jakarta.validation</groupId>
1510
          <artifactId>jakarta.validation-api</artifactId>
1511
          <version>3.0.0</version>
1512
          <!-- checked 2020-08 -->
1513
      </dependency>
1514
	  <dependency>
1515
		 <groupId>org.glassfish.web</groupId>
1516
		 <artifactId>javax.el</artifactId>
1517
		 <version>2.2.6</version>
1518
	  </dependency>
1519
	  <dependency>
1520
	     <groupId>org.hibernate.validator</groupId>
1521
         <artifactId>hibernate-validator-cdi</artifactId>
1522
         <version>${hibernate-validator.version}</version>
1523
	  </dependency>
1524
      <dependency>
1525
         <!-- not clear if needed, but if needed v8.0 should be used to avoid problems with javax.validation.BootstrapConfiguration -->
1526
         <!-- it was a (currently excluded) transitiv dependency from org.geotools/gt-referencing  used in cdmlib-ext -->
1527
         <groupId>javax</groupId>
1528
         <artifactId>javaee-api</artifactId>
1529
         <version>8.0.1</version>
1530
      </dependency>
1531
	  
1532
      <!-- for ikey-plus -->
1533
      <dependency>
1534
        <groupId>identificationKeyAPI</groupId>
1535
        <artifactId>identificationKeyAPI</artifactId>
1536
        <version>1.0</version>   <!-- was <version>1.0-SNAPSHOT</version> -->
1537
      </dependency>
1538
      <dependency>
1539
        <groupId>com.itextpdf</groupId>
1540
        <artifactId>itextpdf</artifactId>
1541
        <version>5.5.13.2</version>
1542
        <scope>compile</scope>
1543
      </dependency>
1544
      <!-- AptView -->
1545
      <dependency>
1546
        <groupId>org.apache.maven.doxia</groupId>
1547
        <artifactId>doxia-module-apt</artifactId>
1548
        <version>${doxia.version}</version>
1549
      </dependency>
1550
      <dependency>
1551
        <groupId>org.apache.maven.doxia</groupId>
1552
        <artifactId>doxia-module-xhtml</artifactId>
1553
        <version>${doxia.version}</version>
1554
      </dependency>
1555
      <dependency>
1556
        <!-- managing version of plexus-utils to avoid multiple versions (3.0.15, 1.4.5) of the artifact -->
1557
      	<groupId>org.codehaus.plexus</groupId>
1558
      	<artifactId>plexus-utils</artifactId>
1559
      	<version>3.4.1</version>
1560
        <!-- checked 2022-01 -->
1561
      </dependency>
1562
      <!-- swagger (rest service doc) -->
1563
      <dependency>
1564
        <groupId>io.swagger</groupId>
1565
        <artifactId>swagger-annotations</artifactId>
1566
        <!-- should match the springfox-swagger2 depends on -->
1567
        <version>1.5.10</version>
1568
      </dependency>
1569

    
1570
      <!-- dependencies for swagger-springmvc, added explicitely -->
1571
      <dependency>
1572
        <groupId>com.fasterxml.jackson.core</groupId>
1573
        <artifactId>jackson-databind</artifactId>
1574
        <version>${jackson.version}</version>
1575
      </dependency>
1576
      <dependency>
1577
        <groupId>com.fasterxml.jackson.core</groupId>
1578
        <artifactId>jackson-core</artifactId>
1579
        <version>${jackson.version}</version>
1580
      </dependency>
1581
      <dependency>
1582
        <groupId>com.fasterxml.jackson.core</groupId>
1583
        <artifactId>jackson-annotations</artifactId>
1584
        <version>${jackson.version}</version>
1585
      </dependency> 
1586
      <!-- END of dependencies for swagger-springmvc, added explicitely -->
1587
      <dependency>
1588
        <groupId>io.springfox</groupId>
1589
        <artifactId>springfox-swagger2</artifactId>
1590
        <version>2.6.1</version>
1591
      </dependency>
1592
      
1593
      <!-- ******* DATABASES DRIVER ******* -->
1594
      <dependency>
1595
        <groupId>mysql</groupId>
1596
        <artifactId>mysql-connector-java</artifactId>
1597
        <version>8.0.27</version>
1598
      </dependency>
1599
      <dependency>
1600
        <groupId>org.mariadb.jdbc</groupId>
1601
        <artifactId>mariadb-java-client</artifactId>
1602
        <version>2.6.2</version>
1603
      </dependency>
1604
      <dependency>
1605
         <groupId>org.postgresql</groupId>
1606
         <artifactId>postgresql</artifactId>
1607
         <version>42.3.1</version>
1608
      </dependency>
1609
	  <dependency>
1610
        <groupId>com.h2database</groupId>
1611
        <artifactId>h2</artifactId>
1612
        <version>1.4.190</version>
1613
      </dependency>
1614
      <!-- SQL Server -->
1615
      <dependency>
1616
        <groupId>com.microsoft.sqlserver</groupId>
1617
        <artifactId>mssql-jdbc</artifactId>
1618
        <version>9.4.1.jre8</version>
1619
      </dependency>
1620
	  <dependency>
1621
        <groupId>org.hsqldb</groupId>
1622
        <artifactId>hsqldb</artifactId>
1623
        <version>${hsqldb.version}</version>
1624
      </dependency>
1625
      <dependency>
1626
        <!-- SQL Server and Sybase -->
1627
        <groupId>net.sourceforge.jtds</groupId>
1628
        <artifactId>jtds</artifactId>
1629
        <version>1.3.1</version>
1630
      </dependency>
1631
      <dependency>
1632
        <groupId>oracle</groupId>
1633
        <artifactId>ojdbc14</artifactId>
1634
        <version>10.2.0.4.0</version>
1635
      </dependency>
1636
      <!--    <dependency>
1637
        <groupId>ojdbc</groupId>
1638
        <artifactId>ojdbc</artifactId>
1639
        <version>14</version>
1640
        </dependency>   -->      
1641
      <!-- GIS/KML -->
1642
	  <dependency>
1643
	     <groupId>de.micromata.jak</groupId>
1644
	     <artifactId>JavaAPIforKml</artifactId>
1645
	     <version>2.2.1</version>
1646
	  </dependency>
1647
	  <dependency>
1648
	    <groupId>org.geotools</groupId>
1649
	    <artifactId>gt-opengis</artifactId>
1650
	    <version>${geotools.version}</version>
1651
	  </dependency>
1652
	  <dependency>
1653
	    <groupId>org.geotools</groupId>
1654
	    <artifactId>gt-referencing</artifactId>
1655
	    <version>${geotools.version}</version>
1656
	  </dependency>
1657
	  <dependency>
1658
	    <groupId>org.geotools</groupId>
1659
	    <artifactId>gt-epsg-wkt</artifactId>
1660
	    <version>${geotools.version}</version>
1661
	  </dependency>
1662
	  <dependency>
1663
	    <groupId>org.geotools</groupId>
1664
	    <artifactId>gt-main</artifactId>
1665
	    <version>${geotools.version}</version>
1666
	  </dependency>
1667
    
1668
      <dependency>
1669
         <groupId>com.sun</groupId>
1670
         <artifactId>tools</artifactId>
1671
         <version>1.8.0</version>
1672
      </dependency>
1673
      <dependency>
1674
        <!-- Email functionality (used in cdmlib-services) -->
1675
          <groupId>com.sun.mail</groupId>
1676
          <artifactId>javax.mail</artifactId>
1677
          <version>${javax.mail.version}</version>
1678
      </dependency>
1679
      <dependency>
1680
        <!-- only needed for PasswordResetService, may be replaced by Thymeleaf -->
1681
        <groupId>org.apache.commons</groupId>
1682
        <artifactId>commons-text</artifactId>
1683
        <version>1.9</version>
1684
      </dependency>
1685
      <dependency>
1686
        <groupId>org.passay</groupId>
1687
        <artifactId>passay</artifactId>
1688
        <version>1.6.1</version>
1689
      </dependency>
1690
   </dependencies>    
1691
  </dependencyManagement>
1692
</project>
(6-6/6)