Project

General

Profile

Download (23.9 KB) Statistics
| Branch: | Tag: | Revision:
1
<?xml version="1.0" encoding="UTF-8"?>
2
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
3
  <modelVersion>4.0.0</modelVersion>
4
  <groupId>eu.etaxonomy</groupId>
5
  <artifactId>cdm-vaadin</artifactId>
6
  <packaging>war</packaging>
7
  <version>5.19.0-SNAPSHOT</version>
8
  <name>Vaadin Web Application</name>
9
  <properties>
10
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
11
    <vaadin.version>7.7.13</vaadin.version>
12
    <vaadin-spring.version>1.2.0</vaadin-spring.version>
13
    <vaadin.plugin.version>${vaadin.version}</vaadin.plugin.version>
14
    <vaadin-spring-addon-eventbus.version>2.0.0.RELEASE</vaadin-spring-addon-eventbus.version>
15
    <cdmlib.version>5.19.0-SNAPSHOT</cdmlib.version>
16
    <unitils.version>3.4.2</unitils.version>
17
    <spring-boot.version>1.3.1.RELEASE</spring-boot.version>
18
    <!-- has spring 4.2.4-RELEASE as dependency --> 
19
    <!-- 
20
        lucene.version must match the version as defined in cdmlib
21
    -->
22
    <lucene.version>5.4.1</lucene.version>
23
    <maven.compiler.source>1.8</maven.compiler.source>
24
    <maven.compiler.target>1.8</maven.compiler.target>
25
  </properties>
26
  <prerequisites>
27
    <maven>3.2.3</maven>
28
  </prerequisites>
29
  <repositories>
30
    <!-- the cdm internal repository -->
31
    <repository>
32
      <id>EditRepository</id>
33
      <url>http://cybertaxonomy.eu/mavenrepo/</url>
34
    </repository>
35
    <!-- current spring source repositories -->
36
    <repository>
37
      <id>SpringSource Enterprise Bundle Repository - External Bundle Milestones</id>
38
      <url>http://repository.springsource.com/maven/bundles/milestone</url>
39
    </repository>
40
    <repository>
41
      <id>SpringSource Enterprise Bundle Repository - SpringSource Bundle Releases</id>
42
      <url>http://repository.springsource.com/maven/bundles/release</url>
43
    </repository>
44
    <repository>
45
      <id>SpringSource Enterprise Bundle Repository - External Bundle Releases</id>
46
      <url>http://repository.springsource.com/maven/bundles/external</url>
47
    </repository>
48
    <repository>
49
      <id>vaadin-addons</id>
50
      <url>http://maven.vaadin.com/vaadin-addons</url>
51
    </repository>
52
    <repository>
53
      <id>vaadin-snapshots</id>
54
      <url>http://oss.sonatype.org/content/repositories/vaadin-snapshots/</url>
55
      <releases>
56
        <enabled>false</enabled>
57
      </releases>
58
      <snapshots>
59
        <enabled>true</enabled>
60
      </snapshots>
61
    </repository>
62
  </repositories>
63
  <pluginRepositories>
64
    <pluginRepository>
65
      <id>vaadin-snapshots</id>
66
      <url>http://oss.sonatype.org/content/repositories/vaadin-snapshots/</url>
67
      <releases>
68
        <enabled>false</enabled>
69
      </releases>
70
      <snapshots>
71
        <enabled>true</enabled>
72
      </snapshots>
73
    </pluginRepository>
74
  </pluginRepositories>
75
  <dependencyManagement>
76
    <dependencies>
77
      <dependency>
78
        <groupId>eu.etaxonomy</groupId>
79
        <artifactId>cdmlib-parent</artifactId>
80
        <version>${cdmlib.version}</version>
81
        <type>pom</type>
82
        <scope>import</scope>
83
      </dependency>
84
      <dependency>
85
        <groupId>org.springframework.boot</groupId>
86
        <artifactId>spring-boot-starter-parent</artifactId>
87
        <version>${spring-boot.version}</version>
88
        <type>pom</type>
89
        <scope>import</scope>
90
      </dependency>
91
      <dependency>
92
        <groupId>com.vaadin</groupId>
93
        <artifactId>vaadin-bom</artifactId>
94
        <version>${vaadin.version}</version>
95
        <type>pom</type>
96
        <scope>import</scope>
97
      </dependency>
98
      <dependency>
99
        <!-- Try updating in cdmlib to 20090211 -->
100
        <groupId>org.json</groupId>
101
        <artifactId>json</artifactId>
102
        <version>20151123</version>
103
      </dependency>
104
    
105
    
106
    
107
    
108
    
109
      <!-- 
110
      <dependency>
111
        < ! - - FIXME move to cdmlib-test - - >
112
        <groupId>org.springframework</groupId>
113
        <artifactId>spring-mock</artifactId>
114
        <version>4.2.3.RELEASE</version>
115
      </dependency>
116
      <dependency>
117
        <groupId>org.seleniumhq.selenium</groupId>
118
        <artifactId>selenium-api</artifactId>
119
        <version>3.5.3</version>
120
      </dependency>
121
      <dependency>
122
        <groupId>org.seleniumhq.selenium</groupId>
123
        <artifactId>selenium-support</artifactId>
124
        <version>3.5.3</version>
125
      </dependency>
126
      -->
127
    </dependencies>
128
  </dependencyManagement>
129
  <distributionManagement>
130
    <repository>
131
      <uniqueVersion>false</uniqueVersion>
132
      <id>cybertaxonomy.eu</id>
133
      <name>Edit Maven Repository</name>
134
      <url>scpexe://cybertaxonomy.eu/var/www/wp5.e-taxonomy.eu/mavenrepo/</url>
135
      <layout>default</layout>
136
    </repository>
137
  </distributionManagement>
138
  <profiles>
139
    <profile>
140
      <id>align-cdmlib-version</id>
141
      <activation>
142
        <property>
143
          <name>align-cdmlib-version</name>
144
        </property>
145
      </activation>
146
      <build>
147
        <plugins>
148
          <plugin>
149
            <groupId>com.google.code.maven-replacer-plugin</groupId>
150
            <artifactId>replacer</artifactId>
151
            <version>1.5.3</version>
152
            <executions>
153
              <execution>
154
                <phase>process-sources</phase>
155
                <goals>
156
                  <goal>replace</goal>
157
                </goals>
158
              </execution>
159
            </executions>
160
            <configuration>
161
              <file>pom.xml</file>
162
              <!-- \u003C = < , \u003E = > -->
163
              <token>(\u003Ccdmlib\.version\u003E)[^\u003C]*</token>
164
              <value>$1${project.version}</value>
165
            </configuration>
166
          </plugin>
167
        </plugins>
168
      </build>
169
    </profile>
170
    <profile>
171
      <id>java8-doclint-disabled</id>
172
      <activation>
173
        <jdk>[1.8,)</jdk>
174
      </activation>
175
      <properties>
176
        <javadoc.opts>-Xdoclint:none</javadoc.opts>
177
      </properties>
178
    </profile>
179
  </profiles>
180
  <build>
181
    <resources>
182
      <resource>
183
        <!-- all main resources without filtering -->
184
        <directory>src/main/resources</directory>
185
      </resource>
186
      <resource>
187
        <!-- replace the place holders like ${...} in datasources.xml -->
188
        <filtering>true</filtering>
189
        <directory>src/test/resources</directory>
190
        <targetPath>../test-classes</targetPath>
191
        <includes>
192
          <include>datasources.xml</include>
193
        </includes>
194
      </resource>
195
      <resource>
196
        <!-- all other test resources without filtering -->
197
        <directory>src/test/resources</directory>
198
        <targetPath>../test-classes</targetPath>
199
        <excludes>
200
          <exclude>datasources.xml</exclude>
201
        </excludes>
202
      </resource>
203
    </resources>
204
    <plugins>
205
      <plugin>
206
        <groupId>org.apache.maven.plugins</groupId>
207
        <artifactId>maven-resources-plugin</artifactId>
208
        <version>3.0.1</version>
209
      </plugin>
210
      <plugin>
211
        <groupId>org.apache.maven.plugins</groupId>
212
        <artifactId>maven-compiler-plugin</artifactId>
213
        <version>3.3</version>
214
        <configuration>
215
          <source>${maven.compiler.source}</source>
216
          <target>${maven.compiler.target}</target>
217
          <encoding>UTF-8</encoding>
218
        </configuration>
219
      </plugin>
220
      <plugin>
221
        <groupId>org.apache.maven.plugins</groupId>
222
        <artifactId>maven-surefire-plugin</artifactId>
223
        <version>2.19.1</version>
224
        <configuration>
225
          <argLine>-Xms256m -Xmx512m</argLine>
226
        </configuration>
227
      </plugin>
228
      <!-- As we are doing "inplace" GWT compilation, ensure the widgetset -->
229
      <!-- directory is cleaned properly -->
230
      <plugin>
231
        <artifactId>maven-clean-plugin</artifactId>
232
        <version>2.4.1</version>
233
        <configuration>
234
          <filesets>
235
            <fileset>
236
              <directory>src/main/webapp/VAADIN/widgetsets</directory>
237
            </fileset>
238
          </filesets>
239
        </configuration>
240
      </plugin>
241
      <plugin>
242
        <groupId>org.apache.maven.plugins</groupId>
243
        <artifactId>maven-javadoc-plugin</artifactId>
244
        <version>2.9.1</version>
245
        <configuration>
246
          <additionalparam>${javadoc.opts}</additionalparam>
247
        </configuration>
248
      </plugin>
249
      <plugin>
250
        <groupId>org.apache.maven.plugins</groupId>
251
        <artifactId>maven-war-plugin</artifactId>
252
        <version>2.2</version>
253
        <configuration>
254
          <failOnMissingWebXml>false</failOnMissingWebXml>
255
          <warSourceExcludes>WEB-INF/*,WEB-INF/datasources/*</warSourceExcludes>
256
        </configuration>
257
      </plugin>
258
      <plugin>
259
        <groupId>com.vaadin</groupId>
260
        <artifactId>vaadin-maven-plugin</artifactId>
261
        <version>${vaadin.plugin.version}</version>
262
        <configuration>
263
          <extraJvmArgs>-Xmx512M -Xss1024k</extraJvmArgs>
264
          <!-- We are doing "inplace" but into subdir VAADIN/widgetsets. 
265
            This way compatible with Vaadin eclipse plugin. -->
266
          <webappDirectory>${basedir}/src/main/webapp/VAADIN/widgetsets</webappDirectory>
267
          <hostedWebapp>${basedir}/src/main/webapp/VAADIN/widgetsets</hostedWebapp>
268
          <!-- Most Vaadin apps don't need this stuff, guide that to target -->
269
          <persistentunitcachedir>${project.build.directory}</persistentunitcachedir>
270
          <deploy>${project.build.directory}/gwt-deploy</deploy>
271
          <!-- Compile report is not typically needed either, saves hunreds 
272
            of mb disk -->
273
          <compileReport>false</compileReport>
274
          <noServer>true</noServer>
275
          <!-- Remove draftCompile when project is ready -->
276
          <draftCompile>false</draftCompile>
277
          <style>OBF</style>
278
          <runTarget>http://localhost:8080/</runTarget>
279
        </configuration>
280
        <executions>
281
          <execution>
282
            <configuration>
283
              <!-- if you don't specify any modules, the plugin will find 
284
                them -->
285
              <!-- <modules> <module>com.vaadin.demo.mobilemail.gwt.ColorPickerWidgetSet</module> 
286
                </modules> -->
287
            </configuration>
288
            <goals>
289
              <goal>clean</goal>
290
              <goal>resources</goal>
291
              <goal>update-theme</goal>
292
              <goal>update-widgetset</goal>
293
              <goal>compile-theme</goal>
294
              <goal>compile</goal>
295
            </goals>
296
          </execution>
297
        </executions>
298
      </plugin>
299
      <plugin>
300
        <groupId>org.eclipse.jetty</groupId>
301
        <artifactId>jetty-maven-plugin</artifactId>
302
        <version>9.4.15.v20190215</version>
303
        <!--  
304
            NOTE:
305
            9.4.0.RC1 requires jdk 1.8, formerly we've been using version 9.1.3.v20140225 which was 
306
            the last version compatible to java 7, but this was causing other problems related to asm
307
            which could not be easily solved.
308
        -->
309
        <configuration>
310
          <useTestScope>true</useTestScope>
311
          <scanIntervalSeconds>2</scanIntervalSeconds>
312
          <systemProperties>
313
            <force>true</force>
314
            <systemProperty>
315
              <name>cdm.datasource</name>
316
              <value>h2_cdmTest</value>
317
            </systemProperty>
318
            <systemProperty>
319
              <name>hibernate.hbm2ddl.auto</name>
320
              <value>create-drop</value>
321
            </systemProperty>
322
            <systemProperty>
323
              <!-- 
324
                The lucene index should be placed into the target folder, 
325
                so user.home needs to be set to this folder. user.home needs to be overridden 
326
                since it already exists, thus the force option is turned on above 
327
              -->
328
              <name>user.home</name>
329
              <value>${basedir}/target/</value>
330
            </systemProperty>
331
            <systemProperty>
332
              <!-- 
333
                datasources.xml is prepared by <plugins><resources>..</resources> above 
334
               -->
335
              <name>cdm.beanDefinitionFile</name>
336
              <value>${project.build.directory}/test-classes/datasources.xml</value>
337
            </systemProperty>
338
          </systemProperties>
339
        </configuration>
340
        <dependencies>
341
          <dependency>
342
            <groupId>org.slf4j</groupId>
343
            <artifactId>slf4j-log4j12</artifactId>
344
            <version>1.6.4</version>
345
          </dependency>
346
        </dependencies>
347
      </plugin>
348
      <plugin>
349
        <groupId>org.apache.maven.plugins</groupId>
350
        <artifactId>maven-failsafe-plugin</artifactId>
351
        <version>2.17</version>
352
        <configuration>
353
          <!-- Remove the skipTests line below to run TestBench tests -->
354
          <!-- <skipTests>true</skipTests> -->
355
        </configuration>
356
        <executions>
357
          <execution>
358
            <goals>
359
              <goal>integration-test</goal>
360
              <goal>verify</goal>
361
            </goals>
362
          </execution>
363
        </executions>
364
      </plugin>
365
      <!-- Browser Driver Downloader -->
366
      <plugin>
367
        <groupId>com.lazerycode.selenium</groupId>
368
        <artifactId>driver-binary-downloader-maven-plugin</artifactId>
369
        <version>1.0.14</version>
370
        <!-- has a bug -->
371
        <configuration>
372
          <rootStandaloneServerDirectory>selenium/bin</rootStandaloneServerDirectory>
373
          <downloadedZipFileDirectory>selenium/zip</downloadedZipFileDirectory>
374
        </configuration>
375
        <executions>
376
          <execution>
377
            <goals>
378
              <goal>selenium</goal>
379
            </goals>
380
          </execution>
381
        </executions>
382
      </plugin>
383
      <plugin>
384
        <groupId>external.atlassian.jgitflow</groupId>
385
        <artifactId>jgitflow-maven-plugin</artifactId>
386
        <version>1.0-m6</version>
387
        <configuration>
388
          <pushHotfixes>true</pushHotfixes>
389
          <pushReleases>true</pushReleases>
390
          <enableSshAgent>true</enableSshAgent>
391
          <allowSnapshots>true</allowSnapshots>
392
          <allowUntracked>true</allowUntracked>
393
        </configuration>
394
        <dependencies>
395
          <!-- upgrading dependency jsch.agent.version of jgit-flow plugin 
396
            to 0.1.53 in order have ssl key exchange algorithms compatible with openssh 
397
            6.7 -->
398
          <dependency>
399
            <groupId>com.jcraft</groupId>
400
            <artifactId>jsch</artifactId>
401
            <version>0.1.53</version>
402
          </dependency>
403
        </dependencies>
404
      </plugin>
405
      <plugin>
406
        <groupId>org.apache.maven.plugins</groupId>
407
        <artifactId>maven-enforcer-plugin</artifactId>
408
        <version>3.0.0-M2</version>
409
        <executions>
410
          <execution>
411
            <id>enforce</id>
412
            <configuration>
413
              <fail>false</fail>
414
              <skip>false</skip>
415
              <rules>
416
                <dependencyConvergence />
417
                <requireMavenVersion>
418
                  <version>[3.6.0,)</version>
419
                </requireMavenVersion>
420
              </rules>
421
            </configuration>
422
            <goals>
423
              <goal>enforce</goal>
424
            
425
            
426
            
427
            
428
              <!-- Binds by default to the lifecycle phase: validate -->
429
            </goals>
430
          </execution>
431
        </executions>
432
      </plugin>
433
    </plugins>
434
    <extensions>
435
      <extension>
436
        <groupId>org.apache.maven.wagon</groupId>
437
        <artifactId>wagon-scm</artifactId>
438
        <version>1.0-beta-6</version>
439
      </extension>
440
      <extension>
441
        <groupId>org.apache.maven.wagon</groupId>
442
        <artifactId>wagon-ssh</artifactId>
443
        <version>1.0-beta-6</version>
444
      </extension>
445
      <extension>
446
        <groupId>org.apache.maven.wagon</groupId>
447
        <artifactId>wagon-ssh-external</artifactId>
448
        <version>1.0-beta-6</version>
449
      </extension>
450
      <extension>
451
        <groupId>org.apache.maven.scm</groupId>
452
        <artifactId>maven-scm-manager-plexus</artifactId>
453
        <version>1.0</version>
454
      </extension>
455
      <extension>
456
        <groupId>org.apache.maven.scm</groupId>
457
        <artifactId>maven-scm-provider-svnexe</artifactId>
458
        <version>1.0</version>
459
      </extension>
460
      <!-- WebDAV plugin to upload snapshots -->
461
      <extension>
462
        <groupId>org.apache.maven.wagon</groupId>
463
        <artifactId>wagon-webdav</artifactId>
464
        <version>1.0-beta-2</version>
465
      </extension>
466
    </extensions>
467
    <pluginManagement>
468
      <plugins>
469
        <plugin>
470
          <artifactId>maven-eclipse-plugin</artifactId>
471
          <configuration>
472
            <wtpversion>2.0</wtpversion>
473
            <additionalProjectnatures>
474
              <projectnature>com.vaadin.integration.eclipse.widgetsetNature</projectnature>
475
            </additionalProjectnatures>
476
            <additionalBuildcommands>
477
              <buildcommand>com.vaadin.integration.eclipse.widgetsetBuilder</buildcommand>
478
              <buildcommand>com.vaadin.integration.eclipse.addonStylesBuilder</buildcommand>
479
            </additionalBuildcommands>
480
          </configuration>
481
        </plugin>
482
        <!--This plugin's configuration is used to store Eclipse m2e settings only. It has no influence on the Maven build itself.-->
483
        <plugin>
484
          <groupId>org.eclipse.m2e</groupId>
485
          <artifactId>lifecycle-mapping</artifactId>
486
          <version>1.0.0</version>
487
          <configuration>
488
            <lifecycleMappingMetadata>
489
              <pluginExecutions>
490
                <pluginExecution>
491
                  <pluginExecutionFilter>
492
                    <groupId>com.lazerycode.selenium</groupId>
493
                    <artifactId>
494
                      driver-binary-downloader-maven-plugin
495
                    </artifactId>
496
                    <versionRange>[1.0.14,)</versionRange>
497
                    <goals>
498
                      <goal>selenium</goal>
499
                    </goals>
500
                  </pluginExecutionFilter>
501
                  <action>
502
                    <ignore />
503
                  </action>
504
                </pluginExecution>
505
              </pluginExecutions>
506
            </lifecycleMappingMetadata>
507
          </configuration>
508
        </plugin>
509
      </plugins>
510
    </pluginManagement>
511
  </build>
512
  <dependencies>
513
    <!-- ============ Vaadin ============ -->
514
    <dependency>
515
      <groupId>com.vaadin</groupId>
516
      <artifactId>vaadin-spring</artifactId>
517
      <version>${vaadin-spring.version}</version>
518
    </dependency>
519
    <dependency>
520
      <groupId>org.vaadin.spring.addons</groupId>
521
      <artifactId>vaadin-spring-addon-eventbus</artifactId>
522
      <version>${vaadin-spring-addon-eventbus.version}</version>
523
    </dependency>
524
    <dependency>
525
      <groupId>com.vaadin</groupId>
526
      <artifactId>vaadin-server</artifactId>
527
    </dependency>
528
    <dependency>
529
      <groupId>com.vaadin</groupId>
530
      <artifactId>vaadin-client-compiled</artifactId>
531
    </dependency>
532
    <!-- Needed when using the widgetset optimizer (custom ConnectorBundleLoaderFactory). 
533
      For widgetset compilation, vaadin-client-compiler is automatically added 
534
      on the compilation classpath by vaadin-maven-plugin so normally there is 
535
      no need for an explicit dependency. -->
536
    <!-- <dependency> <groupId>com.vaadin</groupId> <artifactId>vaadin-client-compiler</artifactId> 
537
      <version>${vaadin.version}</version> <scope>provided</scope> </dependency> -->
538
    <dependency>
539
      <groupId>com.vaadin</groupId>
540
      <artifactId>vaadin-client</artifactId>
541
      <scope>test</scope>
542
      <exclusions>
543
        <exclusion>
544
          <groupId>javax.validation</groupId>
545
          <artifactId>validation-api</artifactId>
546
        </exclusion>
547
      </exclusions>
548
    </dependency>
549
    <!-- disabling push for the moment because it does not work with run-jetty-run 
550
      due to the fact that the latest (even nightly) version of run-jetty-run uses 
551
      9.0.0 M3 which is incompatible with atmoshpere. this does work with the jetty 
552
      included in this pom which is 9.2.5.xx, implying that enabling the dependency 
553
      and running the web app via 'mvn jetty:run' works fine. -->
554
    <!-- <dependency> -->
555
    <!-- <groupId>com.vaadin</groupId> -->
556
    <!-- <artifactId>vaadin-push</artifactId> -->
557
    <!-- <version>${vaadin.version}</version> -->
558
    <!-- </dependency> -->
559
    <dependency>
560
      <groupId>com.vaadin</groupId>
561
      <artifactId>vaadin-themes</artifactId>
562
    </dependency>
563
    <!-- vaadin addons / extensions -->
564
    <dependency>
565
      <groupId>org.vaadin.addons</groupId>
566
      <artifactId>contextmenu</artifactId>
567
      <version>4.5</version>
568
    </dependency>
569
    <dependency>
570
      <groupId>org.vaadin.teemu</groupId>
571
      <artifactId>switch</artifactId>
572
      <version>2.0.4-SNAPSHOT</version>
573
    </dependency>
574
    <dependency>
575
      <groupId>org.vaadin</groupId>
576
      <artifactId>viritin</artifactId>
577
      <version>1.61</version>
578
    </dependency>
579
    <dependency>
580
      <groupId>org.vaadin.addon</groupId>
581
      <artifactId>v-leaflet</artifactId>
582
      <version>1.0.3</version>
583
    </dependency>
584
    <dependency>
585
      <groupId>org.vaadin.addons.lazyquerycontainer</groupId>
586
      <artifactId>vaadin-lazyquerycontainer</artifactId>
587
      <version>7.6.1.3</version>
588
    </dependency>
589
    <dependency>
590
      <groupId>com.flowingcode.vaadin.addons</groupId>
591
      <artifactId>error-window-vaadin</artifactId>
592
      <version>1.0.0</version>
593
    </dependency>
594
    <!-- 
595
    <dependency>
596
        <groupId>org.vaadin.spring.extensions</groupId>
597
        <artifactId>vaadin-spring-ext-test</artifactId>
598
        <version>0.0.8-SNAPSHOT</version>
599
        <scope>test</scope>
600
    </dependency>
601
     -->
602
    <!--     <dependency>
603
        only in the edit repo
604
      <groupId>org.vaadin.addons</groupId>
605
      <artifactId>lazyloadwrapper</artifactId>
606
      <version>0.1-alpha</version>
607
    </dependency> -->
608
    <!-- ============ cdmlib ============ -->
609
    <dependency>
610
      <groupId>eu.etaxonomy</groupId>
611
      <artifactId>cdmlib-remote</artifactId>
612
      <scope>compile</scope>
613
    </dependency>
614
    <dependency>
615
      <groupId>eu.etaxonomy</groupId>
616
      <artifactId>cdmlib-cache</artifactId>
617
      <version>${cdmlib.version}</version>
618
    </dependency>
619
    <dependency>
620
      <groupId>eu.etaxonomy</groupId>
621
      <artifactId>cdmlib-test</artifactId>
622
      <scope>test</scope>
623
    </dependency>
624
    <dependency>
625
      <groupId>eu.etaxonomy</groupId>
626
      <artifactId>cdmlib-db</artifactId>
627
      <version>${cdmlib.version}</version>
628
      <scope>test</scope>
629
    </dependency>
630
    <!-- ============ Other ============ -->
631
    <!-- 
632
        to override version number coming with vaadin client 
633
        version is managed in cdmlib-parent
634
    -->
635
    <dependency>
636
      <groupId>javax.validation</groupId>
637
      <artifactId>validation-api</artifactId>
638
    </dependency>
639
    <dependency>
640
      <groupId>org.springmodules</groupId>
641
      <artifactId>spring-modules-cache</artifactId>
642
      <version>0.7</version>
643
      <exclusions>
644
        <exclusion>
645
          <groupId>org.springframework</groupId>
646
          <artifactId>spring</artifactId>
647
        </exclusion>
648
        <exclusion>
649
          <groupId>org.springframework</groupId>
650
          <artifactId>spring-mock</artifactId>
651
        </exclusion>
652
      </exclusions>
653
      <scope>test</scope>
654
    </dependency>
655
    <dependency>
656
      <groupId>org.springframework</groupId>
657
      <artifactId>spring-test</artifactId>
658
      <scope>test</scope>
659
    </dependency>
660
    <dependency>
661
      <groupId>org.json</groupId>
662
      <artifactId>json</artifactId>
663
    </dependency>
664
    <dependency>
665
      <groupId>javax.servlet</groupId>
666
      <artifactId>javax.servlet-api</artifactId>
667
      <scope>provided</scope>
668
    </dependency>
669
    <!-- ========== testing ======== -->
670
    <dependency>
671
      <groupId>com.codeborne</groupId>
672
      <artifactId>selenide</artifactId>
673
      <version>4.7.1</version>
674
      <scope>test</scope>
675
    </dependency>
676
    <dependency>
677
      <groupId>org.springframework.boot</groupId>
678
      <artifactId>spring-boot</artifactId>
679
    </dependency>
680
    <dependency>
681
      <groupId>org.springframework.boot</groupId>
682
      <artifactId>spring-boot-starter-jetty</artifactId>
683
    </dependency>
684
    <dependency>
685
      <groupId>org.springframework</groupId>
686
      <artifactId>spring-beans</artifactId>
687
    </dependency>
688
  </dependencies>
689
</project>
(4-4/4)