Project

General

Profile

Download (24.9 KB) Statistics
| Branch: | Tag: | Revision:
1
<?xml version="1.0" encoding="UTF-8"?>
2
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
3
  <modelVersion>4.0.0</modelVersion>
4
  <groupId>eu.etaxonomy</groupId>
5
  <artifactId>cdm-vaadin</artifactId>
6
  <packaging>war</packaging>
7
  <version>5.38.0-SNAPSHOT</version>
8
  <name>Vaadin Web Application</name>
9
  <properties>
10
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
11
    <vaadin.version>7.7.17</vaadin.version>
12
    <!-- LAST PUBLIC OPEN-SOURCE VERSION OF THE VAADIN 7 FRAMEWORK !!!   -->
13
    <vaadin-spring.version>1.2.0</vaadin-spring.version>
14
    <vaadin.plugin.version>${vaadin.version}</vaadin.plugin.version>
15
    <vaadin-spring-addon-eventbus.version>2.0.0.RELEASE</vaadin-spring-addon-eventbus.version>
16
    <cdmlib.version>5.38.0</cdmlib.version>
17
    <unitils.version>3.4.2</unitils.version>
18
    <spring-boot.version>1.3.1.RELEASE</spring-boot.version>
19
    <!-- has spring 4.2.4-RELEASE as dependency --> 
20
    <!-- 
21
        lucene.version must match the version as defined in cdmlib
22
    -->
23
    <lucene.version>5.4.1</lucene.version>
24
    <maven.compiler.source>1.8</maven.compiler.source>
25
    <maven.compiler.target>1.8</maven.compiler.target>
26
    <doclint>none</doclint>
27
  </properties>
28
  <prerequisites>
29
    <maven>3.6.3</maven>
30
  </prerequisites>
31
  <repositories>
32
    <!-- the cdm internal repository -->
33
    <repository>
34
      <id>EditRepository</id>
35
      <url>https://cybertaxonomy.org/mavenrepo/</url>
36
    </repository>
37
    <!-- current spring source repositories -->
38
    <repository>
39
      <id>SpringSource Enterprise Bundle Repository - External Bundle Milestones</id>
40
      <url>http://repository.springsource.com/maven/bundles/milestone</url>
41
    </repository>
42
    <repository>
43
      <id>SpringSource Enterprise Bundle Repository - SpringSource Bundle Releases</id>
44
      <url>http://repository.springsource.com/maven/bundles/release</url>
45
    </repository>
46
    <repository>
47
      <id>SpringSource Enterprise Bundle Repository - External Bundle Releases</id>
48
      <url>http://repository.springsource.com/maven/bundles/external</url>
49
    </repository>
50
    <repository>
51
      <id>vaadin-addons</id>
52
      <url>http://maven.vaadin.com/vaadin-addons</url>
53
    </repository>
54
    <repository>
55
      <id>vaadin-snapshots</id>
56
      <url>http://oss.sonatype.org/content/repositories/vaadin-snapshots/</url>
57
      <releases>
58
        <enabled>false</enabled>
59
      </releases>
60
      <snapshots>
61
        <enabled>true</enabled>
62
      </snapshots>
63
    </repository>
64
  </repositories>
65
  <pluginRepositories>
66
    <pluginRepository>
67
      <id>vaadin-snapshots</id>
68
      <url>http://oss.sonatype.org/content/repositories/vaadin-snapshots/</url>
69
      <releases>
70
        <enabled>false</enabled>
71
      </releases>
72
      <snapshots>
73
        <enabled>true</enabled>
74
      </snapshots>
75
    </pluginRepository>
76
  </pluginRepositories>
77
  <dependencyManagement>
78
    <dependencies>
79
      <dependency>
80
        <groupId>eu.etaxonomy</groupId>
81
        <artifactId>cdmlib-parent</artifactId>
82
        <version>${cdmlib.version}</version>
83
        <type>pom</type>
84
        <scope>import</scope>
85
      </dependency>
86
      <dependency>
87
        <groupId>org.springframework.boot</groupId>
88
        <artifactId>spring-boot-starter-parent</artifactId>
89
        <version>${spring-boot.version}</version>
90
        <type>pom</type>
91
        <scope>import</scope>
92
      </dependency>
93
      <dependency>
94
        <groupId>com.vaadin</groupId>
95
        <artifactId>vaadin-bom</artifactId>
96
        <version>${vaadin.version}</version>
97
        <type>pom</type>
98
        <scope>import</scope>
99
      </dependency>
100
      <dependency>
101
        <!-- Try updating in cdmlib to 20090211 -->
102
        <groupId>org.json</groupId>
103
        <artifactId>json</artifactId>
104
        <version>20220320</version>
105
      </dependency>
106
    
107
    
108
    
109
    
110
    
111
    
112
    
113
    
114
    
115
    
116
        <!-- 
117
      <dependency>
118
            updating to same version as in vaadin-server 7.7.28 due to https://vaadin.com/security/2021-10-27 
119
            is not possible due to code incompatibility
120
        <groupId>org.jsoup</groupId>
121
        <artifactId>jsoup</artifactId>
122
        <version>1.14.3</version>
123
      </dependency>
124
        -->
125
      <!-- 
126
      <dependency>
127
        < ! - - FIXME move to cdmlib-test - - >
128
        <groupId>org.springframework</groupId>
129
        <artifactId>spring-mock</artifactId>
130
        <version>4.2.3.RELEASE</version>
131
      </dependency>
132
      <dependency>
133
        <groupId>org.seleniumhq.selenium</groupId>
134
        <artifactId>selenium-api</artifactId>
135
        <version>3.5.3</version>
136
      </dependency>
137
      <dependency>
138
        <groupId>org.seleniumhq.selenium</groupId>
139
        <artifactId>selenium-support</artifactId>
140
        <version>3.5.3</version>
141
      </dependency>
142
      -->
143
    </dependencies>
144
  </dependencyManagement>
145
  <distributionManagement>
146
    <repository>
147
      <uniqueVersion>false</uniqueVersion>
148
      <id>cybertaxonomy.eu</id>
149
      <name>Edit Maven Repository</name>
150
      <url>scpexe://cybertaxonomy.org/var/www/wp5.e-taxonomy.eu/mavenrepo/</url>
151
      <layout>default</layout>
152
    </repository>
153
  </distributionManagement>
154
  <profiles>
155
    <profile>
156
      <id>align-cdmlib-version</id>
157
      <activation>
158
        <property>
159
          <name>align-cdmlib-version</name>
160
        </property>
161
      </activation>
162
      <build>
163
        <plugins>
164
          <plugin>
165
            <groupId>com.google.code.maven-replacer-plugin</groupId>
166
            <artifactId>replacer</artifactId>
167
            <version>1.5.3</version>
168
            <executions>
169
              <execution>
170
                <phase>process-sources</phase>
171
                <goals>
172
                  <goal>replace</goal>
173
                </goals>
174
              </execution>
175
            </executions>
176
            <configuration>
177
              <file>pom.xml</file>
178
              <!-- \u003C = < , \u003E = > -->
179
              <token>(\u003Ccdmlib\.version\u003E)[^\u003C]*</token>
180
              <value>$1${project.version}</value>
181
            </configuration>
182
          </plugin>
183
        </plugins>
184
      </build>
185
    </profile>
186
    <profile>
187
      <id>java8-doclint-disabled</id>
188
      <activation>
189
        <jdk>[1.8,)</jdk>
190
      </activation>
191
      <properties>
192
        <javadoc.opts>-Xdoclint:none</javadoc.opts>
193
      </properties>
194
    </profile>
195
  </profiles>
196
  <build>
197
    <resources>
198
      <resource>
199
        <!-- all main resources without filtering -->
200
        <directory>src/main/resources</directory>
201
      </resource>
202
      <resource>
203
        <!-- replace the place holders like ${...} in datasources.xml -->
204
        <filtering>true</filtering>
205
        <directory>src/test/resources</directory>
206
        <targetPath>../test-classes</targetPath>
207
        <includes>
208
          <include>datasources.xml</include>
209
        </includes>
210
      </resource>
211
      <resource>
212
        <!-- all other test resources without filtering -->
213
        <directory>src/test/resources</directory>
214
        <targetPath>../test-classes</targetPath>
215
        <excludes>
216
          <exclude>datasources.xml</exclude>
217
        </excludes>
218
      </resource>
219
    </resources>
220
    <plugins>
221
      <plugin>
222
        <groupId>org.apache.maven.plugins</groupId>
223
        <artifactId>maven-resources-plugin</artifactId>
224
        <version>3.2.0</version>
225
      </plugin>
226
      <plugin>
227
        <groupId>org.apache.maven.plugins</groupId>
228
        <artifactId>maven-compiler-plugin</artifactId>
229
        <version>3.9.0</version>
230
        <configuration>
231
          <source>${maven.compiler.source}</source>
232
          <target>${maven.compiler.target}</target>
233
          <encoding>UTF-8</encoding>
234
        </configuration>
235
      </plugin>
236
      <plugin>
237
        <groupId>org.apache.maven.plugins</groupId>
238
        <artifactId>maven-surefire-plugin</artifactId>
239
        <version>3.0.0-M7</version>
240
        <configuration>
241
          <argLine>-Xms256m -Xmx512m</argLine>
242
        </configuration>
243
      </plugin>
244
      <!-- As we are doing "inplace" GWT compilation, ensure the widgetset -->
245
      <!-- directory is cleaned properly -->
246
      <plugin>
247
        <artifactId>maven-clean-plugin</artifactId>
248
        <version>3.1.0</version>
249
        <configuration>
250
          <filesets>
251
            <fileset>
252
              <directory>src/main/webapp/VAADIN/widgetsets</directory>
253
            </fileset>
254
          </filesets>
255
        </configuration>
256
      </plugin>
257
      <plugin>
258
        <groupId>org.apache.maven.plugins</groupId>
259
        <artifactId>maven-javadoc-plugin</artifactId>
260
        <version>3.3.1</version>
261
        <configuration>
262
          <doclint>${doclint}</doclint>
263
        </configuration>
264
      </plugin>
265
      <plugin>
266
        <groupId>org.apache.maven.plugins</groupId>
267
        <artifactId>maven-war-plugin</artifactId>
268
        <version>3.3.2</version>
269
        <configuration>
270
          <failOnMissingWebXml>false</failOnMissingWebXml>
271
          <warSourceExcludes>WEB-INF/*,WEB-INF/datasources/*</warSourceExcludes>
272
        </configuration>
273
      </plugin>
274
      <plugin>
275
        <groupId>com.vaadin</groupId>
276
        <artifactId>vaadin-maven-plugin</artifactId>
277
        <version>${vaadin.plugin.version}</version>
278
        <configuration>
279
          <extraJvmArgs>-Xmx512M -Xss1024k</extraJvmArgs>
280
          <!-- We are doing "inplace" but into subdir VAADIN/widgetsets. 
281
            This way compatible with Vaadin eclipse plugin. -->
282
          <webappDirectory>${basedir}/src/main/webapp/VAADIN/widgetsets</webappDirectory>
283
          <hostedWebapp>${basedir}/src/main/webapp/VAADIN/widgetsets</hostedWebapp>
284
          <!-- Most Vaadin apps don't need this stuff, guide that to target -->
285
          <persistentunitcachedir>${project.build.directory}</persistentunitcachedir>
286
          <deploy>${project.build.directory}/gwt-deploy</deploy>
287
          <!-- Compile report is not typically needed either, saves hunreds 
288
            of mb disk -->
289
          <compileReport>false</compileReport>
290
          <noServer>true</noServer>
291
          <!-- Remove draftCompile when project is ready -->
292
          <draftCompile>false</draftCompile>
293
          <style>OBF</style>
294
          <runTarget>http://localhost:8080/</runTarget>
295
        </configuration>
296
        <executions>
297
          <execution>
298
            <configuration>
299
              <!-- if you don't specify any modules, the plugin will find 
300
                them -->
301
              <!-- <modules> <module>com.vaadin.demo.mobilemail.gwt.ColorPickerWidgetSet</module> 
302
                </modules> -->
303
            </configuration>
304
            <goals>
305
              <goal>clean</goal>
306
              <goal>resources</goal>
307
              <goal>update-theme</goal>
308
              <goal>update-widgetset</goal>
309
              <goal>compile-theme</goal>
310
              <goal>compile</goal>
311
            </goals>
312
          </execution>
313
        </executions>
314
      </plugin>
315
      <plugin>
316
        <groupId>org.eclipse.jetty</groupId>
317
        <artifactId>jetty-maven-plugin</artifactId>
318
        <version>9.4.15.v20190215</version>
319
        <!--  
320
            NOTE:
321
            9.4.0.RC1 requires jdk 1.8, formerly we've been using version 9.1.3.v20140225 which was 
322
            the last version compatible to java 7, but this was causing other problems related to asm
323
            which could not be easily solved.
324
        -->
325
        <configuration>
326
          <useTestScope>true</useTestScope>
327
          <scanIntervalSeconds>2</scanIntervalSeconds>
328
          <systemProperties>
329
            <force>true</force>
330
            <systemProperty>
331
              <name>cdm.datasource</name>
332
              <value>h2_cdmTest</value>
333
            </systemProperty>
334
            <systemProperty>
335
              <name>hibernate.hbm2ddl.auto</name>
336
              <value>create-drop</value>
337
            </systemProperty>
338
            <systemProperty>
339
              <!-- 
340
                The lucene index should be placed into the target folder, 
341
                so user.home needs to be set to this folder. user.home needs to be overridden 
342
                since it already exists, thus the force option is turned on above 
343
              -->
344
              <name>user.home</name>
345
              <value>${basedir}/target/</value>
346
            </systemProperty>
347
            <systemProperty>
348
              <!-- 
349
                datasources.xml is prepared by <plugins><resources>..</resources> above 
350
               -->
351
              <name>cdm.beanDefinitionFile</name>
352
              <value>${project.build.directory}/test-classes/datasources.xml</value>
353
            </systemProperty>
354
          </systemProperties>
355
        </configuration>
356
        <dependencies>
357
          <dependency>
358
            <groupId>org.slf4j</groupId>
359
            <artifactId>slf4j-log4j12</artifactId>
360
            <version>1.6.4</version>
361
          </dependency>
362
        </dependencies>
363
      </plugin>
364
      <plugin>
365
        <groupId>org.apache.maven.plugins</groupId>
366
        <artifactId>maven-failsafe-plugin</artifactId>
367
        <version>3.0.0-M5</version>
368
        <configuration>
369
          <!-- Remove the skipTests line below to run TestBench tests -->
370
          <!-- <skipTests>true</skipTests> -->
371
        </configuration>
372
        <executions>
373
          <execution>
374
            <goals>
375
              <goal>integration-test</goal>
376
              <goal>verify</goal>
377
            </goals>
378
          </execution>
379
        </executions>
380
      </plugin>
381
      <!-- Browser Driver Downloader -->
382
      <plugin>
383
        <groupId>com.lazerycode.selenium</groupId>
384
        <artifactId>driver-binary-downloader-maven-plugin</artifactId>
385
        <version>1.0.18</version>
386
        <!-- has a bug -->
387
        <configuration>
388
          <rootStandaloneServerDirectory>selenium/bin</rootStandaloneServerDirectory>
389
          <downloadedZipFileDirectory>selenium/zip</downloadedZipFileDirectory>
390
        </configuration>
391
        <executions>
392
          <execution>
393
            <goals>
394
              <goal>selenium</goal>
395
            </goals>
396
          </execution>
397
        </executions>
398
      </plugin>
399
      <plugin>
400
        <!-- groupId>ch.dvbern.oss.maven.jgitflow</groupId>
401
        <artifactId>jgitflow-maven-plugin</artifactId>
402
        <version>1.0-m8</version>  -->
403
        <groupId>external.atlassian.jgitflow</groupId>
404
        <artifactId>jgitflow-maven-plugin</artifactId>
405
        <version>1.0-m6</version>
406
        <configuration>
407
          <pushHotfixes>true</pushHotfixes>
408
          <pushReleases>true</pushReleases>
409
          <enableSshAgent>true</enableSshAgent>
410
          <allowSnapshots>true</allowSnapshots>
411
          <allowUntracked>true</allowUntracked>
412
        </configuration>
413
        <dependencies>
414
          <!-- upgrading dependency jsch.agent.version of jgit-flow plugin 
415
            to 0.1.53 in order have ssl key exchange algorithms compatible with openssh 
416
            6.7 -->
417
          <dependency>
418
            <groupId>com.jcraft</groupId>
419
            <artifactId>jsch</artifactId>
420
            <version>0.1.55</version>
421
          </dependency>
422
        </dependencies>
423
      </plugin>
424
      <plugin>
425
        <groupId>org.apache.maven.plugins</groupId>
426
        <artifactId>maven-enforcer-plugin</artifactId>
427
        <version>3.1.0</version>
428
        <executions>
429
          <execution>
430
            <id>enforce</id>
431
            <configuration>
432
              <fail>false</fail>
433
              <skip>false</skip>
434
              <rules>
435
                <dependencyConvergence/>
436
                <requireMavenVersion>
437
                  <version>[3.6.3,)</version>
438
                </requireMavenVersion>
439
              </rules>
440
            </configuration>
441
            <goals>
442
              <goal>enforce</goal>
443
            
444
            
445
            
446
            
447
            
448
            
449
            
450
            
451
            
452
 
453
              <!-- Binds by default to the lifecycle phase: validate -->
454
            </goals>
455
          </execution>
456
        </executions>
457
      </plugin>
458
    </plugins>
459
    <extensions>
460
      <extension>
461
        <groupId>org.apache.maven.wagon</groupId>
462
        <artifactId>wagon-scm</artifactId>
463
        <version>3.5.1</version>
464
      </extension>
465
      <extension>
466
        <groupId>org.apache.maven.wagon</groupId>
467
        <artifactId>wagon-ssh</artifactId>
468
        <version>3.5.1</version>
469
      </extension>
470
      <extension>
471
        <groupId>org.apache.maven.wagon</groupId>
472
        <artifactId>wagon-ssh-external</artifactId>
473
        <version>3.5.1</version>
474
      </extension>
475
      <extension>
476
        <groupId>org.apache.maven.scm</groupId>
477
        <artifactId>maven-scm-manager-plexus</artifactId>
478
        <version>1.12.2</version>
479
      </extension>
480
      <extension>
481
        <groupId>org.apache.maven.scm</groupId>
482
        <artifactId>maven-scm-provider-svnexe</artifactId>
483
        <version>1.12.2</version>
484
      </extension>
485
      <!-- WebDAV plugin to upload snapshots -->
486
      <extension>
487
        <groupId>org.apache.maven.wagon</groupId>
488
        <artifactId>wagon-webdav-jackrabbit</artifactId>
489
        <version>3.5.1</version>
490
      </extension>
491
    </extensions>
492
    <pluginManagement>
493
      <plugins>
494
        <plugin>
495
          <groupId>org.apache.maven.plugins</groupId>
496
          <artifactId>maven-eclipse-plugin</artifactId>
497
          <version>2.10</version>
498
          <configuration>
499
            <wtpversion>2.0</wtpversion>
500
            <additionalProjectnatures>
501
              <projectnature>com.vaadin.integration.eclipse.widgetsetNature</projectnature>
502
            </additionalProjectnatures>
503
            <additionalBuildcommands>
504
              <buildcommand>com.vaadin.integration.eclipse.widgetsetBuilder</buildcommand>
505
              <buildcommand>com.vaadin.integration.eclipse.addonStylesBuilder</buildcommand>
506
            </additionalBuildcommands>
507
          </configuration>
508
        </plugin>
509
        <!--This plugin's configuration is used to store Eclipse m2e settings only. It has no influence on the Maven build itself.-->
510
        <plugin>
511
          <groupId>org.eclipse.m2e</groupId>
512
          <artifactId>lifecycle-mapping</artifactId>
513
          <version>1.0.0</version>
514
          <configuration>
515
            <lifecycleMappingMetadata>
516
              <pluginExecutions>
517
                <pluginExecution>
518
                  <pluginExecutionFilter>
519
                    <groupId>com.lazerycode.selenium</groupId>
520
                    <artifactId>
521
                      driver-binary-downloader-maven-plugin
522
                    </artifactId>
523
                    <versionRange>[1.0.14,)</versionRange>
524
                    <goals>
525
                      <goal>selenium</goal>
526
                    </goals>
527
                  </pluginExecutionFilter>
528
                  <action>
529
                    <ignore/>
530
                  </action>
531
                </pluginExecution>
532
              </pluginExecutions>
533
            </lifecycleMappingMetadata>
534
          </configuration>
535
        </plugin>
536
      </plugins>
537
    </pluginManagement>
538
  </build>
539
  <dependencies>
540
    <!-- ============ Vaadin ============ -->
541
    <dependency>
542
      <groupId>com.vaadin</groupId>
543
      <artifactId>vaadin-spring</artifactId>
544
      <version>${vaadin-spring.version}</version>
545
    </dependency>
546
    <dependency>
547
      <groupId>org.vaadin.spring.addons</groupId>
548
      <artifactId>vaadin-spring-addon-eventbus</artifactId>
549
      <version>${vaadin-spring-addon-eventbus.version}</version>
550
    </dependency>
551
    <dependency>
552
      <groupId>com.vaadin</groupId>
553
      <artifactId>vaadin-server</artifactId>
554
    
555
    
556
    
557
    
558
    
559
    
560
    
561
    
562
    
563
    
564
      <!-- 
565
        vaadin-server dependency jsoup upgraded due to https://vaadin.com/security/2021-10-27
566
        further updating of vaadin 7 is no longer possible without purchasing the pro license 
567
       -->
568
    </dependency>
569
    <dependency>
570
      <groupId>com.vaadin</groupId>
571
      <artifactId>vaadin-client-compiled</artifactId>
572
    </dependency>
573
    <!-- Needed when using the widgetset optimizer (custom ConnectorBundleLoaderFactory). 
574
      For widgetset compilation, vaadin-client-compiler is automatically added 
575
      on the compilation classpath by vaadin-maven-plugin so normally there is 
576
      no need for an explicit dependency. -->
577
    <!-- <dependency> <groupId>com.vaadin</groupId> <artifactId>vaadin-client-compiler</artifactId> 
578
      <version>${vaadin.version}</version> <scope>provided</scope> </dependency> -->
579
    <dependency>
580
      <groupId>com.vaadin</groupId>
581
      <artifactId>vaadin-client</artifactId>
582
      <scope>test</scope>
583
      <exclusions>
584
        <exclusion>
585
          <groupId>javax.validation</groupId>
586
          <artifactId>validation-api</artifactId>
587
        </exclusion>
588
      </exclusions>
589
    </dependency>
590
    <!-- disabling push for the moment because it does not work with run-jetty-run 
591
      due to the fact that the latest (even nightly) version of run-jetty-run uses 
592
      9.0.0 M3 which is incompatible with atmoshpere. this does work with the jetty 
593
      included in this pom which is 9.2.5.xx, implying that enabling the dependency 
594
      and running the web app via 'mvn jetty:run' works fine. -->
595
    <!-- <dependency> -->
596
    <!-- <groupId>com.vaadin</groupId> -->
597
    <!-- <artifactId>vaadin-push</artifactId> -->
598
    <!-- <version>${vaadin.version}</version> -->
599
    <!-- </dependency> -->
600
    <dependency>
601
      <groupId>com.vaadin</groupId>
602
      <artifactId>vaadin-themes</artifactId>
603
    </dependency>
604
    <!-- vaadin addons / extensions -->
605
    <dependency>
606
      <groupId>org.vaadin.addons</groupId>
607
      <artifactId>contextmenu</artifactId>
608
      <version>4.5</version>
609
    </dependency>
610
    <dependency>
611
      <groupId>org.vaadin.teemu</groupId>
612
      <artifactId>switch</artifactId>
613
      <version>2.0.4-SNAPSHOT</version>
614
    </dependency>
615
    <dependency>
616
      <groupId>org.vaadin</groupId>
617
      <artifactId>viritin</artifactId>
618
      <version>1.61</version>
619
    </dependency>
620
    <dependency>
621
      <groupId>org.vaadin.addon</groupId>
622
      <artifactId>v-leaflet</artifactId>
623
      <version>1.0.3</version>
624
    </dependency>
625
    <dependency>
626
      <groupId>org.vaadin.addons.lazyquerycontainer</groupId>
627
      <artifactId>vaadin-lazyquerycontainer</artifactId>
628
      <version>7.6.1.3</version>
629
    </dependency>
630
    <dependency>
631
      <groupId>com.flowingcode.vaadin.addons</groupId>
632
      <artifactId>error-window-vaadin</artifactId>
633
      <version>1.0.0</version>
634
    </dependency>
635
    <!-- 
636
    <dependency>
637
        <groupId>org.vaadin.spring.extensions</groupId>
638
        <artifactId>vaadin-spring-ext-test</artifactId>
639
        <version>0.0.8-SNAPSHOT</version>
640
        <scope>test</scope>
641
    </dependency>
642
     -->
643
    <!--     <dependency>
644
        only in the edit repo
645
      <groupId>org.vaadin.addons</groupId>
646
      <artifactId>lazyloadwrapper</artifactId>
647
      <version>0.1-alpha</version>
648
    </dependency> -->
649
    <!-- ============ cdmlib ============ -->
650
    <dependency>
651
      <groupId>eu.etaxonomy</groupId>
652
      <artifactId>cdmlib-remote</artifactId>
653
      <scope>compile</scope>
654
    </dependency>
655
    <dependency>
656
      <groupId>eu.etaxonomy</groupId>
657
      <artifactId>cdmlib-cache</artifactId>
658
      <version>${cdmlib.version}</version>
659
    </dependency>
660
    <dependency>
661
      <groupId>eu.etaxonomy</groupId>
662
      <artifactId>cdmlib-test</artifactId>
663
      <scope>test</scope>
664
    </dependency>
665
    <dependency>
666
      <groupId>eu.etaxonomy</groupId>
667
      <artifactId>cdmlib-db</artifactId>
668
      <version>${cdmlib.version}</version>
669
      <scope>test</scope>
670
    </dependency>
671
    <!-- ============ Other ============ -->
672
    <!-- 
673
        to override version number coming with vaadin client 
674
        version is managed in cdmlib-parent
675
    -->
676
    <dependency>
677
      <groupId>javax.validation</groupId>
678
      <artifactId>validation-api</artifactId>
679
    </dependency>
680
    <!--    <dependency>
681
      <groupId>org.springmodules</groupId>
682
      <artifactId>spring-modules-cache</artifactId>
683
      <version>0.7</version>
684
      <exclusions>
685
        <exclusion>
686
          <groupId>org.springframework</groupId>
687
          <artifactId>spring</artifactId>
688
        </exclusion>
689
        <exclusion>
690
          <groupId>org.springframework</groupId>
691
          <artifactId>spring-mock</artifactId>
692
        </exclusion>
693
      </exclusions>
694
      <scope>test</scope>
695
    </dependency>  -->
696
    <dependency>
697
      <groupId>org.springframework</groupId>
698
      <artifactId>spring-test</artifactId>
699
      <scope>test</scope>
700
    </dependency>
701
    <dependency>
702
      <groupId>org.json</groupId>
703
      <artifactId>json</artifactId>
704
    </dependency>
705
    <dependency>
706
      <groupId>javax.servlet</groupId>
707
      <artifactId>javax.servlet-api</artifactId>
708
      <scope>provided</scope>
709
    </dependency>
710
    <!-- ========== testing ======== -->
711
    <dependency>
712
      <groupId>com.codeborne</groupId>
713
      <artifactId>selenide</artifactId>
714
      <version>4.7.1</version>
715
      <scope>test</scope>
716
    </dependency>
717
    <dependency>
718
      <groupId>org.springframework.boot</groupId>
719
      <artifactId>spring-boot</artifactId>
720
    </dependency>
721
    <dependency>
722
      <groupId>org.springframework.boot</groupId>
723
      <artifactId>spring-boot-starter-jetty</artifactId>
724
    </dependency>
725
    <dependency>
726
      <groupId>org.springframework</groupId>
727
      <artifactId>spring-beans</artifactId>
728
    </dependency>
729
  </dependencies>
730
</project>
(4-4/4)