Project

General

Profile

task #8505

Updated by Andreas Kohlbecker over 4 years ago

follow up to #8189 

 in ConfigFileUtil  

 **1.** turn all spring bean methods into not statically methods. 

 **2.** better naming for `getFolderSeperator()`: 

 CdmUtils.getFolderSeperator differentiates if the code runs from a jar bundle or if it runs from commandline. In the later case the first case you always need "/" as separator while in the later case it is OS dependendend and therefore the test fails. 
 Distinguishing this is e.g. important when term loading from csv files to distinguish the position of the csv files in the file system. If compiled to a jar you need another folder separator then reading from the ordinary folder on Windows because on Windows File.separator <> "/". 

 But I agree that we should maybe rename CdmUtils.getFolderSeperator to make clear that it is only for this specific usecase and it is not a general shortcut to replace File.separator

Back