Project

General

Profile

Actions

bug #9949

closed

doGetSynonymy throws LIE in Mexico Portal

Added by Andreas Müller over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib-remote
Target version:
Start date:
Due date:
% Done:

90%

Estimated time:
Severity:
critical
Found in Version:
Tags:

Description

Caused by collectorTitleCache creation

Example pages:

https://efloramex.ib.unam.mx/cdm_dataportal/taxon/0a279351-c222-4281-a825-10ba0d3a0ff3

https://efloramex.ib.unam.mx/cdm_dataportal/taxon/d32160d9-6ad9-4e43-95f3-f3b481feaed9

Example webservice:

https://132.248.13.83/cdmserver/cdm_flora_mexico/portal/taxon/d32160d9-6ad9-4e43-95f3-f3b481feaed9/synonymy.json

Caused by: org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: eu.etaxonomy.cdm.model.agent.Team.teamMembers, could not initialize proxy - no Session
        at org.hibernate.collection.internal.AbstractPersistentCollection.throwLazyInitializationException(AbstractPersistentCollection.java:584)
        at org.hibernate.collection.internal.AbstractPersistentCollection.withTemporarySessionIfNeeded(AbstractPersistentCollection.java:201)
        at org.hibernate.collection.internal.AbstractPersistentCollection.readSize(AbstractPersistentCollection.java:145)
        at org.hibernate.collection.internal.PersistentList.size(PersistentList.java:113)
        at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getCache(TeamDefaultCacheStrategy.java:174)
        at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getCollectorTitleCache(TeamDefaultCacheStrategy.java:167)
        at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getCollectorTitleCache(TeamDefaultCacheStrategy.java:1)
        at eu.etaxonomy.cdm.model.agent.Team.getCollectorTitleCache(Team.java:359)
        ... 145 common frames omitted

another time it was

Caused by: org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: eu.etaxonomy.cdm.model.agent.Team.teamMembers, could not initialize proxy - no Session
        at org.hibernate.collection.internal.AbstractPersistentCollection.throwLazyInitializationException(AbstractPersistentCollection.java:584)
        at org.hibernate.collection.internal.AbstractPersistentCollection.withTemporarySessionIfNeeded(AbstractPersistentCollection.java:201)
        at org.hibernate.collection.internal.AbstractPersistentCollection.readSize(AbstractPersistentCollection.java:145)
        at org.hibernate.collection.internal.PersistentList.size(PersistentList.java:113)
        at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getCache(TeamDefaultCacheStrategy.java:174)
        at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getNomenclaturalTitleCache(TeamDefaultCacheStrategy.java:152)
        at eu.etaxonomy.cdm.strategy.cache.agent.TeamDefaultCacheStrategy.getNomenclaturalTitleCache(TeamDefaultCacheStrategy.java:1)
        at eu.etaxonomy.cdm.model.agent.Team.getNomenclaturalTitleCache(Team.java:316)
        at eu.etaxonomy.cdm.remote.json.processor.bean.TeamOrPersonBaseBeanProcessor.processBeanSecondStep(TeamOrPersonBaseBeanProcessor.java:33)
        at eu.etaxonomy.cdm.remote.json.processor.bean.TeamOrPersonBaseBeanProcessor.processBeanSecondStep(TeamOrPersonBaseBeanProcessor.java:21)
        at eu.etaxonomy.cdm.remote.json.processor.bean.AbstractBeanProcessor.processBean(AbstractBeanProcessor.java:154)
        at net.sf.json.JSONObject._fromBean(JSONObject.java:676)
        ... 135 common frames omitted

Related issues

Related to EDIT - feature request #4311: Improve person representation in CDMClosedAndreas Müller

Actions
Related to EDIT - feature request #7309: Implement collectorTitle and collectorTitleCache and the same for nomenclatural title in tax editorFeedbackKatja Luther

Actions
Related to EDIT - bug #10090: Many LIEs in cdmserver log for Team.getCollectorTitleCache()ClosedAndreas Müller

Actions
Actions #1

Updated by Andreas Müller over 2 years ago

  • Description updated (diff)
Actions #2

Updated by Andreas Müller over 2 years ago

Actions #3

Updated by Andreas Müller over 2 years ago

  • Related to feature request #7309: Implement collectorTitle and collectorTitleCache and the same for nomenclatural title in tax editor added
Actions #4

Updated by Andreas Müller over 2 years ago

  • Tags changed from mexico to mexico, 5.30
Actions #5

Updated by Andreas Müller over 2 years ago

  • Description updated (diff)
Actions #6

Updated by Andreas Müller over 2 years ago

  • Subject changed from doSynonymy throws LIE in Mexico Portal to doGetSynonymy throws LIE in Mexico Portal
Actions #7

Updated by Andreas Müller over 2 years ago

  • Status changed from New to In Progress
Actions #8

Updated by Andreas Müller over 2 years ago

  • Description updated (diff)
Actions #9

Updated by Andreas Müller over 2 years ago

The problem is that Mexico eFlora has sec references with authors being teams (though they are often only single persons) with no members having a protected titleCache but a non-protected nomenclaturalCache and collectorCache. Trying to compute the later 2 caches tries to initialize the members collection while calling the titleCache during bean initialization does not initialize the members.

Actions #11

Updated by Andreas Müller over 2 years ago

  • Assignee changed from Andreas Müller to Katja Luther

Please review.

Actions #12

Updated by Katja Luther over 2 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Katja Luther to Andreas Müller

This works as expected and adapted property path seems to be correct.

Actions #13

Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 5.51 to Release 5.30
Actions #14

Updated by Andreas Müller over 2 years ago

  • Tags changed from mexico, 5.30 to mexico
Actions #16

Updated by Andreas Müller almost 2 years ago

  • Related to bug #10090: Many LIEs in cdmserver log for Team.getCollectorTitleCache() added
Actions

Also available in: Atom PDF