Project

General

Profile

Actions

bug #9921

closed

manage/Action.jsp broken

Added by Andreas Kohlbecker over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
New
Category:
cdmserver
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Description

It seems as if something got broken due to the recently made code cleaning.

Clicking on stop in the management UI of the cdmserver fails:

URI:    /cdmserver/manage/Action.jsp
STATUS: 500
MESSAGE:    org.apache.jasper.JasperException: Unable to compile class for JSP: An error occurred at line: [15] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.node.JsonNodeFactory resolves to a package An error occurred at line: [16] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.node.ArrayNode resolves to a package An error occurred at line: [18] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.map.ObjectMapper resolves to a package An error occurred at line: [19] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.JsonNode resolves to a package An error occurred at line: [20] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.node.ObjectNode resolves to a package An error occurred at line: [23] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.JsonFactory resolves to a package An error occurred at line: [24] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.JsonGenerator resolves to a package An error occurred at line: [25] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.map.ser.StdSerializerProvider resolves to a package Stacktrace:
SERVLET:    jsp
CAUSED BY:  org.apache.jasper.JasperException: Unable to compile class for JSP: An error occurred at line: [15] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.node.JsonNodeFactory resolves to a package An error occurred at line: [16] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.node.ArrayNode resolves to a package An error occurred at line: [18] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.map.ObjectMapper resolves to a package An error occurred at line: [19] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.JsonNode resolves to a package An error occurred at line: [20] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.node.ObjectNode resolves to a package An error occurred at line: [23] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.JsonFactory resolves to a package An error occurred at line: [24] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.JsonGenerator resolves to a package An error occurred at line: [25] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java] Only a type can be imported. org.codehaus.jackson.map.ser.StdSerializerProvider resolves to a package Stacktrace:
Caused by:

org.apache.jasper.JasperException: Unable to compile class for JSP: 

An error occurred at line: [15] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java]
Only a type can be imported. org.codehaus.jackson.node.JsonNodeFactory resolves to a package

An error occurred at line: [16] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java]
Only a type can be imported. org.codehaus.jackson.node.ArrayNode resolves to a package

An error occurred at line: [18] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java]
Only a type can be imported. org.codehaus.jackson.map.ObjectMapper resolves to a package

An error occurred at line: [19] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java]
Only a type can be imported. org.codehaus.jackson.JsonNode resolves to a package

An error occurred at line: [20] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java]
Only a type can be imported. org.codehaus.jackson.node.ObjectNode resolves to a package

An error occurred at line: [23] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java]
Only a type can be imported. org.codehaus.jackson.JsonFactory resolves to a package

An error occurred at line: [24] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java]
Only a type can be imported. org.codehaus.jackson.JsonGenerator resolves to a package

An error occurred at line: [25] in the generated java file: [/opt/cdmserver/.cdmLibrary/server/default-webapp/org/apache/jsp/manage/Action_jsp.java]
Only a type can be imported. org.codehaus.jackson.map.ser.StdSerializerProvider resolves to a package

Stacktrace:
    at org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:102)
    at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:212)
    at org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:549)
    at org.apache.jasper.compiler.Compiler.compile(Compiler.java:378)
    at org.apache.jasper.compiler.Compiler.compile(Compiler.java:350)
    at org.apache.jasper.compiler.Compiler.compile(Compiler.java:334)
    at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:595)
    at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:399)
    at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:386)
    at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:330)
    at org.eclipse.jetty.jsp.JettyJspServlet.service(JettyJspServlet.java:106)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
    at org.eclipse.jetty.servlet.ServletHolder$NotAsyncServlet.service(ServletHolder.java:1386)
    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:755)
    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:547)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
    at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:555)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:127)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(ScopedHandler.java:235)
    at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:1607)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(ScopedHandler.java:233)
    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1297)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(ScopedHandler.java:188)
    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:485)
    at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:1577)
    at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(ScopedHandler.java:186)
    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1212)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
    at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:221)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:127)
    at org.eclipse.jetty.server.Server.handle(Server.java:500)
    at org.eclipse.jetty.server.HttpChannel.lambda$handle$1(HttpChannel.java:383)
    at org.eclipse.jetty.server.HttpChannel.dispatch(HttpChannel.java:547)
    at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:375)
    at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:270)
    at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:311)
    at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:103)
    at org.eclipse.jetty.io.ChannelEndPoint$2.run(ChannelEndPoint.java:117)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(EatWhatYouKill.java:336)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(EatWhatYouKill.java:313)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(EatWhatYouKill.java:171)
    at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.run(EatWhatYouKill.java:129)
    at org.eclipse.jetty.util.thread.ReservedThreadExecutor$ReservedThread.run(ReservedThreadExecutor.java:388)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:806)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$Runner.run(QueuedThreadPool.java:938)
    at java.lang.Thread.run(Thread.java:748)

~~
Actions #1

Updated by Andreas Kohlbecker over 2 years ago

  • Description updated (diff)
Actions #2

Updated by Andreas Müller over 2 years ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Müller to Andreas Kohlbecker
  • % Done changed from 0 to 50

Please review.

Actions #3

Updated by Andreas Kohlbecker over 2 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

Problem is fully solved.

Actions #4

Updated by Andreas Kohlbecker over 2 years ago

  • Assignee changed from Andreas Kohlbecker to Andreas Müller
Actions #5

Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 5.45 to Release 5.29
Actions

Also available in: Atom PDF