Project

General

Profile

Actions

bug #9900

closed

Null values in agent search dialog

Added by Katja Luther about 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Description

mail AM:

schon seit längerem ist mir aufgefallen, dass bei der Anzeige von Personen im Dialog etwas nicht stimmt. Z.B. hier die ganzen „null“ Werte (aus rem_conf_am).
Kannst du dir das mal anschauen. Wobei wir evtl. nochmal genau definieren müssen, welcher Cache bei welcher Suche als erstes, zweites und drittes angezeigt werden soll und wie mit gleichen oder nicht existierenden Werten umgegangen werden soll. Wobei es letztere eigentlich gar nicht geben sollte, da die Caches ja eigentlich immer was zurückgeben sollten.


Files

picture776-1.png (66.8 KB) picture776-1.png Katja Luther, 12/17/2021 11:42 AM
clipboard-202201211212-sm9dm.png (43.3 KB) clipboard-202201211212-sm9dm.png Andreas Müller, 01/21/2022 12:12 PM
Actions #1

Updated by Katja Luther about 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

This should be fixed.

Actions #2

Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 80

The null is not there anymore so the ticket seems to be fixed.

I only wonder why there was so much code attached. Was there so much refactoring needed or does the code belong to other tasks, too?

Have you checked that all commented code has been removed if not needed anymore?

Ticket generally can be closed.

Actions #3

Updated by Andreas Müller about 1 year ago

  • % Done changed from 80 to 70

... upps I just realize that, when editing a team and open the dialogue to add a new team member the problem still exists. Please check if it is really fixed for all uses of the person dialogue.

Actions #4

Updated by Katja Luther about 1 year ago

Andreas Müller wrote in #note-2:

The null is not there anymore so the ticket seems to be fixed.

I only wonder why there was so much code attached. Was there so much refactoring needed or does the code belong to other tasks, too?

Have you checked that all commented code has been removed if not needed anymore?

Ticket generally can be closed.

I also checked whether nomenclatural author and reference selection dialogs searching for nomenclatural authors/references.

Actions #5

Updated by Katja Luther about 1 year ago

Andreas Müller wrote in #note-3:

... upps I just realize that, when editing a team and open the dialogue to add a new team member the problem still exists. Please check if it is really fixed for all uses of the person dialogue.

Where did you find this behaviour? I could not reproduce it with my workspace verison and the nightly version can not be connected to the test instances.

Actions #6

Updated by Andreas Müller about 1 year ago

Katja Luther wrote in #note-5:

Andreas Müller wrote in #note-3:

... upps I just realize that, when editing a team and open the dialogue to add a new team member the problem still exists. Please check if it is really fixed for all uses of the person dialogue.

Where did you find this behaviour? I could not reproduce it with my workspace verison and the nightly version can not be connected to the test instances.

Actions #7

Updated by Katja Luther about 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

This should be fixed now. Also fixed for new teams. Please review.

Actions #8

Updated by Andreas Müller about 1 year ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 70 to 100
Actions #9

Updated by Andreas Müller 12 months ago

  • Target version changed from Release 5.37 to Release 5.29
Actions

Also available in: Atom PDF