Project

General

Profile

Actions

bug #9878

closed

show MediaSpecimen media source citations in registration items

Added by Wolf-Henning Kusber over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
major
Found in Version:

Description

If lectotype= published image, image reference and refdetail not shown.
see marked areas for Vaadin

For the production portal:


Files

picture271-1.png (68.8 KB) picture271-1.png Wolf-Henning Kusber, 11/22/2021 06:02 PM
picture271-2.png (135 KB) picture271-2.png Wolf-Henning Kusber, 11/22/2021 06:02 PM

Related issues

Related to EDIT - feature request #9388: show media specimen source in all pagesNewAndreas Kohlbecker

Actions
Actions #1

Updated by Andreas Kohlbecker over 2 years ago

  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.45
  • Severity changed from normal to major
Actions #2

Updated by Andreas Kohlbecker over 2 years ago

  • Status changed from New to In Progress

The problem with this issue is that we are suppressing the "designated by ..." reference by just removing all separators and references from the tagged text. This way we also remove the media source reference, though.

Unfortunately there is no way to distinguish the media source reference and the designation reference. Therefore we need to use the separator text (" designated by ") to crop the tagged text at this position.

Actions #3

Updated by Andreas Kohlbecker over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 50

the issue in the web ui (vaadin) is fixed, the data portal issues are handled in #9388

Actions #4

Updated by Andreas Kohlbecker over 2 years ago

Actions #5

Updated by Andreas Kohlbecker over 2 years ago

  • Subject changed from If lectotype= published image, image reference and refdetail not shown to show media specimen media source citations in registration items
Actions #6

Updated by Andreas Kohlbecker over 2 years ago

  • Subject changed from show media specimen media source citations in registration items to show MediaSpecimen media source citations in registration items
Actions #7

Updated by Andreas Kohlbecker about 2 years ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

please can you review this ticket? Only the vaadin part is relevant.

Actions #8

Updated by Wolf-Henning Kusber about 2 years ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 100

In Vaadin the issue is resolved. The ticket can be closed.

Actions #9

Updated by Andreas Kohlbecker about 2 years ago

  • Status changed from Resolved to Closed
Actions #10

Updated by Andreas Müller about 2 years ago

  • Target version changed from Release 5.45 to Release 5.29
Actions

Also available in: Atom PDF