Project

General

Profile

bug #9721

Specimen Table: wrong labels of specimen scans

Added by Andreas Kohlbecker 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
Start date:
07/22/2021
Due date:
% Done:

100%

Severity:
normal
Found in Version:

picture792-1.png View (64.6 KB) Andreas Kohlbecker, 07/22/2021 11:51 AM

Associated revisions

Revision 2de4677e (diff)
Added by Andreas Kohlbecker 3 months ago

fix #9721 individual labels for specimen scans

Revision 80b55fda (diff)
Added by Andreas Kohlbecker 3 months ago

ref #9721 individual labels for specimen scans - acc num + media title

Revision 7d861f5c (diff)
Added by Andreas Kohlbecker 3 months ago

ref #9721 adapting test assertions

History

#1 Updated by Andreas Kohlbecker 3 months ago

  • Description updated (diff)
  • Category changed from cdm-dataportal to cdm

This is caused by the DerivationTreeSummaryDTO which composes identical labels for multiple scans of the same specimen:

The portal/occurrence/89d36e79-3e80-4468-986e-411ca391452e/asDTO.json

"class": "DerivationTreeSummaryDTO",
"specimenScans": [

    {
        "linkText": "CEDiT 2017E68",
        "class": "Link",
        "uri": "https://pictures.bgbm.org/digilib/Scaler?fn=Cyprus/Sisymbrium_aegyptiacum_C1.jpg&mo=file"
    },
    {
        "linkText": "CEDiT 2017E68",
        "class": "Link",
        "uri": "https://plants.jstor.org/stable/viewer/10.5555/al.ap.specimen.m0093531"
    },
    {
        "linkText": "CEDiT 2017E68",
        "class": "Link",
        "uri": "https://plants.jstor.org/stable/viewer/10.5555/al.ap.specimen.linn-hs1310-54"
    }

]

code:

if (media.getKindOfUnit().getUuid().equals(DefinedTerm.uuidSpecimenScan)) {
                        derivateDataDTO.addSpecimenScanUuid(media.getMediaSpecimen().getUuid());
                        String imageLinkText = "scan";
                        imageLinkText = specimenIdentifier;
                        derivateDataDTO.addSpecimenScan(mediaUri, imageLinkText);
                    }

#2 Updated by Andreas Kohlbecker 3 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#3 Updated by Andreas Kohlbecker 3 months ago

  • Status changed from Resolved to Closed
  • Target version changed from Release 5.28 to Release 5.26
  • % Done changed from 50 to 100

#4 Updated by Andreas Kohlbecker 3 months ago

  • Category changed from cdm to cdmlib

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)