Project

General

Profile

bug #9714

cdm-light export: NotSerializableException when starting export via http invoker

Added by Andreas Kohlbecker 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
Start date:
07/17/2021
Due date:
% Done:

100%

Severity:
critical
Found in Version:

Description

ich kann den Cactaceae-Export aus Caryophyllales_spp immer noch nicht machen, bekomme sofort den untenstehenden Fehler.

Alles andere scheint zu laufen.

HG
W

last remote method : http://api.cybertaxonomy.org:80/caryophyllales_spp/remoting/classification.service

last remote request client time : 2021-07-17T05:23:55.482

last remote request response header time : Sat, 17 Jul 2021 03:23:53 GMT

client error time : 2021-07-17T05:23:55.683

login : w.berendsohn

editor version : 5.25.0

server : api.cybertaxonomy.org (cybertaxonomy.org) / caryophyllales_spp

schema version : 5.25.1.0.20210702

os : Windows 10 10.0 amd64

java : 1.8.0_291

org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [http://api.cybertaxonomy.org:80/caryophyllales_spp/remoting/io.service]; nested exception is java.io.NotSerializableException: eu.etaxonomy.cdm.ext.geo.CondensedDistributionConfiguration

                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.convertHttpInvokerAccessException(HttpInvokerClientInterceptor.java:226)

                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.invoke(HttpInvokerClientInterceptor.java:153)

                at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)

                at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:213)

                at com.sun.proxy.$Proxy50.monitExportData(Unknown Source)

                at eu.etaxonomy.taxeditor.io.ExportManager.runMoniteredOperation(ExportManager.java:372)

                at eu.etaxonomy.taxeditor.io.e4.out.cdmlight.CdmLightExportWizardE4.performFinish(CdmLightExportWizardE4.java:131)

                at org.eclipse.jface.wizard.WizardDialog.finishPressed(WizardDialog.java:790)

                at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:423)

                at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:618)

                at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:249)

                at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)

                at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)

                at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)

                at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)

                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)

                at org.eclipse.jface.window.Window.runEventLoop(Window.java:818)

                at org.eclipse.jface.window.Window.open(Window.java:794)

                at eu.etaxonomy.taxeditor.io.e4.out.AbstractOpenExportWizard.execute(AbstractOpenExportWizard.java:30)

                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

                at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

                at java.lang.reflect.Method.invoke(Unknown Source)

                at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)

                at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)

                at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:288)

                at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)

                at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)

                at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)

                at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)

                at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)

                at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)

                at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)

                at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)

                at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)

                at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)

                at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)

                at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)

                at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)

                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)

                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)

                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)

                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)

                at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)

                at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)

                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)

                at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)

                at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)

                at eu.etaxonomy.taxeditor.Application.start(Application.java:20)

                at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)

                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)

                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)

                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)

                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

                at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

                at java.lang.reflect.Method.invoke(Unknown Source)

                at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)

                at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)

                at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

Caused by: java.io.NotSerializableException: eu.etaxonomy.cdm.ext.geo.CondensedDistributionConfiguration

                at java.io.ObjectOutputStream.writeObject0(Unknown Source)

                at java.io.ObjectOutputStream.defaultWriteFields(Unknown Source)

                at java.io.ObjectOutputStream.writeSerialData(Unknown Source)

                at java.io.ObjectOutputStream.writeOrdinaryObject(Unknown Source)

                at java.io.ObjectOutputStream.writeObject0(Unknown Source)

                at java.io.ObjectOutputStream.writeArray(Unknown Source)

                at java.io.ObjectOutputStream.writeObject0(Unknown Source)

                at java.io.ObjectOutputStream.defaultWriteFields(Unknown Source)

                at java.io.ObjectOutputStream.writeSerialData(Unknown Source)

                at java.io.ObjectOutputStream.writeOrdinaryObject(Unknown Source)

                at java.io.ObjectOutputStream.writeObject0(Unknown Source)

                at java.io.ObjectOutputStream.writeObject(Unknown Source)

                at org.springframework.remoting.httpinvoker.AbstractHttpInvokerRequestExecutor.doWriteRemoteInvocation(AbstractHttpInvokerRequestExecutor.java:199)

                at org.springframework.remoting.httpinvoker.AbstractHttpInvokerRequestExecutor.writeRemoteInvocation(AbstractHttpInvokerRequestExecutor.java:168)

                at org.springframework.remoting.httpinvoker.AbstractHttpInvokerRequestExecutor.getByteArrayOutputStream(AbstractHttpInvokerRequestExecutor.java:148)

                at org.springframework.remoting.httpinvoker.AbstractHttpInvokerRequestExecutor.executeRequest(AbstractHttpInvokerRequestExecutor.java:132)

                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.executeRequest(HttpInvokerClientInterceptor.java:202)

                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.executeRequest(HttpInvokerClientInterceptor.java:184)

                at org.springframework.remoting.httpinvoker.CachingHttpInvokerProxyFactoryBean.doExecuteRequest(CachingHttpInvokerProxyFactoryBean.java:149)

                at org.springframework.remoting.httpinvoker.CachingHttpInvokerProxyFactoryBean.handleGeneralRequest(CachingHttpInvokerProxyFactoryBean.java:87)

                at org.springframework.remoting.httpinvoker.CachingHttpInvokerProxyFactoryBean.executeRequest(CachingHttpInvokerProxyFactoryBean.java:81)

                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.invoke(HttpInvokerClientInterceptor.java:150)

                ... 59 more

Associated revisions

Revision 90720c06 (diff)
Added by Andreas Kohlbecker 3 months ago

ref #9714 making CondensedDistributionConfiguration serializable

History

#1 Updated by Andreas Kohlbecker 3 months ago

  • Status changed from New to In Progress
  • Assignee changed from Andreas Müller to Andreas Kohlbecker

#2 Updated by Andreas Kohlbecker 3 months ago

  • Status changed from In Progress to Closed
  • Target version changed from Release 5.28 to Release 5.26
  • % Done changed from 0 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)