Project

General

Profile

bug #9688

Make disabled fields copyable

Added by Katja Luther 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
06/30/2021
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

from #9287:

There is only one final issue which is valid for all disabled fields. Is it possible to generally make disabled fields copyable? Currently they only show the text but it is not possble to copy it. At some places this is already implemented. We probably should move this issue to a new ticket.


Related issues

Duplicated by Edit - bug #8277: Username (and other fields) should allow c&p Duplicate 05/16/2019
Copied from Edit - feature request #9287: Show term details in details view of term tree editor Closed 11/09/2020

Associated revisions

Revision 8fbdff7b (diff)
Added by Katja Luther 4 months ago

ref #9688: make disabled fields copyable

Revision 5953dcce (diff)
Added by Katja Luther 4 months ago

fix #9688: Adapt toggleable text field to textWithLabel to avoid changes if disabled

Revision 20e64571 (diff)
Added by Katja Luther 4 months ago

fix #9688: Fix disabled toggleable text field

Revision 4181f8aa (diff)
Added by Katja Luther 3 months ago

ref #9688: keep username field disabled when updating controls

History

#1 Updated by Katja Luther 4 months ago

  • Subject changed from make disabled fields copyable to Make disabled fields copyable

#2 Updated by Katja Luther 4 months ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • Target version changed from Unassigned CDM tickets to Release 5.25

please review.

#3 Updated by Andreas Müller 4 months ago

#4 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 30

Copy from #9287:

AM:

For toggleable they still set the dirty flag (tested on Person details view with bulk editor). This is unwanted.

I do not yet fully understand why it is not possible to use the same technique as for ordinary text fields in toggleable fields.

KL:

The same technique is used for text fields and toggleable text fields but maybe I need to have a look on the event handling of the toggleable text field.

#5 Updated by Katja Luther 4 months ago

Andreas Müller wrote:

Copy from #9287:

AM:

For toggleable they still set the dirty flag (tested on Person details view with bulk editor). This is unwanted.

I do not yet fully understand why it is not possible to use the same technique as for ordinary text fields in toggleable fields.

KL:

The same technique is used for text fields and toggleable text fields but maybe I need to have a look on the event handling of the toggleable text field.

The toggleable text field has additional modifyListener and keyListener, maybe this is the cause of the different behaviour.

#6 Updated by Katja Luther 4 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 30 to 50

#7 Updated by Katja Luther 4 months ago

  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 50 to 30

This is fixed, please review.

#8 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Now an unprotected toggleable field can be edited. I tested with unprotected collector title of a team. But same result for e.g. name cache.

#9 Updated by Katja Luther 4 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 30 to 50

#10 Updated by Andreas Müller 4 months ago

  • Assignee changed from Katja Luther to Andreas Müller

I guess this is for review.

#11 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

works as expected now.

#12 Updated by Andreas Müller 3 months ago

  • Duplicated by bug #8277: Username (and other fields) should allow c&p added

#13 Updated by Andreas Müller 3 months ago

  • Status changed from Closed to Feedback
  • % Done changed from 100 to 80

I have to reopen this as now the Username and Group.name fields are editable again, but shouldn't. See also #8277.

Changing the username must not be possible. What is the reason why these fields are now editable again? Is it possible that there are other fields influenced in the same way that are now editable but they shouldn't? If yes, this is critical and needs to be fixed as soon as possible.

#14 Updated by Katja Luther 3 months ago

Fixed it for the Userdetails but the group name never was disabled. I can do this as well, but maybe this is a little bit more difficult because it should be editable as long as it is not used anywhere?

#15 Updated by Andreas Müller 3 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 80 to 90

Katja Luther wrote:

Fixed it for the Userdetails but the group name never was disabled. I can do this as well, but maybe this is a little bit more difficult because it should be editable as long as it is not used anywhere?

Yes, for groupnames it is not so obvious. But both fields are marked as unique so the easiest way to guarantee this is to make the field not editable. On the other hand a groupname should have a semantic meaning so sometimes an admin may want to change the name to a better one.
So, yes, probably we should leave it editable. It is not a serious issue anyway.

I will check the username implementation and close the ticket then.

#16 Updated by Andreas Müller 3 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 90 to 100

For usernames it works as expected.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)