Project

General

Profile

bug #9651

After creating a new MAN the details view is filled with other MAN

Added by Katja Luther 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
06/07/2021
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

mail WB:

Hallo,
es geht um die EIngabe eines MAN mit dem gleichen Namen wie ein bereits bestehender MAN (derzeit ist das häufig notwendig, da man ja nur eine Referenz als sensu eingeben kann).
Im Name Editor tippe ich Enter, suche dann den Namen im Details view heraus, speichere das und erkläre dann das Synonym zum MAN.

Dann springt der Details View auf die Details des anderen angegebenen MANs

picture003-1.png View (30.2 KB) Katja Luther, 06/07/2021 10:07 AM

picture003-2.png View (34.9 KB) Katja Luther, 06/07/2021 10:07 AM

Associated revisions

Revision 1b62813b (diff)
Added by Katja Luther 4 months ago

fix #9651: setFocus only for selected conceptContainer

History

#1 Updated by Katja Luther 4 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Katja Luther 4 months ago

  • Category set to taxeditor
  • Assignee set to Andreas Müller
  • Target version changed from Unassigned CDM tickets to Release 5.25

This problem was caused by setting the focus everytime the name editor is refreshed and all containers are redrawed. Maybe this also can be optimised to only redraw the selected container, but this is another ticket, sometimes the order of the containers will change therefore the complete redraw is needed (for example when changing a MAN into synonym)

Please review.

#3 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

Seem to work as expected (but not sure if I could reproduce it correctly)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)