Project

General

Profile

bug #9641

NameTypeDesignationEditor: LIE related to typifiedNames.nomenclaturalSource

Added by Andreas Kohlbecker 13 days ago. Updated 12 days ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
06/01/2021
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

Test System

Genus = Sabbea (published, orig. des.) --> open NameTypeDesignation Editor

Caused by: org.hibernate.LazyInitializationException: could not initialize proxy - no Session
    at org.hibernate.proxy.AbstractLazyInitializer.initialize(AbstractLazyInitializer.java:147)
    at org.hibernate.proxy.AbstractLazyInitializer.getImplementation(AbstractLazyInitializer.java:260)
    at org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer.invoke(JavassistLazyInitializer.java:73)
    at eu.etaxonomy.cdm.model.reference.Reference_$$_jvste28_2d.getType(Reference_$$_jvste28_2d.java)
    at eu.etaxonomy.cdm.vaadin.view.name.NameTypeDesignationPresenter.loadBeanById(NameTypeDesignationPresenter.java:147)
    at eu.etaxonomy.cdm.vaadin.view.name.NameTypeDesignationPresenter.loadBeanById(NameTypeDesignationPresenter.java:1)
    at eu.etaxonomy.vaadin.mvp.AbstractPopupEditor.loadInEditor(AbstractPopupEditor.java:848)
    at eu.etaxonomy.cdm.vaadin.view.registration.RegistrationWorkingsetPresenter.onTypeDesignationsEditorActionEdit(RegistrationWorkingsetPresenter.java:568)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.vaadin.spring.events.internal.MethodListenerWrapper.publish(MethodListenerWrapper.java:78)
    at org.vaadin.spring.events.internal.ListenerCollection.publish(ListenerCollection.java:167)
    at org.vaadin.spring.events.internal.ScopedEventBus.publish(ScopedEventBus.java:116)
    at org.vaadin.spring.events.internal.ScopedEventBus.publish(ScopedEventBus.java:109)
    at eu.etaxonomy.cdm.vaadin.view.registration.RegistrationWorksetViewBean.lambda$4(RegistrationWorksetViewBean.java:404)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at com.vaadin.event.ListenerMethod.receiveEvent(ListenerMethod.java:510)
    ... 82 more

Associated revisions

Revision 830b420d (diff)
Added by Andreas Kohlbecker 13 days ago

fix #9641 adding init strategy for typifiedNames.nomenclaturalSource.citation

History

#1 Updated by Andreas Kohlbecker 13 days ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Andreas Kohlbecker 13 days ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

please review on the test system

#3 Updated by Wolf-Henning Kusber 13 days ago

no errors yet, seems to be correct, but I need to check more examples.

#4 Updated by Wolf-Henning Kusber 13 days ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 100

opening, saving, editing is working without problems for new and old records. Ticket can be closed.

#5 Updated by Andreas Kohlbecker 12 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)