Project

General

Profile

Actions

bug #9629

open

Better handling of OptionalDataException

Added by Katja Luther over 2 years ago. Updated 9 months ago.

Status:
In Progress
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

80%

Estimated time:
Severity:
normal
Found in Version:

Description

This exception should be handled and the user should be informed to restart the editor.

last remote method : http://api.cybertaxonomy.org:80/euromed/remoting/term.service
last remote request client time : 2021-05-19T11:32:16.744
last remote request response header time : Wed, 19 May 2021 11:32:16 GMT
client error time : 2021-05-19T11:32:16.914
login : e.raabstraube
editor version : 5.22.1
server : api.cybertaxonomy.org (cybertaxonomy.org) / euromed
schema version : 5.22.0.0.20210315
os : Windows 7 6.1 amd64
java : 1.8.0_231
org.eclipse.swt.SWTException: Failed to execute runnable (org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [http://api.cybertaxonomy.org:80/euromed/remoting/term.service]; nested exception is net.sf.ehcache.CacheException: java.io.OptionalDataException)
                at org.eclipse.swt.SWT.error(SWT.java:4533)
                at org.eclipse.swt.SWT.error(SWT.java:4448)
                at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
                at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
                at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
                at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
                at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
                at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
                at eu.etaxonomy.taxeditor.Application.start(Application.java:20)
                at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                at java.lang.reflect.Method.invoke(Unknown Source)
                at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
                at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
                at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [http://api.cybertaxonomy.org:80/euromed/remoting/term.service]; nested exception is net.sf.ehcache.CacheException: java.io.OptionalDataException
                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.convertHttpInvokerAccessException(HttpInvokerClientInterceptor.java:226)
                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.invoke(HttpInvokerClientInterceptor.java:153)
                at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
                at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:213)
                at com.sun.proxy.$Proxy45.list(Unknown Source)
                at eu.etaxonomy.taxeditor.store.TermStore.getTermsFromService(TermStore.java:115)
                at eu.etaxonomy.taxeditor.store.TermStore.access$0(TermStore.java:110)
                at eu.etaxonomy.taxeditor.store.TermStore$4.getTerms(TermStore.java:214)
                at eu.etaxonomy.taxeditor.store.TermStore.getTerms(TermStore.java:92)
                at eu.etaxonomy.taxeditor.store.TermStore.getTerms(TermStore.java:52)
                at eu.etaxonomy.taxeditor.store.TermManager.getTerms(TermManager.java:334)
                at eu.etaxonomy.taxeditor.ui.section.description.detail.DistributionDetailElement.getStatusListForArea(DistributionDetailElement.java:128)
                at eu.etaxonomy.taxeditor.ui.section.description.detail.DistributionDetailElement.createControls(DistributionDetailElement.java:92)
                at eu.etaxonomy.taxeditor.ui.section.description.detail.DistributionDetailElement.createControls(DistributionDetailElement.java:1)
                at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailElement.updateContent(AbstractCdmDetailElement.java:106)
                at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailElement.setEntity(AbstractCdmDetailElement.java:93)
                at eu.etaxonomy.taxeditor.ui.section.description.detail.AbstractDetailedDescriptionDetailElement.<init>(AbstractDetailedDescriptionDetailElement.java:51)
                at eu.etaxonomy.taxeditor.ui.section.description.detail.DistributionDetailElement.<init>(DistributionDetailElement.java:63)
                at eu.etaxonomy.taxeditor.ui.element.CdmFormFactory.createDetailedDescriptionDetailElement(CdmFormFactory.java:3404)
                at eu.etaxonomy.taxeditor.ui.section.description.DescriptionElementDetailElement.createControls(DescriptionElementDetailElement.java:42)
                at eu.etaxonomy.taxeditor.ui.section.description.DescriptionElementDetailElement.createControls(DescriptionElementDetailElement.java:1)
                at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailElement.updateContent(AbstractCdmDetailElement.java:106)
                at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailElement.setEntity(AbstractCdmDetailElement.java:93)
                at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailSection.setEntity(AbstractCdmDetailSection.java:155)
                at eu.etaxonomy.taxeditor.view.detail.CdmSectionPart.setFormInput(CdmSectionPart.java:158)
                at org.eclipse.ui.forms.ManagedForm.setInput(ManagedForm.java:210)
                at eu.etaxonomy.taxeditor.view.e4.AbstractCdmDataViewerE4.refresh(AbstractCdmDataViewerE4.java:158)
                at eu.etaxonomy.taxeditor.view.e4.AbstractCdmDataViewerE4.setInput(AbstractCdmDataViewerE4.java:141)
                at eu.etaxonomy.taxeditor.view.e4.details.DetailsViewerE4.setInput(DetailsViewerE4.java:206)
                at eu.etaxonomy.taxeditor.view.e4.details.DetailsViewerE4.setInput(DetailsViewerE4.java:177)
                at eu.etaxonomy.taxeditor.view.e4.AbstractCdmEditorPartE4.showViewer(AbstractCdmEditorPartE4.java:283)
                at eu.etaxonomy.taxeditor.view.e4.details.DetailsPartE4.selectionChanged_internal(DetailsPartE4.java:107)
                at eu.etaxonomy.taxeditor.view.e4.AbstractCdmEditorPartE4$DelaySelection.run(AbstractCdmEditorPartE4.java:94)
                at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
                at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
                ... 23 more
Caused by: net.sf.ehcache.CacheException: java.io.OptionalDataException
                at net.sf.ehcache.store.disk.DiskStorageFactory.retrieve(DiskStorageFactory.java:891)
                at net.sf.ehcache.store.disk.Segment.decodeHit(Segment.java:182)
                at net.sf.ehcache.store.disk.Segment.get(Segment.java:225)
                at net.sf.ehcache.store.disk.DiskStore.fault(DiskStore.java:210)
                at net.sf.ehcache.store.CacheStore$4.call(CacheStore.java:198)
                at net.sf.ehcache.store.CacheStore$4.call(CacheStore.java:192)
                at net.sf.ehcache.store.cachingtier.OnHeapCachingTier$Fault.get(OnHeapCachingTier.java:335)
                at net.sf.ehcache.store.cachingtier.OnHeapCachingTier$Fault.access$200(OnHeapCachingTier.java:312)
                at net.sf.ehcache.store.cachingtier.OnHeapCachingTier.get(OnHeapCachingTier.java:176)
                at net.sf.ehcache.store.CacheStore.get(CacheStore.java:192)
                at net.sf.ehcache.Cache.get(Cache.java:1749)
                at net.sf.ehcache.Cache.get(Cache.java:1722)
                at eu.etaxonomy.cdm.api.cache.CdmCacherBase.getCacheElement(CdmCacherBase.java:105)
                at eu.etaxonomy.cdm.api.cache.CdmCacherBase.getFromCache(CdmCacherBase.java:140)
                at eu.etaxonomy.cdm.api.cache.CdmServiceCacher.load(CdmServiceCacher.java:155)
                at eu.etaxonomy.cdm.cache.CdmTransientEntityCacher.putToCache(CdmTransientEntityCacher.java:227)
                at eu.etaxonomy.cdm.cache.CacheLoader.putToCache(CacheLoader.java:294)
                at eu.etaxonomy.cdm.cache.CacheLoader.loadRecursive(CacheLoader.java:321)
                at eu.etaxonomy.cdm.cache.CacheLoader.loadRecursiveAny(CacheLoader.java:83)
                at eu.etaxonomy.cdm.cache.CacheLoader.loadRecursiveCollection(CacheLoader.java:190)
                at eu.etaxonomy.cdm.cache.CacheLoader.load(CacheLoader.java:157)
                at eu.etaxonomy.cdm.cache.CacheLoader.load(CacheLoader.java:66)
                at eu.etaxonomy.cdm.cache.CdmTransientEntityCacher.load(CdmTransientEntityCacher.java:165)
                at eu.etaxonomy.taxeditor.session.CdmEntitySession.load(CdmEntitySession.java:65)
                at eu.etaxonomy.taxeditor.session.CdmEntitySessionManager.load(CdmEntitySessionManager.java:119)
                at org.springframework.remoting.httpinvoker.CachingHttpInvokerProxyFactoryBean.handleGeneralRequest(CachingHttpInvokerProxyFactoryBean.java:105)
                at org.springframework.remoting.httpinvoker.CachingHttpInvokerProxyFactoryBean.executeRequest(CachingHttpInvokerProxyFactoryBean.java:81)
                at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.invoke(HttpInvokerClientInterceptor.java:150)
                ... 56 more
Caused by: java.io.OptionalDataException
                at java.io.ObjectInputStream.readObject0(Unknown Source)
                at java.io.ObjectInputStream.readObject(Unknown Source)
                at java.util.HashSet.readObject(Unknown Source)
                at sun.reflect.GeneratedMethodAccessor33.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                at java.lang.reflect.Method.invoke(Unknown Source)
                at java.io.ObjectStreamClass.invokeReadObject(Unknown Source)
                at java.io.ObjectInputStream.readSerialData(Unknown Source)
                at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
                at java.io.ObjectInputStream.readObject0(Unknown Source)
                at java.io.ObjectInputStream.defaultReadFields(Unknown Source)
                at java.io.ObjectInputStream.readSerialData(Unknown Source)
                at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
                at java.io.ObjectInputStream.readObject0(Unknown Source)
                at java.io.ObjectInputStream.defaultReadFields(Unknown Source)
                at java.io.ObjectInputStream.defaultReadObject(Unknown Source)
                at net.sf.ehcache.Element.readObject(Element.java:885)
                at sun.reflect.GeneratedMethodAccessor66.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                at java.lang.reflect.Method.invoke(Unknown Source)
                at java.io.ObjectStreamClass.invokeReadObject(Unknown Source)
                at java.io.ObjectInputStream.readSerialData(Unknown Source)
                at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
                at java.io.ObjectInputStream.readObject0(Unknown Source)
                at java.io.ObjectInputStream.readObject(Unknown Source)
                at net.sf.ehcache.store.disk.DiskStorageFactory.read(DiskStorageFactory.java:371)
                at net.sf.ehcache.store.disk.DiskStorageFactory.retrieve(DiskStorageFactory.java:887)
                ... 83 more


Related issues

Related to EDIT - bug #9358: OptionalDataException during HTTP invoker call NewKatja Luther

Actions
Actions #1

Updated by Andreas Müller over 2 years ago

  • Target version changed from Unassigned CDM tickets to Release 5.25

I guess this is fast to implement as we only need to search for "java.io.OptionalDataException" in the stacktrace.
Also it happens relatively often so it is worth implementing it soon to avoid user requests on this.

Actions #2

Updated by Andreas Müller over 2 years ago

  • Related to bug #9358: OptionalDataException during HTTP invoker call added
Actions #3

Updated by Andreas Müller over 2 years ago

The general problem was reported in #9358 already.

Actions #4

Updated by Katja Luther over 2 years ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

the exception is hanlded now, please review.

Actions #5

Updated by Andreas Müller over 2 years ago

  • Status changed from Resolved to Closed

This is difficult to review as I can't create the exception that shows if it works or not. However, the code looks ok and I suggest to close the ticket and reopen if it does not work.

Actions #6

Updated by Andreas Müller over 2 years ago

  • % Done changed from 0 to 100
Actions #7

Updated by Andreas Müller over 2 years ago

  • Target version changed from Release 5.25 to Release 5.24
Actions #8

Updated by Andreas Müller over 2 years ago

  • Status changed from Closed to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • Target version changed from Release 5.24 to Release 5.25
  • % Done changed from 100 to 10

Reopen this ticket. Using toString is incorrect method to check if an exception is in the stacktrace.

exception.toString returns something like "[Ljava.lang.StackTraceElement;@15db9742"

There should be other example in the code for correct error extraction.

Actions #9

Updated by Andreas Müller over 2 years ago

For testing you could manually throw an OptionalDataException and try to catch it correctly.

Actions #10

Updated by Andreas Müller over 2 years ago

You could e.g. recursively iterate through exception e and its causes e.getCause() and check all these exceptions for getClass().getName()

Actions #11

Updated by Katja Luther over 2 years ago

  • Status changed from Feedback to In Progress
  • Target version changed from Release 5.25 to Release 5.43
Actions #12

Updated by Andreas Müller about 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 10 to 50
Actions #13

Updated by Andreas Müller about 2 years ago

  • Priority changed from New to Highest
  • Target version changed from Release 5.43 to Release 5.25

This should be fixed. I tested by adding the following code to the beginning of BulkEditorUtil.openBulkEditor()

   try{
        Constructor<OptionalDataException> c = OptionalDataException.class.getDeclaredConstructor(int.class);
        c.setAccessible(true);
        OptionalDataException a = c.newInstance(0);
        if (true) {
            throw a;
        }
    }catch(Exception e){
        try {
            throw new RuntimeException(e);
        } catch (Exception e1) {
            throw new RuntimeException(e1);
        }
    }

and then opening the author bulk editor.

Please review and maybe adapt error handling if needed.

Actions #14

Updated by Katja Luther about 2 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 50 to 100

works as expected.

Actions #15

Updated by Katja Luther 10 months ago

  • Status changed from Closed to In Progress

Reopen the ticket because it appeared again:

Hallo,
Caryophyllales_spp, beim Aufruf eines Synonyms aus der Suche:
HG
W

last remote method : https://api.cybertaxonomy.org:443/caryophyllales_spp/remoting/term.service
last remote request client time : 2022-12-05T08:37:08.392
last remote request response header time : Mon, 05 Dec 2022 14:35:28 GMT
client error time : 2022-12-05T08:37:09.663
login : w.berendsohn
editor version : 5.34.0
server : api.cybertaxonomy.org (cybertaxonomy.org) / caryophyllales_spp
schema version : 5.33.0.0.20220807
os : Windows 10 10.0 amd64
java : 1.8.0_333
net.sf.ehcache.CacheException: java.io.OptionalDataException
            at net.sf.ehcache.store.disk.DiskStorageFactory.retrieve(DiskStorageFactory.java:866)
            at net.sf.ehcache.store.disk.Segment.decode(Segment.java:171)
            at net.sf.ehcache.store.disk.Segment.evict(Segment.java:859)
            at net.sf.ehcache.store.disk.Segment.evict(Segment.java:831)
            at net.sf.ehcache.store.disk.Segment.flush(Segment.java:1035)
            at net.sf.ehcache.store.disk.DiskStore.flush(DiskStore.java:248)
            at net.sf.ehcache.store.CacheStore$1.evicted(CacheStore.java:99)
            at net.sf.ehcache.store.CacheStore$1.evicted(CacheStore.java:96)
            at net.sf.ehcache.store.cachingtier.OnHeapCachingTier$1.evicted(OnHeapCachingTier.java:87)
            at net.sf.ehcache.store.cachingtier.CountBasedBackEnd$1.removed(CountBasedBackEnd.java:103)
            at net.sf.ehcache.util.concurrent.ConcurrentHashMap.internalReplace(ConcurrentHashMap.java:1346)
            at net.sf.ehcache.util.concurrent.ConcurrentHashMap.removeAndNotify(ConcurrentHashMap.java:2647)
            at net.sf.ehcache.store.cachingtier.CountBasedBackEnd.remove(CountBasedBackEnd.java:115)
            at net.sf.ehcache.store.cachingtier.OnHeapCachingTier.remove(OnHeapCachingTier.java:207)
            at net.sf.ehcache.store.CacheStore.remove(CacheStore.java:238)
            at net.sf.ehcache.Cache.removeInternal(Cache.java:2420)
            at net.sf.ehcache.Cache.tryRemoveImmediately(Cache.java:2183)
            at net.sf.ehcache.Cache.get(Cache.java:1754)
            at net.sf.ehcache.Cache.get(Cache.java:1722)
            at eu.etaxonomy.cdm.api.cache.CdmCacherBase.getCacheElement(CdmCacherBase.java:114)
            at eu.etaxonomy.cdm.api.cache.CdmCacherBase.load(CdmCacherBase.java:127)
            at eu.etaxonomy.cdm.model.term.DefinedTermBase.getTermByClassAndUUID_aroundBody20(DefinedTermBase.java:536)
            at eu.etaxonomy.cdm.model.term.DefinedTermBase.getTermByClassAndUUID(DefinedTermBase.java:1)
            at eu.etaxonomy.cdm.model.name.NameRelationshipType.findTermByUuid(NameRelationshipType.java:129)
            at eu.etaxonomy.cdm.model.name.NameRelationshipType.REPLACED_SYNONYM_aroundBody22(NameRelationshipType.java:482)
            at eu.etaxonomy.cdm.model.name.NameRelationshipType.REPLACED_SYNONYM(NameRelationshipType.java:1)
            at eu.etaxonomy.cdm.model.name.TaxonName.getReplacedSynonyms(TaxonName.java:2097)
            at eu.etaxonomy.cdm.compare.taxon.HomotypicGroupTaxonComparator.getReplacedSynonymClosure(HomotypicGroupTaxonComparator.java:223)
            at eu.etaxonomy.cdm.compare.taxon.HomotypicGroupTaxonComparator.compareBasionyms(HomotypicGroupTaxonComparator.java:198)
            at eu.etaxonomy.cdm.compare.taxon.HomotypicGroupTaxonComparator.compareNames(HomotypicGroupTaxonComparator.java:139)
            at eu.etaxonomy.cdm.compare.taxon.HomotypicGroupTaxonComparator.compare(HomotypicGroupTaxonComparator.java:84)
            at eu.etaxonomy.cdm.compare.taxon.TaxonComparator.compare(TaxonComparator.java:1)
            at java.util.TimSort.countRunAndMakeAscending(Unknown Source)
            at java.util.TimSort.sort(Unknown Source)
            at java.util.Arrays.sort(Unknown Source)
            at java.util.ArrayList.sort(Unknown Source)
            at java.util.Collections.sort(Unknown Source)
            at eu.etaxonomy.cdm.model.taxon.Taxon.getSynonymsInGroup(Taxon.java:1764)
            at eu.etaxonomy.cdm.model.taxon.Taxon.getSynonymsInGroup(Taxon.java:1741)
            at eu.etaxonomy.cdm.model.taxon.Taxon.getHeterotypicSynonymyGroups(Taxon.java:1704)
            at eu.etaxonomy.taxeditor.editor.name.e4.container.ContainerFactoryE4.createOrUpdateHeterotypicSynonymyGroups(ContainerFactoryE4.java:47)
            at eu.etaxonomy.taxeditor.editor.name.e4.TaxonNameEditorE4.createOrUpdateNameComposites(TaxonNameEditorE4.java:225)
            at eu.etaxonomy.taxeditor.editor.name.e4.TaxonNameEditorE4.init(TaxonNameEditorE4.java:445)
            at eu.etaxonomy.taxeditor.editor.EditorUtil.openNameEditor_internal(EditorUtil.java:262)
            at eu.etaxonomy.taxeditor.editor.EditorUtil.openTaxonBaseE4(EditorUtil.java:191)
            at eu.etaxonomy.taxeditor.navigation.NavigationUtil.openEditor(NavigationUtil.java:111)
            at eu.etaxonomy.taxeditor.navigation.NavigationUtil.openEditor(NavigationUtil.java:86)
            at eu.etaxonomy.taxeditor.navigation.search.e4.SearchResultViewE4$1.doubleClick(SearchResultViewE4.java:153)
            at org.eclipse.jface.viewers.StructuredViewer$1.run(StructuredViewer.java:833)
            at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
            at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:50)
            at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:173)
            at org.eclipse.jface.viewers.StructuredViewer.fireDoubleClick(StructuredViewer.java:830)
            at org.eclipse.jface.viewers.StructuredViewer.handleDoubleSelect(StructuredViewer.java:1151)
            at org.eclipse.jface.viewers.StructuredViewer$4.widgetDefaultSelected(StructuredViewer.java:1264)
            at org.eclipse.jface.util.OpenStrategy.fireDefaultSelectionEvent(OpenStrategy.java:252)
            at org.eclipse.jface.util.OpenStrategy.access$0(OpenStrategy.java:249)
            at org.eclipse.jface.util.OpenStrategy$1.handleEvent(OpenStrategy.java:311)
            at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
            at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
            at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
            at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
            at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
            at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
            at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
            at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
            at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
            at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
            at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
            at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
            at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
            at eu.etaxonomy.taxeditor.Application.start(Application.java:20)
            at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
            at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
            at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.io.OptionalDataException
            at java.io.ObjectInputStream.readObject0(Unknown Source)
            at java.io.ObjectInputStream.readObject(Unknown Source)
            at java.io.ObjectInputStream.readObject(Unknown Source)
            at java.util.HashSet.readObject(Unknown Source)
            at sun.reflect.GeneratedMethodAccessor44.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            at java.io.ObjectStreamClass.invokeReadObject(Unknown Source)
            at java.io.ObjectInputStream.readSerialData(Unknown Source)
            at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
            at java.io.ObjectInputStream.readObject0(Unknown Source)
            at java.io.ObjectInputStream.defaultReadFields(Unknown Source)
            at java.io.ObjectInputStream.readSerialData(Unknown Source)
            at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
            at java.io.ObjectInputStream.readObject0(Unknown Source)
            at java.io.ObjectInputStream.defaultReadFields(Unknown Source)
            at java.io.ObjectInputStream.defaultReadObject(Unknown Source)
            at net.sf.ehcache.Element.readObject(Element.java:885)
            at sun.reflect.GeneratedMethodAccessor81.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            at java.io.ObjectStreamClass.invokeReadObject(Unknown Source)
            at java.io.ObjectInputStream.readSerialData(Unknown Source)
            at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
            at java.io.ObjectInputStream.readObject0(Unknown Source)
            at java.io.ObjectInputStream.readObject(Unknown Source)
            at java.io.ObjectInputStream.readObject(Unknown Source)
            at net.sf.ehcache.store.disk.DiskStorageFactory.read(DiskStorageFactory.java:371)
            at net.sf.ehcache.store.disk.DiskStorageFactory.retrieve(DiskStorageFactory.java:864)
            ... 83 more
Actions #16

Updated by Andreas Müller 10 months ago

  • Target version changed from Release 5.25 to Release 5.35
  • % Done changed from 100 to 80
Actions #17

Updated by Andreas Müller 10 months ago

  • Assignee changed from Andreas Müller to Katja Luther
Actions #18

Updated by Andreas Müller 9 months ago

  • Target version changed from Release 5.35 to Release 5.42
Actions

Also available in: Atom PDF