Project

General

Profile

Actions

feature request #9541

closed

Improve referencing objects handling

Added by Andreas Müller over 1 year ago. Updated 5 months ago.

Status:
Closed
Priority:
New
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal

Description

  • DescriptionElementSource, SecundumSource and NomenclaturalStatus do now have a backlink to their referencing main object. Better labels and "open in" can be created for them, so.
  • performance should be improved, currently sorting is done on "description" therefore each label needs to be created during sort, which is at least 1 lazy-initialization call per record if initialization is needed
  • setting module parameters like "referencingObjectsList" is not done synchronized and within 1 command line with a server call. This may result in incorrect data if >1 job is running
  • the total number of records found should be shown
  • each job should be cancelable as often as possible so the jobs should be done in small parts, this is important for human triggered cancel as well as cancel due to focus change
  • tbc

Related issues

Related to EDIT - task #9999: Improve formatting for referencing objects of descriptive dataClosedAndreas Müller03/24/202203/29/2022

Actions
Related to EDIT - bug #9988: Fix selection for supplemental data view/referencing objects viewNewKatja Luther

Actions
Related to EDIT - bug #9656: Closing the referencing objects view should cancel the current requestNewAndreas Müller

Actions
Related to EDIT - feature request #8305: show number of references in referencing objects viewNewKatja Luther

Actions
Related to EDIT - bug #8261: Referencing objects view is missing focus after openingNewKatja Luther

Actions
Related to EDIT - bug #8126: Mediarepresentations should not be shown in Referencing objects viewNewAndreas Müller

Actions
Related to EDIT - feature request #6697: reconstruct getReferencingObjects to return DTOsNewKatja Luther

Actions
Related to EDIT - bug #6476: Remove MediaRepresentation and MediaRepresentationPart from Referencing objects viewNewAndreas Müller

Actions
Related to EDIT - feature request #6460: Refactor referencing objects in a way that supplemental data know what object they belong toResolvedAndreas Müller

Actions
Related to EDIT - feature request #2584: Show loading information for "Referencing Objects"WorksformeAndreas Müller

Actions
Related to EDIT - bug #10051: Remaining issues for Referencing Objects ViewNewAndreas Müller

Actions
Actions #1

Updated by Andreas Müller over 1 year ago

  • Subject changed from Improve labels for referencing objects to Improve referencing objects handling
Actions #2

Updated by Andreas Müller over 1 year ago

  • Description updated (diff)
  • % Done changed from 0 to 20
Actions #3

Updated by Andreas Müller over 1 year ago

  • Status changed from New to Resolved
Actions #4

Updated by Andreas Müller over 1 year ago

  • Description updated (diff)

What I did:

  • moved all referencing objects formatting to cdmlib (ReferencingObjectFormatter) to allow server side formatting and to have formatting at one place (model.format), this is a bit critical because referencing objects formatting is somehow context depending
  • refactored the ReferencingObjectsViewE4 to
    • first load objects without description and without link to target entity
    • load descriptions and target entity in bulk
    • correct handling of synchronized variables (using synchronized and volatile)
    • use only 1 variable (actualUuid) to check if the focus is on a new entity, this variable is synchronized
    • implement "cancel" during bulk load of descriptions and and target entity
  • refactor "open in" framework to be more generic for the different types of entities having the focus (model instances, DTOs, others, ...)
  • allow self referening "Open in ... referencing objects view" to traverse the object graph
  • some more that I forgot
Actions #5

Updated by Andreas Müller over 1 year ago

open issues might be:

  • improved formatting for all CdmBase classes (some formatting also seems to have regression, e.g. Distributions)
  • self-referencing "open in" should not work on target but on base entity to really traverse the graph and not jump to the target instance (e.g. jump from DescriptionElementSource reference to the source and not immediately to the taxon itself)
  • improve handling of view label and count
  • formatting and target object computation without initializing model objects
  • filter out instances which are part of the base object, e.g. do not show nomenclatural source of a TaxonName (but show if nomenclatural source is only using the name as original spelling)
  • ...
Actions #6

Updated by Andreas Müller over 1 year ago

  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 20 to 50

Can you please review?

Open issues should be moved to new ticket.

Actions #7

Updated by Andreas Müller 6 months ago

  • Related to task #9999: Improve formatting for referencing objects of descriptive data added
Actions #8

Updated by Andreas Müller 6 months ago

  • Related to bug #9988: Fix selection for supplemental data view/referencing objects view added
Actions #9

Updated by Andreas Müller 6 months ago

  • Related to bug #9656: Closing the referencing objects view should cancel the current request added
Actions #10

Updated by Andreas Müller 6 months ago

Actions #11

Updated by Andreas Müller 6 months ago

  • Related to bug #8261: Referencing objects view is missing focus after opening added
Actions #12

Updated by Andreas Müller 6 months ago

  • Related to bug #8126: Mediarepresentations should not be shown in Referencing objects view added
Actions #13

Updated by Andreas Müller 6 months ago

Actions #14

Updated by Andreas Müller 6 months ago

  • Related to bug #6476: Remove MediaRepresentation and MediaRepresentationPart from Referencing objects view added
Actions #15

Updated by Andreas Müller 6 months ago

  • Related to feature request #6460: Refactor referencing objects in a way that supplemental data know what object they belong to added
Actions #17

Updated by Andreas Müller 6 months ago

Actions #19

Updated by Katja Luther 5 months ago

  • Related to bug #10051: Remaining issues for Referencing Objects View added
Actions #20

Updated by Katja Luther 5 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Katja Luther to Andreas Müller

Works fine and open issues are moved to a new ticket.

Actions #21

Updated by Andreas Müller 5 months ago

  • % Done changed from 50 to 100
Actions

Also available in: Atom PDF