Project

General

Profile

feature request #9521

Fallback areas in textual representation should always stand alone

Added by Andreas Müller 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
Start date:
03/06/2021
Due date:
% Done:

100%

Severity:
normal
Tags:

Related issues

Related to Edit - bug #8297: Fix condensed distribution string for E+M Closed 05/23/2019
Related to Edit - bug #7107: "Omit level" (TDWG Level2) in distribution hierarchy should not supress distributions source reference New 12/04/2017
Related to Edit - feature request #9502: Implement subarea preference rule and fallback areas for areas with complex hierarchy New 03/02/2021
Related to Edit - feature request #9503: Handle term tree of areas and distribution status for distributionInfo in dataportal New 03/02/2021

Associated revisions

Revision a04aa53a (diff)
Added by Andreas Müller 4 months ago

ref #9521 fallback areas should not appear in textual hierarchy anymore

Revision c160c389 (diff)
Added by Andreas Müller 4 months ago

ref #9521 fallback areas should not appear in textual hierarchy anymore (cont.)

Revision 6e509e8f (diff)
Added by Andreas Müller 4 months ago

ref #9521 handle exception in controller

Revision 71abfebc (diff)
Added by Andreas Müller 4 months ago

ref #9521 handle exception in controller (cont.)

Revision ad034f89 (diff)
Added by Andreas Müller 4 months ago

ref #9521 fix CCE caused by proxy object

Revision 1eba812b (diff)
Added by Andreas Müller 4 months ago

ref #9521 handle fallbackarea computation recursively

Revision 1d41d2cc (diff)
Added by Andreas Müller 4 months ago

ref #9521 handle fallbackarea computation recursively (cont.)

Revision c729e881 (diff)
Added by Andreas Müller 3 months ago

ref #8297, ref #9521 test for recursive fallback area recognition in filterDistributions

History

#1 Updated by Andreas Müller 4 months ago

  • Status changed from New to Resolved
  • Priority changed from New to Highest

Not yet implemented: show fallback areas only if they have sources (currently they are shown if there is an explicit record, which is not filtered by "undefined")

#2 Updated by Andreas Müller 4 months ago

  • Related to bug #8297: Fix condensed distribution string for E+M added

#3 Updated by Andreas Müller 4 months ago

  • Related to bug #7107: "Omit level" (TDWG Level2) in distribution hierarchy should not supress distributions source reference added

#4 Updated by Andreas Müller 4 months ago

  • Related to feature request #9502: Implement subarea preference rule and fallback areas for areas with complex hierarchy added

#5 Updated by Andreas Müller 4 months ago

  • Related to feature request #9503: Handle term tree of areas and distribution status for distributionInfo in dataportal added

#7 Updated by Andreas Müller 3 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

I close this we can reopen if something does not work.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)