Project

General

Profile

Actions

bug #9520

closed

Taxonnode parent merge cascade leads to non-transactional behavior

Added by Andreas Müller over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Highest
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
critical
Found in Version:

Description

If a taxon node is changed and saved the update result also contains its parent and also grandparents up to the classification. This can be seen in the session view of the TaxEditor When saving again all these objects are also merged.

This is not only a performance issue for deeper classifications but it also leads to a situation that if the parent was edited and saved in the meanwhile this editing gets lost because the parent state of the child is saved afterwards.

This behavior can be reproduced by:

  • Open parent and child
  • Change child (e.g. publish flag) and save
  • Change parent (e.g. publish flag) and save
  • Change child again and save

Reopen parent => it has the state from before the change

This is critical.

====

NOTE: Before closing: think about removing SaveOrUpdateEntityListener. It is currently not used anymore.

Actions #1

Updated by Andreas Müller over 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Müller to Katja Luther
  • Priority changed from New to Highest
  • % Done changed from 0 to 50

This needs intensive reviewing as I removed cascading taxon node to parent.

I tested already that the problem itself is solved. I tested the steps from the description and now the new state remains after the child was saved.

Actions #2

Updated by Andreas Müller over 1 year ago

  • Description updated (diff)
Actions #3

Updated by Katja Luther over 1 year ago

  • Status changed from Resolved to Closed
  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 50 to 100

Seems to work as expected.

Actions

Also available in: Atom PDF