Project

General

Profile

bug #9506

Rights can not be selected for reuse

Added by Andreas Müller 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
03/02/2021
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

The selection dialog for rights does not show any existing data even if "*" is entered.

This happened in the cyprus production database.

picture999-1.png View (202 KB) Andreas Müller, 03/02/2021 10:35 PM

picture205-1.png View (993 Bytes) Andreas Müller, 03/04/2021 10:09 AM

picture346-1.png View (3.31 KB) Andreas Müller, 03/04/2021 02:20 PM


Related issues

Related to Edit - bug #7091: Add uri field and abbreviatedText to Righs in supplemental data Closed 11/24/2017
Duplicated by Edit - bug #6688: Rights do not show up in rights search if no text is given Duplicate 06/03/2017

Associated revisions

Revision 90f0f337 (diff)
Added by Katja Luther 5 months ago

fix #9506: the rights were filtered by text, this fixed now

Revision 14c8d1f0 (diff)
Added by Katja Luther 5 months ago

ref 9506: do not show empty rights in rights selection dialog

Revision 9f92498d (diff)
Added by Katja Luther 5 months ago

ref 9506: show uri and abbrev text when available

History

#1 Updated by Andreas Müller 5 months ago

The problem is probably that for copyrights usually only an agent and the rights type is given, but no text.
So the dialog field should include not only the text but maybe something like

{agent.titleCache} - {text} - {type.titleCache}

But the problem of course is that Rights has no titleCache as it is only AnnotatableEntity. So the question is how the search can work. Maybe a first solution could be to search separately on text, on agents used in rights and on rights type.
Later we may think about more sophisticated solutions.

#2 Updated by Katja Luther 5 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#3 Updated by Katja Luther 5 months ago

now the search is on text and agent.titlecache and the label contains {text} - {agent.titleCache} - {type.titleCache}

#4 Updated by Andreas Müller 5 months ago

is this already for review?

#5 Updated by Katja Luther 5 months ago

  • Assignee changed from Katja Luther to Andreas Müller

#6 Updated by Andreas Müller 5 months ago

  • Duplicated by bug #6688: Rights do not show up in rights search if no text is given added

#7 Updated by Andreas Müller 5 months ago

  • Related to bug #7091: Add uri field and abbreviatedText to Righs in supplemental data added

#8 Updated by Andreas Müller 5 months ago

  • File picture205-1.png View added
  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Empty values are not handled correctly:

I think empty or null values should not show up in the list at all.

#9 Updated by Andreas Müller 5 months ago

We should also include abbrev and uri if data is not empty (see #7091)

#10 Updated by Andreas Müller 5 months ago

Finally we could add a filter to search only on certain rights types. But this might be another ticket.

#11 Updated by Katja Luther 5 months ago

  • Status changed from Feedback to In Progress

Andreas Müller wrote:

Empty values are not handled correctly:

I think empty or null values should not show up in the list at all.

this is fixed.

#12 Updated by Katja Luther 5 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

Andreas Müller wrote:

We should also include abbrev and uri if data is not empty (see #7091)

this is fixed.

#13 Updated by Andreas Müller 5 months ago

Katja Luther wrote:

Andreas Müller wrote:

Empty values are not handled correctly:

I think empty or null values should not show up in the list at all.

this is fixed.

This still looks like before:

Any empty text should not show up (including the dash), any null value should not show up at all (also not as "null")

#14 Updated by Andreas Müller 5 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

Katja Luther wrote:

Andreas Müller wrote:

We should also include abbrev and uri if data is not empty (see #7091)

this is fixed.

It doesn't seem to be part of the search, maybe this was a misunderstanding. In #7091 it is required that these attributes are editable. Her in #9506 they should also be searchable, in the same way as the other parts, separated by dash, but only showing up in the label, if data exists.

#15 Updated by Andreas Müller 5 months ago

  • Status changed from Feedback to Closed
  • Priority changed from New to Highest
  • % Done changed from 50 to 100

This works now. Maybe the server was not restarted when I checked last time.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)