Project

General

Profile

bug #9475

NameTypeDesignations for existing names in other nom acts can not be created

Added by Andreas Kohlbecker about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
02/24/2021
Due date:
% Done:

100%

Severity:
normal
Found in Version:
Tags:

Description

this is a regression caused by the changes made for #9324

To reproduce

  • in registration workingset editor: "existing name" (name must not have registration nom act as nom ref)
  • save/confirm name
  • add new name type designation
  • save
  • ===> the registration is lost, since the designation reference was not added

picture397-1.png View (63.3 KB) Andreas Kohlbecker, 03/01/2021 04:06 PM


Related issues

Copied to Edit - bug #9476: SpecimenTypeDesignations for existing names in other nom acts can not be created Closed 02/24/2021

Associated revisions

Revision bd6037c5 (diff)
Added by Andreas Kohlbecker about 2 months ago

ref #9475 fixing problems caused by implementation for #9324 - changing NameTypeDesignationWorkingsetIds strategy again

Revision 245b2535 (diff)
Added by Andreas Kohlbecker about 2 months ago

ref #9475 fixing problems caused by implementation for #9324 - changing NameTypeDesignationWorkingsetIds strategy again - cdmlib part

Revision 3776382f (diff)
Added by Andreas Kohlbecker about 2 months ago

ref #9475 fixing NameTypeDesignations for existing names in other nom acts can not be created

History

#1 Updated by Andreas Kohlbecker about 2 months ago

  • Subject changed from NameTypeDesignations for names in other nom acts can not be created to NameTypeDesignations for existing names in other nom acts can not be created
  • Description updated (diff)
  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Andreas Kohlbecker about 2 months ago

  • Copied to bug #9476: SpecimenTypeDesignations for existing names in other nom acts can not be created added

#3 Updated by Andreas Kohlbecker about 2 months ago

  • Priority changed from New to Highest

#4 Updated by Andreas Kohlbecker about 2 months ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

please review

#5 Updated by Wolf-Henning Kusber about 2 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker

existing genus name selected, fine.
Name type designation editor opened, fine.
Type selected, fine.
Species name selected, fine.
Save -> Name Type designation is not saved! (Two times).

For selection of the typifying authors or section authors there is no field available. Was that planned?

#6 Updated by Andreas Kohlbecker about 1 month ago

I cant see any problem.

Here you can see me choosing the section (non sense data) of the typifying authors:

The typifcation is saved afterwards.

I would need some more details to reproduce this problem if it still persists.

#7 Updated by Wolf-Henning Kusber about 1 month ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 100

The name type section works for new genera names as well as for expisting names as expected.
The recorded error was may be a follow-up error of a different issue. The ticket can be closed.

#8 Updated by Andreas Kohlbecker about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)