Project

General

Profile

Actions

bug #9441

closed

Move names with invalid designation name relationships to the end in taxon comparator

Added by Andreas Müller almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
New
Category:
cdmlib
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Severity:
normal
Found in Version:

Description

copied from #5794 and #9272

Names with relationship

  • is later isonym of
  • is later citation of

are not yet moved to the end in the taxon comparator.

Also the ordering within invalid designation status

  • nom. prov.
  • nom./comb. inval bzw. op. utique oppr.
  • nom. nud.

as described in #5794#note-23 should be removed/replaced by pure date ordering

Check result in TaxEditor and Dataportal.


Related issues

Related to EDIT - feature request #9282: Add nomenclatural standingClosedAndreas Müller

Actions
Related to EDIT - bug #9440: Invalid designation sign missing for some invalid designations in data portalNewAndreas Kohlbecker

Actions
Is duplicate of EDIT - bug #9566: Handle nomenclatural standing correctly in cdmlight / sorting algorithmsClosedAndreas Müller

Actions
Copied from EDIT - feature request #5794: Move other invalid names to the endClosedAndreas Müller

Actions
Copied to EDIT - feature request #9272: Add missing nomenclatural statusClosedAndreas Müller

Actions
Actions #1

Updated by Andreas Müller almost 2 years ago

  • Tags set to fast
  • Category set to cdmlib
  • Assignee set to Andreas Müller
  • Target version changed from Unassigned CDM tickets to Release 5.21
Actions #2

Updated by Andreas Müller almost 2 years ago

Actions #3

Updated by Andreas Müller almost 2 years ago

Actions #4

Updated by Andreas Müller almost 2 years ago

  • Description updated (diff)
Actions #5

Updated by Andreas Müller almost 2 years ago

Actions #6

Updated by Andreas Müller almost 2 years ago

  • Related to bug #9440: Invalid designation sign missing for some invalid designations in data portal added
Actions #7

Updated by Andreas Müller over 1 year ago

  • Target version changed from Release 5.21 to Release 5.22
Actions #8

Updated by Andreas Müller over 1 year ago

  • Is duplicate of bug #9566: Handle nomenclatural standing correctly in cdmlight / sorting algorithms added
Actions #9

Updated by Katja Luther over 1 year ago

  • Status changed from New to Closed

this works now as expected, also for the homotypic groups in editor.

Actions #10

Updated by Andreas Müller over 1 year ago

  • Tags deleted (fast)
Actions

Also available in: Atom PDF