Project

General

Profile

Actions

task #9359

closed

Update cdmlib, taxeditor, cdmserver etc. dependencies

Added by Andreas Müller about 2 years ago. Updated 29 days ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal

Description

A lot of version updates and updates to how dependencies are handled in TaxEditor has been done already in #9204.

However, further cleanup and update is needed.

mvn versions:display-dependency-updates
mvn dependency:tree   (better use "Dependency Hierarchy" view in eclipse)
mvn dependency:tree -Dscope=compile
mvn org.apache.maven.plugins:maven-dependency-plugin:2.10:tree -Dverbose=true  (verbose flag has been removed in 3.0 (https://maven.apache.org/plugins/maven-dependency-plugin/examples/resolving-conflicts-using-the-dependency-tree.html)
mvn dependency:analyze
mvn versions:display-plugin-updates   (upgrade required maven version from time to time!)
* also try https://github.com/basepom/duplicate-finder-maven-plugin
* for checking newer versions: https://javalibs.com/artifact/xpp3/xpp3 (more info then in maven repo) 

also all other maven projects (CDM Server, cdm-vaadin (#9955, #9837), webapp, utis(2/3x) need dependency updates

TODO:

  • spring
  • lucene (#10067)
  • others
  • remove cdmlib-persistence from taxeditor dependencies (also removes hibernate dependencies) (#9208, #10009, ...)
  • upgrade to hibernate >5.1 (#10067)
  • hibernate-validation ( also move to new artefact org.hibernate.validator )
  • remove apache-log4j-extras from taxeditor #9205
  • update maven-compiler-plugin to 3.x in cdmlib #6407/#9919
  • update maven-resources-plugin to 3.2.0 in cdmlib-remote (see comment in pom)
  • jgitflow (#9946)
  • Vaadin needs to be migrated: free support for V8 is over (https://vaadin.com/blog/free-vaadin-8-support-is-over.-what-happens-next)
  • updated jboss-logging to 3.5.0.Final once we use java11
  • check new group-id com.opencsv for OpenCSV

===

Open issues from older tickets:

#3403: Update remaining libraries:

#3344: Migrate to hibernate 4

  • check if exclusion in parent.pom for hibernate-search-engine is still needed => has been removed in the meanwhile
  • check all applicationContexts.xml (xxx-test.xml) for redundant data
  • check preliminary hardcoded type in CdmEntityDaoBase.addOrder
    • AK: Ich denke das können wir vorerst mal so lassen, da ohnehin fast alles als String indiziert ist. Mit dem neuen hibernate search könnte da nun anders sein. Das würde dann eventuell id und date betreffen. Diese Freetext Methoden auf dao ebene werden bisher ohnehin nicht verwendet insofern besteht eh keine gefahr.
  • remove deprecated new FlatXmlDataSet by DataSetBuilder -> not sure what is meant here, maybe fixed already, I can't find a deprecated FlatXmlDataSet
  • uncomment _c3p0ConnectionTest in src/test/resource/cp30-config.xml and remove this file in test (still exists in main)
  • check all errors when running in commandline (e.g. all locks on index updating and others) - index locking problem solved r17458
  • check @Ignore necessary for all tests (especially in service layer)

#2031 Update Hibernate to latest stable 4.1.1:

  • All open issues in ticket, kept open for now, including OrderedColumn ticket (see #3722) => ticket closed in the meanwhile

#4716 Other dependencies to be updated

  • remove and solve ignore from DescriptionServiceImplTest.testMoveDescriptionElementsToTaxon => see comment #4716#note-6
  • AK: fix hibernate search related issues
    • 8096b11 : IndexDocValue relates issues solved, indexing now without exceptions, most tests in TaxonServiceSearchTest successful
    • remove Index annotations from abstract classes, hibernate search seems not capable of indexing polymorph classes. This will remove the @HSEARCH000044 warings.
  • AK: use the encrypto Passwordencoder in UserService instead of the deprecated one

  • move remoting-services.xml and httpInvokerServices.xml to remoting

  • try to remove exclusions where possible

  • check if the postcommit handler were set correctly in CdmPostDataChangeObservableListener and ValidationEventListenerBase

  • fix EntityValidationCrudJdbcImplTest and remove ignore

  • move TableGeneratorGlobalOverride back to cdmlib-test (see r27338)

  • remove dependsOn=tableGeneratorGlobalOverride from sessionFactory in persistence.xml and security_base.xml in production mode. It should be used only for test.

  • find a solution for dbunitModul to load datasets also from jars and other packages to avoid duplication of standard dataset files (TODO create ticket with detailed information)

TODO

  • aspectj-main anttask in model-pom still uses org.springframework.aspects and not sring-aspects (?) and aspectjtools version 1.7.1 => moved to #4608 if still open

  • we may concider removing commons-dbcp.commons-dbcp by org.apache.commons.commons-dbcp2 (maybe only used by unitils-database)

  • AK: what is with json-lib, why does it have [classifier]jdk15[/classifier] and is the dependency net.sf.json-lib:json-lib:jar:jdk15:2.4 still required => see #9887

  • do we want to move xpp3.xpp3 (1.1.4c) to org.ogce.xpp3 (1.1.6) ?

  • do we want to move xom.xom (1.2.5) to com.io7m.xom.xom (1.2.10) ? Already upgraded from 1.0 to 1.2.5

  • do we still need hibernate-parent (last version was 3.6.)? => can't find this anymore, probably removed some time ago

  • decide which oracle driver to use

  • check if usertype.jodatime has been replaced by usertype.core => yes, and changed in pom with b82005b408a86 (#10067)

  • check how to upgrade to jena-tdb 3.0.0 (also check if commonsRDF is an alternative: https://commonsrdf.incubator.apache.org/ ) => new ticket #10125

  • resolve those spring configuration files which still do have a spring-beans-3.0.xsd schema location => all changed to spring-beans-4.3.xsd some time ago

  • remove apache snapshot repository (for jena) and others => removed JBoss and apache incubating repos, maybe still open "OSGeo Repository" (#10055)

  • check if we can upgrade hibernate tooling with dependencies to hibernate 3.2.4 in persistence pom (tooling 5 is not yet released) => seems to be fixed in the meanwhile

  • Check if SpringModule dependencies can be fully removed (it is only used in AbstractOaiPmhController for Caching, this could probably handled by other caching frameworks like EhCacheCache from spring-context-support) . #3408

  • we may want to further normalize spring config files: #5380

  • check if TaxonNodeByNameComparator is needed as spring bean as it is currently the case

  • Try to fix the HHH90000003 warnings (thrown in org.hibernate.boot.model.source.internal.hbm.ModelBinder line 2416, probably related to hibernate-envers, can be switched off by log4j.logger.org.hibernate.orm.deprecation=error) (related but not #7289)

  • fix open issues for cdmlib-db (#6025)

  • see if we can do more cross-project version management using toolchain plugin (https://maven.apache.org/plugins/maven-toolchains-plugin/index.html) or enforcer plugin or similar solutions. => see https://maven.apache.org/pom.html#Quick_Overview inheritance and aggregation section for all required base information on this. We may create a "cdm_base.pom" for all cdm wide inherited information and maybe another "edit_platform.pom" for all widely shared information (such as the EDIT platform repository and maybe some maven-plugin versioning). Cdmlib-parent will then primarily become an aggregation.pom


Related issues

Related to EDIT - task #4009: consider using jackson as json libraryNewAndreas Müller

Actions
Related to EDIT - task #3722: Using @OrderColumn does not work in treesClosedAndreas Müller05/23/202205/27/2022

Actions
Related to EDIT - bug #6025: Remaining open issues for cdmlib-dbNewAndreas Müller

Actions
Related to EDIT - bug #6407: Upgrade maven compiler plugin to latest versionNewAndreas Müller

Actions
Related to EDIT - task #9837: updadte vaadin to latets 7.* versionIn ProgressAndreas Müller

Actions
Related to EDIT - task #9887: remove jdk15 classifier from json-libRejectedAndreas Müller

Actions
Related to EDIT - task #9886: Create cdmlib modul cdmlib-apiIn ProgressAndreas Müller

Actions
Related to EDIT - task #9919: Upgrade maven-compiler-plugin to 3.x in cdmlibDuplicateAndreas Müller

Actions
Related to EDIT - task #9946: Update or remove jgitflowNewAndreas Müller

Actions
Related to EDIT - task #9955: Upgrade vaadin to latest versionNewAndreas Müller

Actions
Related to EDIT - task #10009: Cleanup dependencies in TaxEditorResolvedKatja Luther05/10/202205/13/2022

Actions
Related to EDIT - task #10055: Updates, upgrades and cleanup 2023NewAndreas Müller

Actions
Related to EDIT - task #10067: Update to hibernate 5.4 (or higher) and hibernate search 5.11 and lucene 5.5ClosedAndreas Müller05/23/202206/01/2022

Actions
Related to EDIT - task #10077: upgrade ehcache to 3.xNewAndreas Müller

Actions
Related to EDIT - bug #10079: Fix timezone problems after upgrading jadira.usertype, hibernate and/or mysql driversIn ProgressKatja Luther

Actions
Related to EDIT - task #10095: Synchronize dependency versions in CdmServerClosedAndreas Müller

Actions
Related to EDIT - bug #10141: Exception (CCE) caused by logging setLevel in phycobankClosedAndreas Müller

Actions
Copied from EDIT - feature request #9204: Update cdmlib and taxeditor dependenciesClosedAndreas Müller

Actions
Copied to EDIT - task #9205: Remove apache-log4j-extras from TaxEditor dependenciesClosedAndreas Müller

Actions
Copied to EDIT - feature request #9190: Make taxeditor.local a loadable plugin not installed by defaultIn ProgressKatja Luther

Actions
Copied to EDIT - feature request #9154: Further reduce TaxEditor size by cleaning up dependencies and making taxeditor.webapp plugin optionalNewKatja Luther

Actions
Copied to EDIT - feature request #9341: Move local datasource access fully to taxeditor.localNewAndreas Müller

Actions
Copied to EDIT - bug #9351: Include new locations for cdmlib-print and cdmlib-remote in jenkins release scriptClosedAndreas Kohlbecker

Actions
Copied from EDIT - feature request #4716: Other dependencies to be updatedClosedAndreas Müller

Actions
Copied to EDIT - task #10072: Upgrade fully to log4j2ClosedAndreas Müller

Actions
Copied to EDIT - task #10125: Upgrade jena dependencyNewKatja Luther

Actions
Actions #1

Updated by Andreas Müller about 2 years ago

  • Description updated (diff)
Actions #2

Updated by Andreas Müller about 2 years ago

Actions #3

Updated by Andreas Müller about 2 years ago

Actions #4

Updated by Andreas Müller about 2 years ago

  • Copied to task #9205: Remove apache-log4j-extras from TaxEditor dependencies added
Actions #5

Updated by Andreas Müller about 2 years ago

Actions #6

Updated by Andreas Müller about 2 years ago

  • Copied to feature request #9154: Further reduce TaxEditor size by cleaning up dependencies and making taxeditor.webapp plugin optional added
Actions #7

Updated by Andreas Müller about 2 years ago

Actions #8

Updated by Andreas Müller about 2 years ago

  • Copied to bug #9351: Include new locations for cdmlib-print and cdmlib-remote in jenkins release script added
Actions #9

Updated by Andreas Müller about 2 years ago

  • Target version changed from Release 5.19 to Release 5.21
Actions #11

Updated by Andreas Müller almost 2 years ago

  • Description updated (diff)
Actions #12

Updated by Andreas Müller almost 2 years ago

  • Related to task #4009: consider using jackson as json library added
Actions #13

Updated by Andreas Müller almost 2 years ago

  • Description updated (diff)
Actions #14

Updated by Andreas Müller almost 2 years ago

  • Description updated (diff)
Actions #16

Updated by Andreas Müller almost 2 years ago

  • Description updated (diff)
Actions #18

Updated by Andreas Müller almost 2 years ago

  • Description updated (diff)
Actions #19

Updated by Andreas Müller almost 2 years ago

  • Related to task #3722: Using @OrderColumn does not work in trees added
Actions #20

Updated by Andreas Müller almost 2 years ago

  • Description updated (diff)
Actions #21

Updated by Andreas Müller almost 2 years ago

  • Description updated (diff)
Actions #22

Updated by Andreas Müller almost 2 years ago

  • Description updated (diff)
Actions #23

Updated by Andreas Müller almost 2 years ago

Actions #24

Updated by Andreas Müller almost 2 years ago

Actions #25

Updated by Andreas Müller almost 2 years ago

  • Related to task #6714: Create 001-cdm.h2.sql automatically added
Actions #26

Updated by Andreas Müller almost 2 years ago

  • Related to deleted (task #6714: Create 001-cdm.h2.sql automatically)
Actions #27

Updated by Andreas Müller almost 2 years ago

  • Status changed from New to In Progress
  • Priority changed from New to Highest
  • % Done changed from 0 to 10
Actions #28

Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 5.21 to Release 5.22
Actions #29

Updated by Andreas Müller almost 2 years ago

  • Target version changed from Release 5.22 to Release 5.38
Actions #30

Updated by Andreas Müller over 1 year ago

  • Description updated (diff)
Actions #32

Updated by Andreas Müller over 1 year ago

  • Related to bug #6025: Remaining open issues for cdmlib-db added
Actions #33

Updated by Andreas Müller over 1 year ago

  • Description updated (diff)
Actions #34

Updated by Andreas Müller over 1 year ago

  • Related to bug #6407: Upgrade maven compiler plugin to latest version added
Actions #35

Updated by Andreas Müller over 1 year ago

  • Description updated (diff)
Actions #36

Updated by Andreas Müller about 1 year ago

  • Related to task #9837: updadte vaadin to latets 7.* version added
Actions #37

Updated by Andreas Müller about 1 year ago

  • Related to task #9887: remove jdk15 classifier from json-lib added
Actions #38

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #39

Updated by Andreas Müller about 1 year ago

  • Related to task #9886: Create cdmlib modul cdmlib-api added
Actions #40

Updated by Andreas Müller about 1 year ago

  • Subject changed from Update cdmlib and taxeditor dependencies to Update cdmlib, taxeditor, cdmserver etc. dependencies
  • Description updated (diff)
Actions #41

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #42

Updated by Andreas Müller about 1 year ago

  • Related to task #9919: Upgrade maven-compiler-plugin to 3.x in cdmlib added
Actions #43

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #44

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #45

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #46

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #47

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #48

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #49

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #50

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #51

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #52

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #53

Updated by Andreas Müller about 1 year ago

  • Description updated (diff)
Actions #54

Updated by Andreas Müller 12 months ago

  • Description updated (diff)
Actions #55

Updated by Andreas Müller 12 months ago

  • Related to task #9946: Update or remove jgitflow added
Actions #56

Updated by Andreas Müller 11 months ago

  • Related to task #9955: Upgrade vaadin to latest version added
Actions #57

Updated by Andreas Müller 11 months ago

  • Description updated (diff)
Actions #58

Updated by Andreas Müller 10 months ago

  • Related to task #10009: Cleanup dependencies in TaxEditor added
Actions #59

Updated by Andreas Müller 10 months ago

  • Description updated (diff)
Actions #60

Updated by Andreas Müller 9 months ago

  • Related to task #10055: Updates, upgrades and cleanup 2023 added
Actions #61

Updated by Andreas Müller 9 months ago

  • Related to task #10067: Update to hibernate 5.4 (or higher) and hibernate search 5.11 and lucene 5.5 added
Actions #62

Updated by Andreas Müller 9 months ago

  • Description updated (diff)
Actions #63

Updated by Andreas Müller 9 months ago

  • Description updated (diff)
Actions #64

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #65

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #66

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #67

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #68

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #69

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #70

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #71

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #72

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #73

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #74

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #75

Updated by Andreas Müller 8 months ago

  • Description updated (diff)
Actions #76

Updated by Andreas Müller 8 months ago

Actions #77

Updated by Andreas Müller 8 months ago

Actions #78

Updated by Andreas Müller 7 months ago

  • Related to bug #10079: Fix timezone problems after upgrading jadira.usertype, hibernate and/or mysql drivers added
Actions #79

Updated by Andreas Müller 7 months ago

  • Related to task #10095: Synchronize dependency versions in CdmServer added
Actions #80

Updated by Andreas Müller 7 months ago

  • Description updated (diff)
Actions #81

Updated by Andreas Müller 6 months ago

  • Description updated (diff)
Actions #82

Updated by Andreas Müller 6 months ago

  • Description updated (diff)
Actions #83

Updated by Andreas Müller 6 months ago

  • Description updated (diff)
Actions #84

Updated by Andreas Müller 6 months ago

  • Description updated (diff)
  • % Done changed from 10 to 20
Actions #85

Updated by Andreas Müller 5 months ago

Actions #86

Updated by Andreas Müller 5 months ago

  • Description updated (diff)
Actions #87

Updated by Andreas Müller 5 months ago

  • Related to bug #10141: Exception (CCE) caused by logging setLevel in phycobank added
Actions #88

Updated by Andreas Müller about 1 month ago

  • Description updated (diff)
Actions #89

Updated by Andreas Müller about 1 month ago

  • Description updated (diff)
Actions #90

Updated by Andreas Müller about 1 month ago

  • Description updated (diff)
Actions #91

Updated by Andreas Müller about 1 month ago

  • Description updated (diff)
Actions #92

Updated by Andreas Müller about 1 month ago

  • Description updated (diff)
Actions #93

Updated by Andreas Müller about 1 month ago

  • Description updated (diff)
Actions #94

Updated by Andreas Müller about 1 month ago

  • Status changed from In Progress to Closed
  • % Done changed from 20 to 100

All open issues moved to upgrade 2023 #10055

Actions #95

Updated by Andreas Müller 29 days ago

  • Description updated (diff)
Actions

Also available in: Atom PDF