Project

General

Profile

Actions

bug #9354

closed

Sorting in distribution editor is broken

Added by Katja Luther almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

90%

Estimated time:
Severity:
normal
Found in Version:

Description

The comparator for sorting the taxa in distribution editor does not work correctly.


Related issues

Related to EDIT - feature request #8889: Remaining issues for distribution editor - continueIn ProgressKatja Luther

Actions
Is duplicate of EDIT - feature request #8708: Sort taxa in distribution editor same as in navigatorDuplicateKatja Luther

Actions
Copied to EDIT - task #9416: Improve distribution editor sort methodsNewAndreas Müller

Actions
Actions #1

Updated by Katja Luther almost 2 years ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

fixed for hotfix 5.18.1

Actions #2

Updated by Andreas Müller almost 2 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 10

There are still open issues as the comparator does not follow the comparator contract and handling of names with rank1 != rank2 is not handled.

Generally the comparator should work the same way as the taxon navigator compartor. But this might be another ticket (does it exist already?)

Actions #3

Updated by Katja Luther almost 2 years ago

  • Target version changed from Release 5.18 to Release 5.19
Actions #4

Updated by Andreas Müller almost 2 years ago

  • Severity changed from normal to critical

I put this to critical as it is a requirement the E+M Bratislava team to edit disttribution data for CZ and SK which itself is a requirement for the outstanding E+M publication.

Actions #5

Updated by Katja Luther almost 2 years ago

Andreas Müller wrote:

There are still open issues as the comparator does not follow the comparator contract and handling of names with rank1 != rank2 is not handled.

Generally the comparator should work the same way as the taxon navigator compartor. But this might be another ticket (does it exist already?)

This is not as easy as it looks like because in navigator we have a tree structure and in the distribution editor we have a list. If we use the same comparator like in the navigator we have the same problem that the higher ranks come first.

Actions #6

Updated by Katja Luther almost 2 years ago

Actions #7

Updated by Katja Luther almost 2 years ago

  • Severity changed from critical to normal

Andreas Müller wrote:

Generally the comparator should work the same way as the taxon navigator compartor. But this might be another ticket (does it exist already?)

this is described in #8889

Actions #8

Updated by Katja Luther almost 2 years ago

  • Status changed from Feedback to Resolved

this is fixed now by sorting the list on server side. The sortMode is a method parameter.

Actions #9

Updated by Katja Luther almost 2 years ago

  • Assignee changed from Katja Luther to Andreas Müller

please review.

Actions #10

Updated by Andreas Müller almost 2 years ago

There is an NPE issue in TaxonNodeByRankAndNameComparator if name or rank does not exist in taxon. I fixed it.

Actions #11

Updated by Katja Luther almost 2 years ago

Andreas Müller wrote:

There is an NPE issue in TaxonNodeByRankAndNameComparator if name or rank does not exist in taxon. I fixed it.

Thanks!

Actions #12

Updated by Andreas Müller almost 2 years ago

  • % Done changed from 10 to 50

I unified the 2 TaxonNodeDao.listChildrenOf(...) methods as I don't think it is good to have recursion input parameters on a publicly available method.

Actions #13

Updated by Andreas Müller almost 2 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 90

Works as expected. We only could do some further improvements which I put in a new ticket #9416.

Please review my changes and close if ok.

Actions #14

Updated by Andreas Müller almost 2 years ago

  • Copied to task #9416: Improve distribution editor sort methods added
Actions #15

Updated by Katja Luther almost 2 years ago

  • Status changed from Feedback to Closed

The code looks fine. Close the ticket.

Actions #16

Updated by Katja Luther over 1 year ago

Actions

Also available in: Atom PDF