Project

General

Profile

feature request #9332

Rename TypeDesignationBase.source to .designationSource

Added by Andreas Müller about 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm
Target version:
Start date:
11/25/2020
Due date:
% Done:

100%

Severity:
normal

Description

as simple "source" creates confusion as there are also the general sources attached to TypeDesignationBase.


Related issues

Related to Edit - feature request #6581: Make all microreferenced references OriginalSources Closed 04/24/2017

Associated revisions

Revision 0a20a617 (diff)
Added by Katja Luther 12 months ago

ref #9332: further clean up in editor

Revision c5c25011 (diff)
Added by Andreas Kohlbecker 11 months ago

ref #9332 re-organizing source(es) in TypeDesignation init-strategy

Revision a3d00817 (diff)
Added by Andreas Müller 9 months ago

ref #9332 adapt vaadin code to designationSource

Revision 1ce8157a (diff)
Added by Andreas Müller 9 months ago

ref #9332 adapt some test data to new designationSource in vaadin

Revision a862b070 (diff)
Added by Andreas Müller 9 months ago

ref #9332 rename TypeDesignationBase.source to .designationSource in cdmlib

Revision ebe255f5 (diff)
Added by Andreas Müller 9 months ago

ref #9332 adapt registration dao to designationSource renaming

Revision 72cd6341 (diff)
Added by Andreas Müller 9 months ago

ref #9332 adapt some test data and a query to new designationSource in cdmlib

Revision 51dfa0e0 (diff)
Added by Andreas Müller 9 months ago

ref #9332 adapt xml mapping to new designationSource

Revision 66620566 (diff)
Added by Andreas Müller 9 months ago

ref #9332 adapt TypeDesignationBaseBeanProcessor to designationSource changes

Revision 8ea93946 (diff)
Added by Andreas Müller 9 months ago

ref #9332 adapt TaxEditor code to .designationSource

Revision dd6b7a1e (diff)
Added by Andreas Müller 9 months ago

ref #9332 adapt PhycobankHigherClassificationExcelImport to designationSource handling

Revision d7849510 (diff)
Added by Andreas Kohlbecker 8 months ago

ref #9332 adapting initstrategy

Revision 2f206257 (diff)
Added by Andreas Kohlbecker 8 months ago

ref #9332 adapting further init strategies

Revision 63367139 (diff)
Added by Andreas Kohlbecker 8 months ago

ref #9332 adapting DTO to property change source -> designationSource

Revision 2f5cf318 (diff)
Added by Andreas Kohlbecker 8 months ago

ref #9332 adapting portal to model type designation property change source -> designationSource

Revision 6c2110e6 (diff)
Added by Andreas Kohlbecker 8 months ago

ref #9332 adapting init strategy to renamed field source -> designationSource

History

#1 Updated by Andreas Müller about 1 year ago

  • Priority changed from New to Highest

#2 Updated by Andreas Müller 9 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

This is solved in cdmlib but we need to check if it works in TaxEditor and vaadin

#3 Updated by Andreas Müller 9 months ago

  • Status changed from Resolved to Closed
  • Target version changed from CDM UML 5.29 to Release 5.22
  • % Done changed from 50 to 100

#4 Updated by Andreas Müller 9 months ago

#5 Updated by Andreas Kohlbecker 8 months ago

  • Status changed from Closed to Resolved
  • % Done changed from 100 to 40

the renamed field is causing LIEs in cdm-vaadin, so this ticket is not fully solved.

e.g.

http://test.e-taxonomy.eu/cdmserver/phycobank/app/registration#!workingset/4e40184e-815c-4fd2-abe1-570040dde8ef

Caused by: org.hibernate.LazyInitializationException: failed to lazily initialize a collection of role: eu.etaxonomy.cdm.model.reference.OriginalSourceBase.annotations, could not initialize proxy - no Session
    at org.hibernate.collection.internal.AbstractPersistentCollection.throwLazyInitializationException(AbstractPersistentCollection.java:584)
    at org.hibernate.collection.internal.AbstractPersistentCollection.withTemporarySessionIfNeeded(AbstractPersistentCollection.java:201)
    at org.hibernate.collection.internal.AbstractPersistentCollection.readSize(AbstractPersistentCollection.java:145)
    at org.hibernate.collection.internal.PersistentSet.isEmpty(PersistentSet.java:149)
    at eu.etaxonomy.cdm.model.common.AnnotatableEntity.checkEmpty(AnnotatableEntity.java:180)
    at eu.etaxonomy.cdm.model.reference.OriginalSourceBase.checkEmpty(OriginalSourceBase.java:293)
    at eu.etaxonomy.cdm.model.reference.NamedSourceBase.checkEmpty(NamedSourceBase.java:88)
    at eu.etaxonomy.cdm.model.name.TypeDesignationBase.checkNullSource(TypeDesignationBase.java:302)
    at eu.etaxonomy.cdm.model.name.TypeDesignationBase.setCitation_aroundBody6(TypeDesignationBase.java:267)
    at eu.etaxonomy.cdm.model.name.TypeDesignationBase.setCitation_aroundBody7$advice(TypeDesignationBase.java:46)
    at eu.etaxonomy.cdm.model.name.TypeDesignationBase.setCitation(TypeDesignationBase.java:1)
    at eu.etaxonomy.cdm.vaadin.model.registration.SpecimenTypeDesignationDTO.setDesignationReference(SpecimenTypeDesignationDTO.java:222)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

Apparently all init-strategies for name and specimen type designations still need to be adaptet.

#6 Updated by Andreas Kohlbecker 8 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 40 to 100

should be fixed now

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)