Project

General

Profile

task #9308

Supress "designated by" reference in portal in registration ListView and RegistrationWorkingSetEditor

Added by Andreas Kohlbecker 11 months ago. Updated 4 days ago.

Status:
Closed
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
11/16/2020
Due date:
% Done:

100%

Severity:
normal
Tags:

Description

this task has been copied from #9302

see also #9306

Also fix the dangling plural s of "isotypes" which is not formatted in bold letters as the rest of the word.

picture165-1.png View (72.3 KB) Andreas Kohlbecker, 11/17/2020 03:55 PM

picture010-1.png View (48.9 KB) Andreas Kohlbecker, 11/18/2020 03:54 PM


Related issues

Related to Edit - task #9306: Registration result list: supress "designated by" reference in portal Closed 11/16/2020
Related to Edit - bug #9290: stop setting Registration.citation as citation for TypeDesignations in all type editors by default Closed 11/10/2020
Related to Edit - bug #9701: Order and display of different typifications for one name in one reference Closed 07/07/2021
Copied from Edit - bug #9302: Phycobank related issues for TypeDesignation formatting In Progress 11/14/2020

Associated revisions

Revision ddbbb621 (diff)
Added by Andreas Kohlbecker 11 months ago

ref #9308 slight improvement for type status in bold letters

Revision 57488685 (diff)
Added by Andreas Kohlbecker about 1 month ago

fix #9308 more structured formatting of type labels and removing "designated by ..."

History

#1 Updated by Andreas Kohlbecker 11 months ago

  • Status changed from Closed to New
  • % Done changed from 100 to 0

#2 Updated by Andreas Kohlbecker 11 months ago

  • Copied from bug #9302: Phycobank related issues for TypeDesignation formatting added

#3 Updated by Andreas Kohlbecker 11 months ago

  • Related to task #9306: Registration result list: supress "designated by" reference in portal added

#4 Updated by Andreas Kohlbecker 11 months ago

#5 Updated by Andreas Kohlbecker 11 months ago

Even if the plural "s" problem is fixed, there are also other problems with showing the type status in bold letters which can't easily bee solved.

It is be better to operate on a more structured string.

Another important point:

The redundant designated by may be caused by the problematic use of the TypeDesignation.citation property, see #9290

Solving this here should not be started before #9290 is done

#6 Updated by Andreas Kohlbecker 11 months ago

  • Related to bug #9290: stop setting Registration.citation as citation for TypeDesignations in all type editors by default added

#7 Updated by Andreas Kohlbecker 9 months ago

  • Target version changed from Release 5.19 to Release 5.21

#8 Updated by Andreas Müller 7 months ago

  • Target version changed from Release 5.21 to Release 5.22

#9 Updated by Andreas Kohlbecker 6 months ago

  • Target version changed from Release 5.22 to Release 5.25

#10 Updated by Andreas Müller 3 months ago

  • Target version changed from Release 5.25 to Release 5.28

#11 Updated by Andreas Kohlbecker about 1 month ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#12 Updated by Andreas Kohlbecker about 1 month ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

can be reviewed from 7.9.21 on

#13 Updated by Andreas Kohlbecker about 1 month ago

  • Related to bug #9701: Order and display of different typifications for one name in one reference added

#14 Updated by Andreas Müller 29 days ago

  • Target version changed from Release 5.28 to Release 5.27

#15 Updated by Wolf-Henning Kusber 5 days ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 50 to 100

Task is perfectly implemented, ticket can be closed.

#16 Updated by Andreas Müller 4 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)