Project

General

Profile

bug #9290

stop using the Registration.citation as citation for TypeDesignations in all type editors

Added by Andreas Kohlbecker 2 months ago. Updated 1 day ago.

Status:
Resolved
Priority:
Highest
Category:
cdm-vaadin
Target version:
Start date:
11/10/2020
Due date:
% Done:

50%

Severity:
normal
Found in Version:
Tags:

Description

As shown in the analysis ( TaxonName and Typedesignation citations unequal_diff.xlsx ) using the Registration.citation as citation for TypeDesignations currently causes inconsistencies.

In many cases the Name.nomenclaturalReference is a Section of an Article. Due to the mechanism currently implemented the TypeDesignations receive the Article instead, the article which is the in-reference of the section. This could be corrected for all the found inconsistent cases bout would impose a complex management in the UI to adjust the typeDesignation.citation in case the section reference in the name is being changed.

It is better to stop using the Registration.citation as citation for TypeDesignations in all type editors since this does not conform to the intended use of the TypeDesignations.citation property.

This also involves to hide the citation and ciation detail for all NameTypes which have NameTypeDesignationStatus.hasDesignationSource() == false

Update (2020-11-13):

There is a crucial misconception in the SpecimenTypeDesignationWorkingSetDTO:

The SpecimenTypeDesignationWorkingsetEditorPresenter.loadBeanById(Object identifier) receives in the identifier object the referenceId from the RegistrationWorkingsetPresenter.onTypeDesignationWorkingsetAdd(TypeDesignationWorkingsetEditorAction event) method where the reference of the RegistrationWorkingset (e.g. Article) is passed to the type designation workingset:

identifierSet = new TypeDesignationWorkingsetEditorIdSet(
        event.getRegistrationUuid(),
        getView().getCitationUuid(), // FIXME This may pass the reference (e.g. Article) from RegistrationWorkingsetView
                    // to the TypeDesignationWorkingset even if the nomenclatural act is a Section !!! --> #9290
        typifiedNameUuid
        );

The SpecimenTypeDesignationWorkingSetServiceImpl.save(SpecimenTypeDesignationWorkingSetDTO<? extends VersionableEntity> dto) in erroneously saves the citation with each of the SpecimenTypeDesignations.

This is the cause for in inconsistend data which has been shown in the Excel sheet.

For a solution to this problem the following is needed:

  1. 'SpecimenTypeDesignationWorkingSetServiceImpl.save(SpecimenTypeDesignationWorkingSetDTO<? extends VersionableEntity> dto)': Stop setting the citation before saving.
  2. If the citation is somehow really for the workflow and there is no way to chanage this, we should rather pass the registration reference in RegistrationWorkingsetPresenter.onTypeDesignationWorkingsetAdd(TypeDesignationWorkingsetEditorAction event)
  3. SpecimenTypeDesignationEditor: Add fields for citation and citationDetail --> #9301

TaxonName and Typedesignation citations unequal_diff.xlsx (163 KB) Andreas Kohlbecker, 11/13/2020 04:35 PM


Related issues

Related to Edit - task #9291: Clear all unnecesary TypeDesignation.citation entities and citationDetails New 11/10/2020
Related to Edit - feature request #9301: SpecimenTypeDesignationEditor: Add fields for citation and citationDetail Resolved 11/13/2020
Related to Edit - bug #9302: Phycobank related issues for TypeDesignation formatting In Progress 11/14/2020
Related to Edit - task #9308: Supress "designated by" reference in portal in registration ListView and RegistrationWorkingSetEditor New 11/16/2020

Associated revisions

Revision da219650 (diff)
Added by Andreas Kohlbecker 2 months ago

ref #9290 comment on typdesignation citation problem

Revision 508b8f01 (diff)
Added by Andreas Kohlbecker 3 days ago

ref #9290 NameTypeDesignationEditor now using designation reference correctly

Revision 91e53109 (diff)
Added by Andreas Kohlbecker 2 days ago

ref #9290 SpecimenTypeDesignationEditor now using designation reference correctly

Revision cc9c04a4 (diff)
Added by Andreas Kohlbecker 2 days ago

ref #9290 cleaning up

Revision 0b71a670 (diff)
Added by Andreas Kohlbecker 2 days ago

ref #9290 making TypeDesignationWorkingsetEditorIdSet --> TypeDesignationWorkingsetIds more clear

Revision d7d6bc83 (diff)
Added by Andreas Kohlbecker 2 days ago

ref #9290 making TypeDesignationWorkingsetEditorIdSet --> TypeDesignationWorkingsetIds more clear

Revision c27b3a19 (diff)
Added by Andreas Kohlbecker 2 days ago

ref #9290 castTo method for TypedEntityReference

History

#1 Updated by Andreas Kohlbecker 2 months ago

  • Related to task #9291: Clear all unnecesary TypeDesignation.citation entities and citationDetails added

#2 Updated by Andreas Kohlbecker 2 months ago

  • Description updated (diff)

#3 Updated by Andreas Kohlbecker 2 months ago

  • Description updated (diff)

#4 Updated by Andreas Kohlbecker 2 months ago

  • Description updated (diff)

#5 Updated by Andreas Kohlbecker 2 months ago

  • Description updated (diff)

#6 Updated by Andreas Kohlbecker 2 months ago

Update to the Excel file.

Now the reference type is also shown.

"Irregular" Reference Types are highlighted.

#7 Updated by Andreas Kohlbecker 2 months ago

  • File deleted (TaxonName and Typedesignation citations unequal_diff.xlsx)

#8 Updated by Andreas Kohlbecker 2 months ago

  • Related to feature request #9301: SpecimenTypeDesignationEditor: Add fields for citation and citationDetail added

#9 Updated by Andreas Kohlbecker 2 months ago

  • Description updated (diff)

#10 Updated by Andreas Müller 2 months ago

  • Related to bug #9302: Phycobank related issues for TypeDesignation formatting added

#11 Updated by Andreas Kohlbecker 2 months ago

  • Related to task #9308: Supress "designated by" reference in portal in registration ListView and RegistrationWorkingSetEditor added

#12 Updated by Andreas Kohlbecker 2 days ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

Hi Henning, could you please make some tests in the test-server to make sure the changes are not causing problems with exiting specimen- and name-type-designations and if creating new ones works well.

The "Citation"-field in the name type designation editor has been re-labeled to "Designation reference" in order to better clarify its purpose. Are you ok with this or do you prefer something else?

BTW: The "Designation reference" still cant be edited. this is subject to another ticket: #9301

#13 Updated by Andreas Kohlbecker 1 day ago

  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)