Project

General

Profile

bug #9230

Type in preparation of a published name displayed in PhycoBank Portal Name Page

Added by Wolf-Henning Kusber about 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib
Target version:
Start date:
09/24/2020
Due date:
% Done:

100%

Severity:
major
Found in Version:

Description

Similar problem to the already solved one with displayed unpublished names related to published names (#8328)

The problem: An old name was currently lectotypified.
Published name: Cymatopleura brunii P. Petit = http://phycobank.org/102573

Typification in preparation (Screen shot Vaadin, 1. record in preparation even though 2 article was published by the journal)
Typification shown in portal (Screen shot portal)

The portal view shows exactly the situation in Vaadin.

The workaround does not function: Postpone the publication date of the typifying publication.

picture235-1.png View (74.7 KB) Wolf-Henning Kusber, 09/24/2020 12:29 PM

picture235-2.png View (271 KB) Wolf-Henning Kusber, 09/24/2020 12:29 PM


Related issues

Related to Edit - bug #8328: Unpublished record visible in Portal if related name is published Closed 06/04/2019

Associated revisions

Revision b728050e (diff)
Added by Andreas Kohlbecker 11 months ago

ref #9230 implementing test for exposure of unpublished type designation

Revision cc665988 (diff)
Added by Andreas Kohlbecker 11 months ago

ref #9230 RegistrableEntityFilter to centralize filter functions

Revision 41dde72f (diff)
Added by Andreas Kohlbecker 11 months ago

ref #9230 RegistrableEntityFilter function for type designations and using it for all relevant controller methods

Revision 71152358 (diff)
Added by Andreas Kohlbecker 11 months ago

ref #9230 fixing bug in test assertion

History

#1 Updated by Andreas Kohlbecker about 1 year ago

  • Category set to cdmlib
  • Priority changed from New to Highest
  • Target version changed from Unassigned CDM tickets to Release 5.18

#2 Updated by Andreas Kohlbecker 11 months ago

  • Subject changed from Type in preparation of a published name displayed in PhycoBank Portal to Type in preparation of a published name displayed in PhycoBank Portal Name Page

#3 Updated by Andreas Kohlbecker 11 months ago

  • Tags changed from phycobank to phycobank, security

#4 Updated by Andreas Kohlbecker 11 months ago

  • Tags changed from phycobank, security to phycobank, security, permission

#5 Updated by Andreas Kohlbecker 11 months ago

  • Related to bug #8328: Unpublished record visible in Portal if related name is published added

#6 Updated by Andreas Kohlbecker 11 months ago

  • Description updated (diff)

#7 Updated by Andreas Kohlbecker 11 months ago

it is the portal/name/{uuid}/typeDesignations which misses to filter the entities

#8 Updated by Andreas Kohlbecker 11 months ago

  • Status changed from New to Resolved
  • Assignee changed from Andreas Kohlbecker to Wolf-Henning Kusber
  • % Done changed from 0 to 50

please review

#9 Updated by Wolf-Henning Kusber 11 months ago

  • % Done changed from 50 to 90

Checked this example. The issue is perfectly solved. Before we close the ticket, I want to find an example with mixed = published AND unpublished types.

#10 Updated by Wolf-Henning Kusber 11 months ago

  • Assignee changed from Wolf-Henning Kusber to Andreas Kohlbecker
  • % Done changed from 90 to 100

Gomphonemopsis ligowskii is published and has a holotype.
I inserted a unpublished test reference Kusber in Zeitschrift für Pfützenkunde and added an unpublished epitye.

The holotype is shown = correct
The unpublished epitype is NOT shown = correct.

The problem is solved, the ticket can be closed.

#11 Updated by Andreas Kohlbecker 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)