Project

General

Profile

Actions

task #9207

closed

update ehcache dependency and handle hibernate-ehcache

Added by Andreas Müller over 3 years ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Highest
Category:
cdmlib
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Tags:

Description

The latest version of ehcache-core is 3.8.1 but has a different groupId since version 3.0 so we need to check if this is still working together.

Also we should check if cdmlib-remote dependency hibernate-ehcache is really needed. It relates to the similar library ehcache (not -core) and therefore many classes are duplicated.
Removing hibernate-ehcache from maven pom does not create any compile problems.
=> seems to be fixed in the meanwhile, hibernate-ehcache is not a dependency anymore


Related issues

Related to EDIT - task #10218: Unify cache handling in CDM platformNewAndreas Müller

Actions
Related to EDIT - task #10055: Updates, upgrades and cleanup 2023NewAndreas Müller

Actions
Is duplicate of EDIT - task #10077: upgrade ehcache to 3.xNewAndreas Müller

Actions
Actions #1

Updated by Andreas Müller over 3 years ago

The different versions have different sizes. The old version net.sf.ehcache-core and the very new version org.ehcache have 9MB.

Therefore we should discuss if we really want to use net.sf.ehcache. Better we migrate cdmlib-cache to org.ehcache and keep net.sf.ehcache-core as long as it is referenced by any dependent library.
org.ehcache has completely new namespaces and a couple of changes. Therefore it is not compatible to any 2.x version at all.

Actions #2

Updated by Andreas Müller over 3 years ago

  • Status changed from New to In Progress
  • Target version changed from Unassigned CDM tickets to Release 5.18
Actions #3

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.18 to Release 5.19
Actions #4

Updated by Andreas Müller over 3 years ago

  • Target version changed from Release 5.19 to Release 5.21
Actions #5

Updated by Andreas Müller about 3 years ago

  • Target version changed from Release 5.21 to Release 5.22
Actions #6

Updated by Andreas Müller about 3 years ago

  • Target version changed from Release 5.22 to Release 5.46
Actions #7

Updated by Andreas Müller over 1 year ago

  • Related to task #10218: Unify cache handling in CDM platform added
Actions #8

Updated by Andreas Müller over 1 year ago

  • Description updated (diff)
  • % Done changed from 0 to 30
Actions #9

Updated by Andreas Müller over 1 year ago

  • Is duplicate of task #10077: upgrade ehcache to 3.x added
Actions #10

Updated by Andreas Müller over 1 year ago

  • Tags set to ehcache
  • Status changed from In Progress to Duplicate
  • % Done changed from 30 to 100
Actions #11

Updated by Andreas Müller over 1 year ago

  • Related to task #10055: Updates, upgrades and cleanup 2023 added
Actions #12

Updated by Andreas Müller 3 months ago

  • Target version deleted (Release 5.46)
Actions

Also available in: Atom PDF