Project

General

Profile

task #9189

Move datasource view to taxeditor.local

Added by Andreas Müller 7 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
08/13/2020
Due date:
% Done:

100%

Severity:
normal

Description

As the datasource view is only needed for local mgd. it can be moved to taxeditor.webapp

This way maybe the datasource dependencies can be used from taxeditor.webapp too and can be removed in taxeditor.cdmlib.

Also when handling taxeditor.webapp as loadable plugin these dependencies are not needed at all anymore.

This also includes the dialogues opened within the datasource view.

Problems need to be solved:

after moving all datasource/managed server related classes results in problems concerning the login dialog because it uses these classes.

Therefore we need another login dialog containing the managed server in webapp which is used when the webapp plugin is loaded.

picture929-1.png View (3.75 KB) Andreas Müller, 12/01/2020 11:12 AM


Related issues

Related to Edit - feature request #5752: Reduce TaxEditor size Closed 05/24/2016
Related to Edit - feature request #9154: Further reduce TaxEditor size by cleaning up dependencies and making taxeditor.webapp plugin optional New 07/15/2020
Related to Edit - task #9119: Remove schema create and schema update functionality from datsource view Closed 07/02/2020
Related to Edit - feature request #9190: Make taxeditor.local a loadable plugin not installed by default In Progress 08/13/2020
Related to Edit - feature request #9204: Update cdmlib and taxeditor dependencies Closed 08/20/2020

Associated revisions

Revision 192243b3 (diff)
Added by Katja Luther 6 months ago

ref #9189: move datasource to webapp

Revision 8dde8e84 (diff)
Added by Katja Luther 6 months ago

ref #9189: move datasource to webapp - continue

Revision b33b7c33 (diff)
Added by Katja Luther 6 months ago

ref #9189: move datasource to webapp - adapt manifest files

Revision 500c500e (diff)
Added by Katja Luther 6 months ago

ref #9189: move datasource to webapp - adapt manifest files

Revision 5c44e322 (diff)
Added by Katja Luther 3 months ago

ref #9189: harmonize l10n files

Revision 73192ab3 (diff)
Added by Andreas Müller 3 months ago

ref #9204 remove some cdmlib-dbs from git and upgrade postgresql version

Revision 8a79d625 (diff)
Added by Andreas Müller 3 months ago

ref #9204 add jtds and mssql-jdbc-8.4.1.jre8 to gitignore

Revision 47d8963b (diff)
Added by Andreas Müller 3 months ago

ref #9204 remove postgresql and mysql connector from taxeditor.cdmlib pom

Revision 4e6b7379 (diff)
Added by Andreas Müller 3 months ago

ref #9204 remove postgresql and mysql connector from taxeditor.cdmlib pom (cont.)

Revision 99996219 (diff)
Added by Andreas Müller 3 months ago

ref #9204 remove H2, postgresql and mysql fully from taxeditor.cdmlib

Revision 9306fdac (diff)
Added by Andreas Müller 3 months ago

ref #4866, ref #9228 preliminary revert moving h2, postgresql and mysql from cdmlib to local and include mchange-commons-java in cdmlib

Revision ca0e1f12 (diff)
Added by Andreas Müller 3 months ago

ref #4866, ref #9228 fix postgresql version number and add to gitignore

Revision e796e4aa (diff)
Added by Katja Luther 3 months ago

ref #9189: move new menu item to the top

History

#1 Updated by Andreas Müller 7 months ago

#2 Updated by Andreas Müller 7 months ago

  • Related to feature request #9154: Further reduce TaxEditor size by cleaning up dependencies and making taxeditor.webapp plugin optional added

#3 Updated by Andreas Müller 7 months ago

  • Related to task #9119: Remove schema create and schema update functionality from datsource view added

#4 Updated by Katja Luther 7 months ago

  • Target version changed from Release 5.18 to Release 5.19

#5 Updated by Andreas Müller 7 months ago

  • Target version changed from Release 5.19 to Release 5.18

#6 Updated by Andreas Müller 6 months ago

  • Related to feature request #9190: Make taxeditor.local a loadable plugin not installed by default added

#7 Updated by Andreas Müller 6 months ago

#8 Updated by Andreas Müller 6 months ago

  • Priority changed from New to Highest

#9 Updated by Katja Luther 6 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

#10 Updated by Katja Luther 5 months ago

  • Status changed from In Progress to Resolved

#11 Updated by Andreas Müller 4 months ago

Is this for review?

#12 Updated by Katja Luther 3 months ago

yes, please check whether everything still works.

#13 Updated by Katja Luther 3 months ago

  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 0 to 60

#14 Updated by Andreas Müller 3 months ago

Title translations are missing:

#15 Updated by Andreas Müller 3 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

The "New" button is missing.

#16 Updated by Andreas Müller 3 months ago

The finish button does not seem to work anymore (when using clone).

#17 Updated by Katja Luther 3 months ago

Andreas Müller wrote:

The "New" button is missing.

Shouldn't the new button should be removed in #9119?

#18 Updated by Andreas Müller 3 months ago

Entering a name (or other information) now is very fast. It was slow before because I think there was always done some duplication check after each key stroke. It is good that it is faster now but I am afraid some functionality got lost.

#19 Updated by Andreas Müller 3 months ago

Katja Luther wrote:

Andreas Müller wrote:

The "New" button is missing.

Shouldn't the new button should be removed in #9119?

#9119 is about schema create and update, not about create new datasource.
Also it was closed in 5.17 but in 5.17 the New button still existed.

#20 Updated by Katja Luther 3 months ago

Andreas Müller wrote:

Entering a name (or other information) now is very fast. It was slow before because I think there was always done some duplication check after each key stroke. It is good that it is faster now but I am afraid some functionality got lost.

if a database with same name already exist, you get a message and it is not possible to finish

#21 Updated by Katja Luther 3 months ago

Andreas Müller wrote:

Katja Luther wrote:

Andreas Müller wrote:

The "New" button is missing.

Shouldn't the new button should be removed in #9119?

#9119 is about schema create and update, not about create new datasource.
Also it was closed in 5.17 but in 5.17 the New button still existed.

sorry, I added the menu item again.

#22 Updated by Katja Luther 3 months ago

Andreas Müller wrote:

The finish button does not seem to work anymore (when using clone).

This is caused by java.lang.NoClassDefFoundError: com/mchange/v2/ser/Indirector, this is only the case for mysql databases, for h2 it works as expected.

#23 Updated by Andreas Müller 3 months ago

Katja Luther wrote:

Andreas Müller wrote:

The finish button does not seem to work anymore (when using clone).

This is caused by java.lang.NoClassDefFoundError: com/mchange/v2/ser/Indirector, this is only the case for mysql databases, for h2 it works as expected.

Looks like mchange-commons-java is missing (https://stackoverflow.com/questions/28977313/caused-byjava-lang-noclassdefrounderrorcom-mchange-v2-ser-indirector). I will try to fix this in dependencies.

#24 Updated by Andreas Müller 3 months ago

Katja Luther wrote:

Andreas Müller wrote:

The finish button does not seem to work anymore (when using clone).

This is caused by java.lang.NoClassDefFoundError: com/mchange/v2/ser/Indirector, this is only the case for mysql databases, for h2 it works as expected.

The dependency mchange-commons-java which includes com/mchange/v2/ser/Indirector definetely exists for taxeditor.local. Can you please check the stacktrace which class loader tries to use it. So can you provide the full stack trace.

Also the question is why the exception is swallowed. Shouldn't it be thrown?

#25 Updated by Katja Luther 3 months ago

Andreas Müller wrote:

Katja Luther wrote:

Andreas Müller wrote:

The finish button does not seem to work anymore (when using clone).

This is caused by java.lang.NoClassDefFoundError: com/mchange/v2/ser/Indirector, this is only the case for mysql databases, for h2 it works as expected.

The dependency mchange-commons-java which includes com/mchange/v2/ser/Indirector definetely exists for taxeditor.local. Can you please check the stacktrace which class loader tries to use it. So can you provide the full stack trace.

Also the question is why the exception is swallowed. Shouldn't it be thrown?

The exception is catched in rcp code (Window.class), there is no stacktrace but the detail message is: "com.mchange.v2.ser.Indirector cannot be found by eu.etaxonomy.taxeditor.cdmlib_5.18.0.qualifier"

and the classLoader is EquinoxClassLoader

#26 Updated by Andreas Müller 3 months ago

Katja Luther wrote:

Andreas Müller wrote:

Katja Luther wrote:
and the classLoader is EquinoxClassLoader

Equinox is probably the Classloader for all. What I meant is, to wich module does it belong, taxeditor.local, taxeditor.cdmlib or even another (do I understand correctly that each model has its own classloader?

#27 Updated by Andreas Müller 3 months ago

Katja Luther wrote:

Andreas Müller wrote:

Katja Luther wrote:

Andreas Müller wrote:

The "New" button is missing.
...
sorry, I added the menu item again.

Can you move it to the top. That is where it was before.

done

#28 Updated by Andreas Müller 3 months ago

  • Subject changed from Move datasource view to taxeditor.webapp to Move datasource view to taxeditor.local

#29 Updated by Andreas Müller 3 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 60 to 100

This works now but there are still open issues to solve before all cdmlib-db stuff can fully migrate to taxeditor.local. Handled in #9341

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)