Project

General

Profile

Actions

bug #9171

closed

Doubtful taxa are not found in bulkeditor

Added by Katja Luther about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Severity:
normal
Found in Version:

Description

merkwürdig. Ich bin im Bulk Editor für Taxa und suche (eigentlich) nach Obione chilensis. Folgendes Ergebnis:

Das Taxon wird nicht gefunden, dafür aber ein Synonym.
Ich habe noch nicht viel mit dem Taxon Bulkeditor gearbeitet – bearbeitet man da auch Synonyme? Da müssen wir dann mal über die Terminologie nachdenken.
Und warum wird Obione chilensis nicht gefunden? Vielleicht, weil das doubtful Flag im Details View gesetzt ist?
Tatsächlich! Das ist dann wirklich ein Bug!
Herzlichen Gruß
Walter


Files

picture912-1.png (15.4 KB) picture912-1.png Katja Luther, 07/30/2020 11:46 AM
Actions #1

Updated by Katja Luther about 2 years ago

  • Category set to taxeditor
  • Assignee set to Katja Luther
Actions #2

Updated by Katja Luther about 2 years ago

The search is based on the titleCache and the titleCache of doubtful taxa starts with "?", we should search on the titleCache of the taxon and of the name then we will find ?Obione chilensis.
A workaround could be to use '*' at the beginning.

Actions #3

Updated by Andreas Müller about 2 years ago

Katja Luther wrote:

The search is based on the titleCache and the titleCache of doubtful taxa starts with "?", we should search on the titleCache of the taxon and of the name then we will find ?Obione chilensis.
A workaround could be to use '*' at the beginning.

I am not sure which of the solutions is the correct one and which is the workaround. To me, searching on the name feels like the workaround. Generally we are searching here for taxa, not for pure names. So someone may search for 'Abies alba* sec. xyz*' and may not get a result with the first solution. While searching for 'Abies alba sec. xyz*' gives a solution. However, * is a bit too vague and maybe reduces performance. A better solution might be to search for both 'Abies alba* sec. xyz*' and '_Abies alba* sec. xyz*' or even '?Abies alba* sec. xyz*'. This is because I think there are no other cases of prefixes then the '?' case until now.

Actions #4

Updated by Andreas Müller about 2 years ago

  • Target version changed from Unassigned CDM tickets to Release 5.18

As this issue comes up from time to time I put it to the current milestone. Maybe oral discussion is needed.

Actions #5

Updated by Andreas Müller about 2 years ago

  • Description updated (diff)
Actions #6

Updated by Katja Luther about 2 years ago

  • Description updated (diff)
  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

this should be fixed, please review.

Actions #7

Updated by Andreas Müller about 2 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 0 to 50

Generally the search works now. But there are the following issues:

  • the overriden methods findByTitleWithRestrictions(...) and findByTitle(...) use pagers. The paging mechanism will not work correctly as far as I can see

  • discussion is needed how the ordering should work in the methods and in the UI. Should the "?" be included in the ordering or should the "?" be neglected for ordering

Actions #8

Updated by Andreas Müller about 2 years ago

  • Priority changed from New to Highest

Also the implementation for findByTitleWithRestrictions and findByTitle differs a bit in terms of handling "numberOfResults". As both algorithms need to be adapted to work correctly with paging (and sorting) this might be automatically solved.

Actions #9

Updated by Katja Luther about 2 years ago

Andreas Müller wrote:

Generally the search works now. But there are the following issues:

  • the overriden methods findByTitleWithRestrictions(...) and findByTitle(...) use pagers. The paging mechanism will not work correctly as far as I can see

  • discussion is needed how the ordering should work in the methods and in the UI. Should the "?" be included in the ordering or should the "?" be neglected for ordering

at the moment the ordering includes the "?" because it works on the titlecache.

Actions #10

Updated by Andreas Müller about 2 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 50 to 100

This works and can be closed.

Actions #11

Updated by Andreas Müller about 2 years ago

  • Target version changed from Release 5.18 to Release 5.17
Actions

Also available in: Atom PDF