Project

General

Profile

feature request #9137

IPTC Keywords (and maybe other information) is not shown in Universal Viewer yet

Added by Andreas Müller 27 days ago. Updated 22 days ago.

Status:
Resolved
Priority:
Highest
Category:
cdm-dataportal
Target version:
Start date:
07/09/2020
Due date:
% Done:

50%

Severity:
normal
Tags:

Description

The UV reads and displays most the EXIF metadata of an image. However, to me is not clear if this is also the case for IPTC meta data.

E.g. the file Bromus_fasciculatus_s_delilei_A1.jpg in cyprus has IPTC keywords which are not shown (and are not stored yet in the CDM). Also the IPTC copyright is missing while the EXIF copyright exists.

The IPTC keywords are most important as they store the really relevant information while most EXIF data is not needed at all (except for width and length).


Related issues

Related to Edit - task #5083: Alternative image viewer for dataportal Closed 07/13/2015
Related to Edit - feature request #8884: iiif manifest service: enrich metadata with information provided by other iiif image servers New 02/28/2020
Related to Edit - feature request #9153: Handle additional information in image metadata New 07/15/2020
Blocked by Edit - task #9148: Replace sanselan library by the newer apache commons-imaging Resolved 07/13/2020

Associated revisions

Revision 2e047df9 (diff)
Added by Andreas Müller 23 days ago

fix #9137 IPTC keywords read by CdmImageInfo

History

#1 Updated by Andreas Kohlbecker 26 days ago

  • Status changed from New to Feedback
  • Assignee changed from Andreas Kohlbecker to Andreas Müller

All image metadata (EXIF, IPTC, ...) is extracted by the cdmlib. The data portal only receives this data.
So the problem, if it exists, might be caused by the library reading the image metadata: eu.etaxonomy.cdm.common.media.ImageInfo.readMetaData(Integer timeOut)

#2 Updated by Andreas Müller 26 days ago

RH:

ihr schraubt noch an der Darstellung der Metadaten. Allerdings weiß ich nicht, wie weit Details diskutiert worden sind. Ich liste zwei Punkte auf, da ich nun immer wieder Bilder durchgemustert habe.

(1) Beim Öffnen von "more information" rechts sollten wie bisher die Basisdaten Taxon, Locality, Date, Photographer im Vordergrund stehen. Früher wurde das wunderschön komprimiert dargeboten. Das sollte also ganz oben in der Aufklappleiste stehen. In Absprache mit Dominik hatten wir seinerzeit bei den Keywords zu den Fotos vier Sparten fixiert, hierzu ein Beispiel:
Taxon: Bromus fasciculatus subsp. delilei
Locality: Cyprus, Antifonitis, 700 m SW of monastery
Date: 21.04.2019
Photographer: G. N. Hadjikyriakou

Man sollte auch diese vier Spartenüberschriften wieder übernehmen. Danach sollte man das Copyright mit dem Namen des Fotografen nochmals wiederholen. Auf den Rest könnte ich komplett verzichten.
Bisher ertrinken die Metadaten in allerlei Zahlensalat zur Technik der Kameras, wenn solche Daten abgegriffen werden können. Wir möchten Wissenschaft darbieten, der Technikkram interessiert doch keinen. Manche Fotografen dürfte es sogar verstören, wenn all diese "intimen" Details ausgebreitet werden. Kurz und knackig wie bisher wäre wünschenswert.

(2) Datum: Das korrekte Aufnahmedatum wird immer bei den Metadaten eingegeben. Offenbar greift die Maschine vorrangig Daten der Kamera ab, zeigt auch völlig überflüssig die Uhrzeit an, was es sehr unübersichtlich macht. Hier müsste die Metadaten-Eingabe vorrangig sein, weil die Kameradaten oft nicht stimmen.

Es wäre fein, wenn nach dem Motto "weniger ist mehr" das Dickicht etwas ausgelichtet werden könnte.

#3 Updated by Andreas Müller 26 days ago

  • Related to task #5083: Alternative image viewer for dataportal added

#4 Updated by Andreas Kohlbecker 23 days ago

  • Related to feature request #8884: iiif manifest service: enrich metadata with information provided by other iiif image servers added

#5 Updated by Andreas Kohlbecker 23 days ago

  • Tags set to image-viewer

#6 Updated by Andreas Müller 23 days ago

  • Blocked by task #9148: Replace sanselan library by the newer apache commons-imaging added

#7 Updated by Andreas Müller 23 days ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 50

#8 Updated by Andreas Müller 22 days ago

  • Assignee changed from Andreas Müller to Andreas Kohlbecker
  • Priority changed from New to Highest

I hope this is fixed now. Can you please review?

#9 Updated by Andreas Müller 21 days ago

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)