Project

General

Profile

bug #9113

NPE when deleting classification

Added by Katja Luther 12 days ago. Updated 12 days ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
06/30/2020
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

mail AM:

Hallo,

Beim Löschen einer Classification habe ich den Fehler unten bekommen. Im Code unten wurde wohl kein Parent gefunden, obwohl eine ParentUuid existiert.

last remote method : http://localhost:8080/remoting/taxonnode.service
last remote request client time : 2020-06-28T16:02:58.615
last remote request response header time : Sun, 28 Jun 2020 16:02:58 +0200
client error time : 2020-06-28T16:02:58.63
login : admin
editor version : 5.16.0.qualifier
server : localhost (localhost-dev)
schema version : 5.15.2.0.20200611
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
      at org.eclipse.swt.SWT.error(SWT.java:4533)
      at org.eclipse.swt.SWT.error(SWT.java:4448)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
      at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
      at eu.etaxonomy.taxeditor.Application.start(Application.java:20)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:498)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
      at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Caused by: java.lang.NullPointerException
      at eu.etaxonomy.cdm.persistence.dto.TaxonNodeDto.<init>(TaxonNodeDto.java:83)
      at eu.etaxonomy.cdm.persistence.dto.TaxonNodeDto.<init>(TaxonNodeDto.java:75)
      at eu.etaxonomy.taxeditor.util.TaxonTreeNodeContentProvider.getParent(TaxonTreeNodeContentProvider.java:74)
      at org.eclipse.jface.viewers.AbstractTreeViewer.getParentElement(AbstractTreeViewer.java:1704)
      at org.eclipse.jface.viewers.TreeViewer.getParentElement(TreeViewer.java:558)
      at org.eclipse.jface.viewers.AbstractTreeViewer.internalExpand(AbstractTreeViewer.java:1631)
      at org.eclipse.jface.viewers.AbstractTreeViewer.setExpandedElements(AbstractTreeViewer.java:2410)
      at eu.etaxonomy.taxeditor.navigation.navigator.e4.TaxonNavigatorE4.onChange(TaxonNavigatorE4.java:583)
      at eu.etaxonomy.taxeditor.store.CdmUIDataChangeService$2.run(CdmUIDataChangeService.java:44)
      at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:233)
      at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:145)
      at org.eclipse.swt.widgets.Display.syncExec(Display.java:4821)
      at eu.etaxonomy.taxeditor.store.CdmUIDataChangeService.fireChangeEvent(CdmUIDataChangeService.java:41)
      at eu.etaxonomy.taxeditor.operation.RemotingCdmOperation.fireDataChangeEvent(RemotingCdmOperation.java:70)
      at eu.etaxonomy.taxeditor.operation.RemotingCdmUpdateOperation.postExecute(RemotingCdmUpdateOperation.java:78)
      at eu.etaxonomy.taxeditor.operation.RemotingCdmOperation.execute(RemotingCdmOperation.java:51)
      at eu.etaxonomy.taxeditor.model.AbstractUtility.lambda$4(AbstractUtility.java:200)
      at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:162)
      at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:154)
      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
      ... 24 more

Associated revisions

Revision 687bfc97 (diff)
Added by Katja Luther 13 days ago

avoid NPE and fix closing of obsolete editors when deleting classification

History

#1 Updated by Katja Luther 12 days ago

  • Status changed from New to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

please review

#2 Updated by Katja Luther 12 days ago

  • % Done changed from 0 to 50

#3 Updated by Andreas Müller 12 days ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

This is fixed.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)