Project

General

Profile

bug #9112

Widget is disposed when closing factual data view

Added by Katja Luther 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
06/30/2020
Due date:
% Done:

100%

Severity:
normal
Found in Version:

Description

mail WB:

Hallo, nach dem Schließen des Fact-views nach Eingabe einer Citation beim Speichern des Taxons. Der neue Fact wurde nicht gespeichert.
HG
W

last remote method : http://api.cybertaxonomy.org:80/caryophyllales_spp/remoting/name.service
last remote request client time : 2020-06-26T08:46:34.627
last remote request response header time : Fri, 26 Jun 2020 08:46:34 GMT
client error time : 2020-06-26T08:47:01.063
login : w.berendsohn
editor version : 5.15.0
server : api.cybertaxonomy.org (cybertaxonomy.org) / caryophyllales_spp
schema version : 5.15.2.0.20200611
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.e4.core.di.InjectionException: org.eclipse.swt.SWTException: Widget is disposed
                at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:65)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:247)
                at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:90)
                at org.eclipse.e4.ui.internal.workbench.PartServiceSaveHandler.save(PartServiceSaveHandler.java:57)
                at org.eclipse.ui.internal.WorkbenchWindow$7.save(WorkbenchWindow.java:594)
                at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.savePart(PartServiceImpl.java:1390)
                at eu.etaxonomy.taxeditor.workbench.SaveHandler.execute(SaveHandler.java:38)
                at sun.reflect.GeneratedMethodAccessor135.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                at java.lang.reflect.Method.invoke(Method.java:498)
                at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
                at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
                at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:132)
                at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:152)
                at org.eclipse.core.commands.Command.executeWithChecks(Command.java:494)
                at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
                at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:210)
                at org.eclipse.e4.ui.workbench.renderers.swt.HandledContributionItem.executeItem(HandledContributionItem.java:433)
                at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem.handleWidgetSelection(AbstractContributionItem.java:454)
                at org.eclipse.e4.ui.workbench.renderers.swt.AbstractContributionItem$3.handleEvent(AbstractContributionItem.java:482)
                at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
                at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4418)
                at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
                at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4236)
                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3824)
                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
                at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
                at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
                at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
                at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
                at eu.etaxonomy.taxeditor.Application.start(Application.java:20)
                at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                at java.lang.reflect.Method.invoke(Method.java:498)
                at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
                at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
                at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: org.eclipse.swt.SWTException: Widget is disposed
                at org.eclipse.swt.SWT.error(SWT.java:4533)
                at org.eclipse.swt.SWT.error(SWT.java:4448)
                at org.eclipse.swt.SWT.error(SWT.java:4419)
                at org.eclipse.swt.widgets.Widget.error(Widget.java:482)
                at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:354)
                at org.eclipse.swt.widgets.Tree.getSelection(Tree.java:3472)
                at org.eclipse.jface.viewers.TreeViewer.getSelection(TreeViewer.java:228)
                at org.eclipse.jface.viewers.TreeViewer.setSelection(TreeViewer.java:299)
                at org.eclipse.jface.viewers.AbstractTreeViewer.setSelectionToWidget(AbstractTreeViewer.java:2533)
                at org.eclipse.jface.viewers.AbstractTreeViewer.setSelectionToWidget(AbstractTreeViewer.java:2989)
                at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1465)
                at org.eclipse.jface.viewers.TreeViewer.preservingSelection(TreeViewer.java:354)
                at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1419)
                at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1519)
                at org.eclipse.jface.viewers.ColumnViewer.refresh(ColumnViewer.java:523)
                at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1478)
                at eu.etaxonomy.taxeditor.editor.view.descriptive.e4.FactualDataPartE4.changed(FactualDataPartE4.java:213)
                at eu.etaxonomy.taxeditor.view.e4.AbstractCdmEditorPartE4.postOperation(AbstractCdmEditorPartE4.java:355)
                at eu.etaxonomy.taxeditor.operation.AbstractPostOperation.postExecute(AbstractPostOperation.java:77)
                at eu.etaxonomy.taxeditor.editor.view.descriptive.operation.DeleteDescriptionElementOperation.execute(DeleteDescriptionElementOperation.java:75)
                at eu.etaxonomy.taxeditor.editor.e4.TaxonEditorInputE4.merge(TaxonEditorInputE4.java:374)
                at eu.etaxonomy.taxeditor.editor.name.e4.TaxonNameEditorE4.save(TaxonNameEditorE4.java:419)
                at sun.reflect.GeneratedMethodAccessor132.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                at java.lang.reflect.Method.invoke(Method.java:498)
                at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)

Associated revisions

Revision ffb73e56 (diff)
Added by Katja Luther 4 months ago

avoid widget is disposed exception

History

#1 Updated by Katja Luther 4 months ago

  • Category set to taxeditor
  • Status changed from New to Resolved
  • Assignee set to Andreas Müller
  • Target version changed from Unassigned CDM tickets to Release 5.16
  • % Done changed from 0 to 70

please review or close the ticket.

#2 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 70 to 100

Don't know if this is easy to reproduce. But I did not get an exception when closing the facts view.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)