Project

General

Profile

bug #9035

Reference details view throws NPE

Added by Andreas Müller 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Highest
Category:
taxeditor
Target version:
-
Start date:
05/27/2020
Due date:
% Done:

100%

Severity:
blocker
Found in Version:

Description

Using the reference bulk editor is not possible because when clicking on any reference the following NPE is thrown (probably when calculating the reference details view):

last remote method : http://test.e-taxonomy.eu:80/cdmserver/rem_conf_am/remoting/common.service
last remote request client time : 2020-05-27T19:49:53.088
last remote request response header time : Wed, 27 May 2020 19:49:53 GMT
client error time : 2020-05-27T19:49:53.323
login : admin
editor version : 5.15.0.202005271502
server : test.e-taxonomy.eu (edit-test) / rem_conf_am
schema version : 5.15.0.0.20200510
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
    at org.eclipse.swt.SWT.error(SWT.java:4533)
    at org.eclipse.swt.SWT.error(SWT.java:4448)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.NullPointerException
    at org.eclipse.ui.forms.widgets.TableWrapLayout.calculateColumnWidths(TableWrapLayout.java:772)
    at org.eclipse.ui.forms.widgets.TableWrapLayout.internalGetMinimumWidth(TableWrapLayout.java:715)
    at org.eclipse.ui.forms.widgets.TableWrapLayout.layout(TableWrapLayout.java:241)
    at org.eclipse.swt.widgets.Composite.updateLayout(Composite.java:1386)
    at org.eclipse.swt.widgets.Composite.updateLayout(Composite.java:1371)
    at org.eclipse.swt.widgets.Composite.layout(Composite.java:725)
    at org.eclipse.swt.widgets.Composite.layout(Composite.java:676)
    at org.eclipse.ui.forms.widgets.SizeCache.layoutIfNecessary(SizeCache.java:526)
    at org.eclipse.ui.forms.widgets.SizeCache.setBounds(SizeCache.java:512)
    at org.eclipse.ui.forms.widgets.ExpandableComposite$ExpandableLayout.layout(ExpandableComposite.java:385)
    at org.eclipse.swt.widgets.Composite.updateLayout(Composite.java:1386)
    at org.eclipse.swt.widgets.Composite.updateLayout(Composite.java:1371)
    at org.eclipse.swt.widgets.Composite.layout(Composite.java:725)
    at org.eclipse.swt.widgets.Composite.layout(Composite.java:676)
    at org.eclipse.swt.widgets.Composite.layout(Composite.java:632)
    at org.eclipse.ui.forms.widgets.ExpandableComposite.setText(ExpandableComposite.java:826)
    at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailSection.setText(AbstractCdmDetailSection.java:84)
    at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailSection.setSectionTitle(AbstractCdmDetailSection.java:185)
    at eu.etaxonomy.taxeditor.ui.section.AbstractCdmDetailSection.setEntity(AbstractCdmDetailSection.java:157)
    at eu.etaxonomy.taxeditor.view.detail.CdmSectionPart.setFormInput(CdmSectionPart.java:167)
    at org.eclipse.ui.forms.ManagedForm.setInput(ManagedForm.java:210)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmDataViewerE4.refresh(AbstractCdmDataViewerE4.java:162)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmDataViewerE4.setInput(AbstractCdmDataViewerE4.java:143)
    at eu.etaxonomy.taxeditor.view.e4.details.DetailsViewerE4.setInput(DetailsViewerE4.java:202)
    at eu.etaxonomy.taxeditor.view.e4.details.DetailsViewerE4.setInput(DetailsViewerE4.java:173)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmEditorPartE4.showViewer(AbstractCdmEditorPartE4.java:284)
    at eu.etaxonomy.taxeditor.view.e4.details.DetailsPartE4.selectionChanged_internal(DetailsPartE4.java:107)
    at eu.etaxonomy.taxeditor.view.e4.AbstractCdmEditorPartE4$DelaySelection.run(AbstractCdmEditorPartE4.java:94)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
    ... 23 more

picture003-1.png View (4.72 KB) Andreas Müller, 05/27/2020 07:59 PM


Related issues

Blocks Edit - bug #8999: Verbatim date not persisted for books Closed 05/05/2020
Blocks Edit - feature request #8988: Add link button to DOI field for references Closed 04/29/2020

Associated revisions

Revision ffeb89d3 (diff)
Added by Katja Luther 4 months ago

fix #9035: fix NPE in reference details

History

#1 Updated by Andreas Müller 4 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

As this is a serious regression it needs to be fixed asap.

#2 Updated by Andreas Müller 4 months ago

A similar error occurs when trying to edit the reference via the editing dialog (e.g. when opening the nomenclatural reference of a name).

#3 Updated by Andreas Müller 4 months ago

Also in the nom. ref. label field the reference does not appear anymore. Don't know if this is related:

#4 Updated by Andreas Müller 4 months ago

  • Blocks bug #8999: Verbatim date not persisted for books added

#5 Updated by Andreas Müller 4 months ago

#6 Updated by Katja Luther 4 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 50

#7 Updated by Katja Luther 4 months ago

  • Assignee changed from Katja Luther to Andreas Müller
  • % Done changed from 50 to 0

this should be fixed, please review

#8 Updated by Katja Luther 4 months ago

  • % Done changed from 0 to 50

#9 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Closed
  • Target version deleted (Release 5.15)
  • % Done changed from 50 to 100

This is fixed. As it was only a temporary regression during 5.15 development I remove the target version.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)