Project

General

Profile

feature request #9032

Implement Feature.availableFor in TaxEditor

Added by Andreas Müller 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
05/26/2020
Due date:
% Done:

90%

Severity:
normal

Description

The alternatives should be available as checkboxes in the Feature details view similar to supportsXXX.

Also the values should be evaluated when suggesting features in the factual data view for taxa, specimen and names or elsewhere where features are suggested. This will remove the current implementation which checks for certain vocabularies (which is a workaround).

For details see also #9027


Related issues

Related to Edit - bug #9070: Adapt preference page to feature.isAvailableFor... Resolved 06/15/2020
Related to Edit - feature request #9079: Move supported and available for parts of feature detail element to sections New 06/18/2020
Follows Edit - feature request #9027: Implement Feature.availableFor Closed 05/24/2020

Associated revisions

Revision 25c76819 (diff)
Added by Katja Luther 5 months ago

ref #9032: add available for in feature details view

Revision 5499d5e4 (diff)
Added by Katja Luther 5 months ago

ref #9032: fix isAvailableForTaxon

Revision 7cbd337d (diff)
Added by Katja Luther 5 months ago

ref #9032: adapt featureTree creation to isAvailableFor

Revision 62d28a57 (diff)
Added by Katja Luther 5 months ago

ref #9032: add FeatureDto

Revision 51788caf (diff)
Added by Katja Luther 5 months ago

ref #9032: add FeatureDto - continue

Revision 5edd1fbf (diff)
Added by Katja Luther 5 months ago

fix #9040: implement service/persistent methods to get featureDtos fitting to availableFor param

Revision 8b643532 (diff)
Added by Katja Luther 5 months ago

fix #9040: adapt preferences to availableFor attribute of features

Revision 45f81765 (diff)
Added by Katja Luther 5 months ago

fix #9032: layout issues in feature details view

Revision 83cb55ca (diff)
Added by Katja Luther 5 months ago

ref #9032: label can set to bold

History

#1 Updated by Andreas Müller 5 months ago

  • Due date set to 05/25/2020
  • Start date changed from 05/26/2020 to 05/25/2020
  • Follows feature request #9027: Implement Feature.availableFor added

#2 Updated by Andreas Müller 5 months ago

  • Description updated (diff)
  • Due date deleted (05/25/2020)
  • Category changed from cdm to taxeditor
  • Start date changed from 05/25/2020 to 05/26/2020

#3 Updated by Katja Luther 5 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

the details view and the featureTree creation is implemented, but the preference page needs to be adapted, because the term preference pages work with vocabularies.

Therefore the contentProvider for the treeViewer needs to be adapted.

#4 Updated by Katja Luther 5 months ago

Katja Luther wrote:

the details view and the featureTree creation is implemented, but the preference page needs to be adapted, because the term preference pages work with vocabularies.

Therefore the contentProvider for the treeViewer needs to be adapted.

I create a new ticket for this and close this ticket. (#9070)

#5 Updated by Katja Luther 5 months ago

  • Related to bug #9070: Adapt preference page to feature.isAvailableFor... added

#6 Updated by Andreas Müller 5 months ago

Is this ticket for review then?

#7 Updated by Katja Luther 5 months ago

No, I just found a problem.

#8 Updated by Katja Luther 5 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Katja Luther to Andreas Müller

#9 Updated by Katja Luther 5 months ago

Katja Luther wrote:

No, I just found a problem.

the problem is fixed, please review.

#10 Updated by Andreas Müller 5 months ago

Generally it seems to work.

One issue I found:

  • I changed "Orthography to be available for Taxon, not Taxon name".
  • In Facts View I added an orthography fact to a taxon => the new fact was not shown in the facts view

Reopening the taxon did also no show the new fact.
Restarting the TaxEditor did finally show the fact, so it was saved but there was probably a problem with the (default) feature tree used in the facts view not being synchronized.

#11 Updated by Andreas Müller 5 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther

#12 Updated by Andreas Müller 5 months ago

A minor issue for the layout of the term details view

We should maybe better distinguish the supportsXXX and availableForXXX cases by e.g. having headers for each section. This way we could also avoid repeating "Supports" and "Available for".

It could look like

Supports

..Text Data........ x
..Quantitative Data x
...

Available for

..Taxon....... x
..Taxon Name.. 0
..Occurrence.. x

#13 Updated by Andreas Müller 5 months ago

Minor note: can we move Categorical Data up just below Supports Text Data? This is because features for Categorical Data and Quantitative Data are much more often created then features for the remaining subclasses.

#14 Updated by Katja Luther 5 months ago

  • Status changed from Feedback to Resolved

#15 Updated by Katja Luther 5 months ago

  • Assignee changed from Katja Luther to Anton Güntsch

the layout issues are solved.

#16 Updated by Andreas Müller 5 months ago

  • Assignee changed from Anton Güntsch to Andreas Müller

#17 Updated by Andreas Müller 5 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 90

Looks much better now.

I just wonder if it is not maybe better to handle Supports and Available for also as Sections (they have a title by default), same as Media and some others.

But it is up to you to decide if this makes sense. It has definetely no high priority.

#18 Updated by Katja Luther 5 months ago

  • Related to feature request #9079: Move supported and available for parts of feature detail element to sections added

#19 Updated by Katja Luther 5 months ago

  • Status changed from Feedback to Closed

Andreas Müller wrote:

Looks much better now.

I just wonder if it is not maybe better to handle Supports and Available for also as Sections (they have a title by default), same as Media and some others.

But it is up to you to decide if this makes sense. It has definetely no high priority.

I would move this to a new ticket (#9079) and close this ticket.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)