Project

General

Profile

feature request #9023

option to start cdm webapp with hibernate.hbm2ddl.auto = create

Added by Andreas Kohlbecker 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Highest
Category:
cdmlib-remote
Target version:
Start date:
05/19/2020
Due date:
% Done:

100%

Severity:
normal

Description

in compliance with the existing start parameter cdm.forceSchemaUpdate which can be set as system parameter or ServletContext attribute the new option may be named cdm.forceSchemaCreate


UPDATE:

The new integration test profile can be run by

mvn integration-test -pl cdmlib-remote-webapp -Pdb-create

Associated revisions

Revision 5666c59e (diff)
Added by Andreas Kohlbecker 4 months ago

fix #9023 implementing stratup option cdm.forceSchemaCreate with integration test:
- CdmDatabaseException as RuntimeException for all sever db connection problems
- web service for CDM Metadata
- integration test for data base creation as optional maven profile

Revision 3b929c99 (diff)
Added by Andreas Kohlbecker 4 months ago

ref #9023 documentation on running the test profile

History

#1 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)
  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

#3 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from Closed to Resolved
  • % Done changed from 100 to 50

#4 Updated by Andreas Kohlbecker 4 months ago

running the integration tests from the parent project casues probelms:

mvn integration-test -pl cdmlib-remote-webapp -Pdb-create
Caused by: java.io.FileNotFoundException: class path resource [eu/etaxonomy/cdm/remote.xml] cannot be opened because it does not exist
    at org.springframework.core.io.ClassPathResource.getInputStream (ClassPathResource.java:172)
    at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions (XmlBeanDefinitionReader.java:330)
    at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions (XmlBeanDefinitionReader.java:304)
    at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions (AbstractBeanDefinitionReader.java:181)
    at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions (AbstractBeanDefinitionReader.java:217)
    at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.importBeanDefinitionResource (DefaultBeanDefinitionDocumentReader.java:223)

#5 Updated by Andreas Kohlbecker 4 months ago

prior running

mvn package -DskipTests

is needed

#6 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 50 to 100

this works now as expected

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)