Project

General

Profile

feature request #8972

integrate kml layers into map viewer

Added by Andreas Kohlbecker 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Highest
Category:
cdm-dataportal
Target version:
Start date:
04/22/2020
Due date:
% Done:

100%

Severity:
normal
Tags:
map


Related issues

Related to Edit - feature request #6113: webservice to expose FieldUnits related to a Taxon or TaxonName as KML and/or GML Closed 09/29/2016
Related to Edit - feature request #4257: specimen map should zoom to area of distribution Closed 09/10/2014
Related to Edit - bug #9097: specimen coordinate links in maps to geohack service broken Closed 06/25/2020
Related to Edit - bug #9099: placemark icon in kml map not clickable Resolved 06/25/2020
Copied to Edit - feature request #8993: suppress the map in name pages and registration pages if there are no locations to display: New 05/04/2020

Associated revisions

Revision c1fc969a (diff)
Added by Andreas Kohlbecker 4 months ago

ref #8972, ref #8855, ref #4488 using kml response to show specimen points in maps with data in balloon popups with links

Revision 2871509d (diff)
Added by Andreas Kohlbecker 4 months ago

ref #8972, ref #8855, ref #4488 modified representation of field units in balloons

Revision 7844642a (diff)
Added by Andreas Kohlbecker 4 months ago

ref #8972 switching type_designations_maps to kml

Revision 64f6df71 (diff)
Added by Andreas Kohlbecker 4 months ago

ref #4257, ref #8972 zooming map to kml layer feature bounds

Revision 108f1865 (diff)
Added by Andreas Kohlbecker 4 months ago

ref #4257, ref #8972 setting zoomToClosestLevel = false to prevent from hidden features in KML layers

Revision 43c5bf8b (diff)
Added by Andreas Kohlbecker 3 months ago

ref #8972 refactoring: moving map compose method into maps.inc and simplifying code

History

#1 Updated by Andreas Kohlbecker 4 months ago

  • Related to feature request #6113: webservice to expose FieldUnits related to a Taxon or TaxonName as KML and/or GML added

#2 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 50

#3 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#4 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)
  • % Done changed from 50 to 100

#5 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from Closed to In Progress
  • % Done changed from 100 to 60

#6 Updated by Andreas Kohlbecker 4 months ago

#7 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#8 Updated by Andreas Kohlbecker 4 months ago

  • Description updated (diff)

#9 Updated by Andreas Kohlbecker 4 months ago

  • Status changed from In Progress to Resolved

this is complete now. BUT it was necessary to set zoomToClosestLevel = false
Which as been introduced for #5683 with value TRUE,
but can cause feature to tbe hidden in KML layers.

Make sure that there are no probelms with the maps and the loading indicator in the flora of cuba for which this setting has been introduced originally.

#10 Updated by Andreas Kohlbecker 3 months ago

  • Description updated (diff)

#11 Updated by Andreas Kohlbecker 3 months ago

  • Description updated (diff)

#12 Updated by Andreas Kohlbecker 3 months ago

  • Copied to feature request #8993: suppress the map in name pages and registration pages if there are no locations to display: added

#13 Updated by Andreas Kohlbecker 3 months ago

  • Description updated (diff)
  • Status changed from Resolved to Closed
  • % Done changed from 60 to 100

no problems found in the flora cuba which could be caused by the change to the zoomToClosestLevel = false setting.

So we can consider this ticket as fully solved.

#14 Updated by Andreas Kohlbecker about 2 months ago

  • Related to bug #9097: specimen coordinate links in maps to geohack service broken added

#15 Updated by Andreas Kohlbecker about 1 month ago

  • Related to bug #9099: placemark icon in kml map not clickable added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)