Project

General

Profile

bug #8962

Handle widget is disposed after closing Supplemental Data View

Added by Andreas Müller 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
New
Assignee:
Category:
taxeditor
Target version:
Start date:
04/20/2020
Due date:
% Done:

100%

Severity:
blocker
Found in Version:

Description

WGB:
nach Schließen des Supplemental Data views.
Vorher: Synonym Wormia von Ancistrocladus Fokus auf Name gesetzt. Noch keinerlei Edits nach Öffnen der Instanz.

last remote method : http://api.cybertaxonomy.org:80/caryophyllales_spp/remoting/common.service
last remote request client time : 2020-04-20T04:56:02.093
last remote request response header time : Mon, 20 Apr 2020 04:56:02 GMT
client error time : 2020-04-20T04:56:16.464
login : w.berendsohn
editor version : 5.14.0
server : api.cybertaxonomy.org (cybertaxonomy.org) / caryophyllales_spp
schema version : 5.12.0.0.20191202
os : Windows Server 2012 R2 6.3 amd64
java : 1.8.0_121
org.eclipse.swt.SWTException: Failed to execute runnable (org.eclipse.swt.SWTException: Widget is disposed)
                at org.eclipse.swt.SWT.error(SWT.java:4533)
                at org.eclipse.swt.SWT.error(SWT.java:4448)
                at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
                at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4211)
                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3827)
                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
                at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
                at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
                at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
                at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
                at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
                at eu.etaxonomy.taxeditor.Application.start(Application.java:24)
                at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                at java.lang.reflect.Method.invoke(Method.java:498)
                at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
                at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
                at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: org.eclipse.swt.SWTException: Widget is disposed
                at org.eclipse.swt.SWT.error(SWT.java:4533)
                at org.eclipse.swt.SWT.error(SWT.java:4448)
                at org.eclipse.swt.SWT.error(SWT.java:4419)
                at org.eclipse.swt.widgets.Widget.error(Widget.java:482)
                at org.eclipse.swt.widgets.Widget.checkWidget(Widget.java:354)
                at org.eclipse.swt.widgets.Control.setEnabled(Control.java:3410)
                at org.eclipse.ui.forms.widgets.ExpandableComposite.setEnabled(ExpandableComposite.java:782)
                at eu.etaxonomy.taxeditor.view.e4.supplementaldata.SupplementalDataViewerE4.setEnabled(SupplementalDataViewerE4.java:209)
                at eu.etaxonomy.taxeditor.view.e4.supplementaldata.SupplementalDataPartE4.selectionChanged_internal(SupplementalDataPartE4.java:134)
                at eu.etaxonomy.taxeditor.view.e4.AbstractCdmEditorPartE4$DelaySelection.run(AbstractCdmEditorPartE4.java:94)
                at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
                at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
                ... 23 more

Associated revisions

Revision 6a56588d (diff)
Added by Katja Luther 5 months ago

fix #8962: check for disposed section

History

#1 Updated by Katja Luther 5 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Katja Luther 5 months ago

  • Assignee changed from Katja Luther to Andreas Müller
  • Severity changed from normal to blocker

please review

#3 Updated by Andreas Müller 4 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

I don't know how to review this exactly. The code looks ok as far as I can decide this.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)