Project

General

Profile

bug #8959

Moving a synonym to the homotypical group of the accepted taxon opens the context menu of the accepted taxon

Added by Andreas Müller 4 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Highest
Assignee:
Category:
taxeditor
Target version:
Start date:
04/20/2020
Due date:
% Done:

100%

Severity:
major
Found in Version:

Description

To reproduce:

  • open a taxon which has a heterotypic synonym
  • move this synonym to the homotypic group of the accepted taxon
  • right click on the now homotpyic synonym

=>

picture872-1.png View (6.81 KB) Andreas Müller, 04/20/2020 12:16 PM

picture836-1.png View (7.5 KB) Andreas Müller, 06/16/2020 07:15 PM


Related issues

Duplicated by Edit - bug #8593: Name editor: wrong context menu for synonyms Duplicate 10/15/2019

Associated revisions

Revision 764151af (diff)
Added by Katja Luther 4 months ago

fix #8959: set focus to synonym after moving synonym to other homotypic group

Revision 9d01ebe7 (diff)
Added by Katja Luther about 2 months ago

fix #8959: fix correct focus after move syn

History

#1 Updated by Katja Luther 4 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 50

#2 Updated by Katja Luther 4 months ago

  • Assignee changed from Katja Luther to Andreas Müller

Now the focus is set explicitly to the moved synonym, so the context menu should be correct. please review

#3 Updated by Andreas Müller 4 months ago

I did not review yet (editor is still building) but forgot to mention in the description that also removing a synonym from the homotypical group of the accepted taxon changes the menu of remaining homotypic synonym in a way that they seem to be heterotypic. Is this also expected to be fixed?

#4 Updated by Katja Luther 4 months ago

Andreas Müller wrote:

I did not review yet (editor is still building) but forgot to mention in the description that also removing a synonym from the homotypical group of the accepted taxon changes the menu of remaining homotypic synonym in a way that they seem to be heterotypic. Is this also expected to be fixed?

Yes, I think this should be fixed also.

#5 Updated by Andreas Müller 2 months ago

  • Assignee changed from Andreas Müller to Katja Luther
  • Severity changed from critical to major

The problem still exists if you directly click on the moved synonym. If you click on another name and back again the correct menu appears.
This is the same when moving a synonym into the homotypic group (of the accepted taxon) and when moving it out.

#6 Updated by Andreas Müller 2 months ago

  • Status changed from Resolved to Feedback

#7 Updated by Katja Luther 2 months ago

I can't reproduce it when starting from workspce, I will try it again with nightly build.

#8 Updated by Andreas Müller about 2 months ago

Did you try again? If not please pass the ticket back to me and I will try again.

#9 Updated by Katja Luther about 2 months ago

  • Assignee changed from Katja Luther to Andreas Müller

I tried an hour ago, but the test server was not available.

#10 Updated by Andreas Müller about 2 months ago

  • Assignee changed from Andreas Müller to Katja Luther

Now the test server is up again. Can you please try again?

#11 Updated by Katja Luther about 2 months ago

  • Assignee changed from Katja Luther to Andreas Müller

Katja Luther wrote:

I tried an hour ago, but the test server was not available.

I can't reproduce it with the nightly build.

#12 Updated by Andreas Müller about 2 months ago

Strange, the problem still exists for me:

#13 Updated by Andreas Müller about 2 months ago

  • Assignee changed from Andreas Müller to Katja Luther

What I did in rem_conf_am:

  • Open taxon "Test" in classification "Testklass"
  • Move heterotypic synonym Hetero syn Mill. to homotypic group of accepted taxon
  • Wait until everything is fully layouted
  • right click on the "Hetero syn Mill." => the above context menu appears

#14 Updated by Andreas Müller about 2 months ago

Andreas K., can you also check if you can reproduce this?

#15 Updated by Andreas Müller about 2 months ago

Andreas Müller wrote:

The problem still exists if you directly click on the moved synonym. If you click on another name and back again the correct menu appears.
This is the same when moving a synonym into the homotypic group (of the accepted taxon) and when moving it out.

When moving out I can not reproduce this anymore. The problem exists only when moving the synonym from a heterotypic group to the homotypic group.

#16 Updated by Katja Luther about 2 months ago

  • Assignee changed from Katja Luther to Andreas Kohlbecker

Andreas K., can you also check if you can reproduce this?

#17 Updated by Andreas Kohlbecker about 2 months ago

  • Assignee changed from Andreas Kohlbecker to Katja Luther

Katja Luther wrote:

Andreas K., can you also check if you can reproduce this?

Yes, this is reliably reproducible.

#18 Updated by Andreas Kohlbecker about 2 months ago

  • Related to bug #8593: Name editor: wrong context menu for synonyms added

#19 Updated by Andreas Kohlbecker about 2 months ago

I linked a tightly related issue: #8593

#20 Updated by Katja Luther about 2 months ago

  • Status changed from Feedback to Resolved

#21 Updated by Katja Luther about 2 months ago

  • Assignee changed from Katja Luther to Andreas Müller

Katja Luther wrote:

Applied in changeset taxeditor|9d01ebe78d471b0203107cc8ebaac5ead4f1b2ee.

this should be fixed now, please review.

#22 Updated by Katja Luther about 2 months ago

  • Related to deleted (bug #8593: Name editor: wrong context menu for synonyms)

#23 Updated by Katja Luther about 2 months ago

  • Duplicated by bug #8593: Name editor: wrong context menu for synonyms added

#24 Updated by Andreas Müller about 2 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Andreas Müller to Katja Luther
  • % Done changed from 50 to 100

Now it seems to work as expected

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 40 MB)